Suse 15 with Gnome (Dell D620) login problem and mouse slow+lag

Hi (first post on forum)

Opensuse version installation have quite easily worked in Dell D620 (centrino duo), but now there is some problems with Gnome desktop of Opensuse 15

  1. After installation of Gnome: when started, login window has no mouse cursor visible, but navigation works with keyboard so that password can be given and
    login is succesful (after login cursor mouse cursor comes visible).
  2. After login Gnome desktop is displayed normally, but mouse moves slowly/has lag and pointing defined point on screen is difficult. Checking processor load
    shows that both processors run near maximum limit.

In same laptop earlier opensuse 42.3 with Gnome worked well and current opensuse 15 with KDE also works ok.

I try to figure problem cause and search advice from forums earlier.

Welcome to openSUSE Forums. The major change for Leap 15 is that the GNOME desktop is using Wayland by default. It’s working fine for many users, but it’s still work in progress and maybe it’s not playing so nice with your graphics hardware for some reason. You might comparing the behaviour with running Gnome DE with Xorg instead. You can choose this option at the login screen.

Your graphics hardware details might be relevant here…

/usr/sbin/hwinfo --gfxcard

I also note that is an old laptop (circa ~2006?). How much memory does the machine have?

free

Hi,

Try to switch to Xorg from gdm menu.
I had the same problems with Wayland, Gnome 3.26 and a Nvidia card.
PS. Or from “/etc/gdm/custom.conf” uncomment “WaylandEnable=false”

Thanks for you all your help ( there was wayland process on )

Next works in this case as correction:

  1. restart
  2. log as default user, that screen suggests ( use return key as there is no mouse cursor )
  3. as login view opens navigate with tab to desktop list (gear-picture) and select from list “Gnome with Xorg”
  4. then give password (use tab to navigate as there is no mouse cursor)
  5. navigate with tab to sign in button, use return key to start login (there is no mouse cursor).
  6. after succesful login mouse cursor/pointer is visible and move Ok (there is no anymore wayland process in processes list)
  7. when next time started opensuse uses “Gnome with Xorg” as default.

There is still mouse cursor/pointer missing in login stage, but after login cursor/pointer is working and Gnome desktop
works Ok. Dell D620 ( memory 4GB) processor load also now stays under 60% in idle (no applications opened).

:slight_smile:

That reads like an improvement! :slight_smile:

The login screen (using GDM) is still running with Wayland. And apparently that’s a problem on your computer. You can maybe try the suggesting in reply #4 above (to change the “gdm” configuration). You could also try uninstalling “gnome-session-wayland” and then (after removing) lock that package (or mark it as “protected - do not modify” in Yast Software Management so that it never comes back.

After doing uncomment for row “WaylandEnable=false” on file “/etc/gdm/custom.conf” as reply #4 suggested
also login screen now has mouse cursor/pointer visible and using mouse/touchpad works as it should also in login. Additionally
on login window from desktop list (gear-picture) original “GNOME” selection was again selected (“Gnome with Xorg” was
not anymore on list at all after that). Processor load was about same 60% when “System monitor” on and just about 10% when “System monitor” not measuring processorload.

Here additional steps as done:
8) as prework do steps 1-7 of post #5 to get mouse pointer on desktop usable
9) restart and log in and start “Terminal”-app on desktop
10) on Terminal app start editor as root
>gnomesu gedit
11) open with editor file: /etc/gdm/custom.conf
12) there is propably commented (#) row
#WaylandEnable=false
and just edit it to (remove #-character)
WaylandEnable=false
13) save file.
14) close editor and terminal
15) restart opensuse
16) now cursor/pointer is visible on login and next on login window from desktop list (gear-picture) select back “GNOME”
17) after succesful login on desktop mouse cursor/pointer is visible and move Ok

There is short refresh on login screen before desktop opens , but that is not problem.

Thanks for you all supporting to do also to login work correctly.

:slight_smile:

You’re welcome.
I am glad that works.

I think Gnome only runs on Xorg after that config change. So just picking “Gnome” should give you Gnome on Xorg.

You can try in a terminal window:

echo $XDG_SESSION_TYPE 

and I think that will tell you that you are using X11.

You are right, when testing with

> echo $XDG_SESSION_TYPE

terminal shows

x11

So it’s “Gnome on Xorg”

Additional info: There is Dell D620 HW versions with different intel processors and earlier discussion was case with with sticker “Intel Centrino Duo” with Intel Core2 T7200 (Dual core 2,00GHz) processor and with PRO/Wireless 3945ABG(Golan) wlan. In another case of version with sticker “Intel Core 2 Duo” with Intel Core2 T5600 (Dual core 1,83GHz) installation of desktop goes without problems and after installation Gnome works Ok on “Wayland” mode (, but unfortunately this spesific Dell D620 has Broadcom wlan circuit (BCM4311 802.11a/b/g) that does not work properly out of box after SUse Leap 15 installation even install_bcm43xx_firmware driven after installation as in this case wlan is then active it is unusable because of slow speed 1-11Mb/s which is maybe subject for another discussion as earlier Suse 42.3 version same Broadcom wlan was working proper speeds.).

You should start a new thread (with suitably descriptive title) if you want to discuss wireless networking issues.

New thread opened about Broadcom wlan issue : Wlan with Broadcom wlan circuit (BCM4311 802.11a/b/g) too slow problem - Network/Internet - openSUSE Forums

And you’ll note that I’ve already replied there. :wink: