Suse 15 try to install apps, the install process happens, but no apps are installed.

Rebuilt four times, once with a completely different hard drive. Same thing.

Originally I built it like this:

/ 20GB Btrfs
/usr 20GB Btrfs
/var 20GB Btrfs
/tmp 20GB Btrfs
/home 200GB Btrfs

I thought that maybe the Btrfs on /home might be causing it, so I rebuilt this way:

/ 20GB Btrfs
/usr 20GB Btrfs
/var 20GB Btrfs
/tmp 20GB Btrfs
/home 200GB Ext4

Same thing, so I rebuilt like this:

/ 80GB Btrfs
/home 200GB Ext4

Same thing, so I rebuilt like this:

/ 80GB Btrfs
/home 200GB XFS

Each time, I had it reformat each partiion.

Same thing.

Help. I don’t even know where to begin on this one.

“Same thing” is not very informative.

Please explain as precisely as possible:
What you want to achieve.
What you were trying to do (from the beginning).
What you were trying to do it to (hardware and existing software).
What you actually did (exact commands and actions).
What you expected or hoped to happen.
What really happened.

I agree with eng-int, but to put it more simply, what does “install process happens” mean, and how do you know “no apps are installed”?

I was trying to install some programs.
What I did, was, open YAST, install some programs. YAST said it was finished. I went to the start menu to launch the newly installed programs and they weren’t there in the menu where they should be. YAST said it installed properly and the install finished but the programs don’t show up to be used.
Existing hardware is a computer with a core i5 and 8GB of ram 500GB hard drive – I had Suse 15 running on this system before with all of my programs installed and running fine. All installed programs showed up in the start menu as expected, everything was running great for a week. I installed Ubuntu as a dual boot so I could try it out. But instead of installing as an extra OS, like it claimed it would do, Ubuntu wiped out the Suse install. So I re-installed Suse 15 and that’s when the problem began. I can use YAST to install programs all day long and even though YAST says it installed nothing is in the start menu.

I tried just installing one program that is quick to install as a test, that program is gkrellm.
I open YAST, type in gkrellm, select it, click ok. Wait for YAST to get done, Click finish. Click the start menu and go to System where gkrellm has been for the last 5 years after it’s installed and it’s not there.

I suggest to create a new user with YaST2, login with that user, and see if the menus are as you expect. If they are, then there is some incompatibility with configuration(s) saved in your regular user’s home directory. If you need to post back, include output from

fdisk -l; blkid

in case we need to see what partition scheme you are working with.

Now I understand. After trying to install application software you cannot find it in the Application Menu. We do not know that there was no installation, only that you cannot find something to click on.

You re-installed Leap-15.0 over the top of an Ubuntu installation. How exactly? Did you reformat the root and home directories? What Desktop Environment are you using? Is ths a default KDE configuration or have you changed the application launcher?

If a default KDE what happens if you type “gkrellm” into the application launcher search box? Can you use either <Alt+F2> or Konsole to launch the program?

This sound as if it might be a reuse of the users configuration file between two distributions. Have you tried logging in as a new user? Have you tried deleting/renaming ~/.config/menus?

My apologies I overlooked this:

I suspect
That the perception that an application isn’t installed is because you don’t know how to invoke the application.

The first thing to know is that an application doesn’t typically install in /home, applications typically install in one of the other partitions or directories… settings and personal modifications are typically stored in /home. These generalities of course have their exceptions.

If a menu item doesn’t exist for your application,
You should try invoking the application in a windowed console (command line).
If the application is installed in a PATH, you should be able to launch the application (usually but not always by the application name) from any location.
If the application is installed n a location not in a PATH, then you’ll have to first “change directory” to the location of the application binary before you can launch, or describe the directory path to the binary to launch.

Determining the location of application binary can be done a couple ways…

  1. List the package contents. The following command does this
rpm -ql *packagename*  
  1. Find the installed location. I recommend using “locate” instead of other similar apps like “Find.” The locate utility can be installed as follows. In an elevated console, install the mlocate package as follows
zypper in mlocate

Although the locate database will update every 24hrs, we don’t want to wait a day to use “locate” so you should run the following to populate the database

updatedb

You can now run “locate” to find any files on your system. The following example assumes that a binary exists that has the same name as your package, and searches not just for gkrellm, but also makes an educated guess that the executable binary for that app is in a “bin” folder

locate bin/gkrellm

HTH,
TSU

I had it reformat all partitions each time and I deleted all partitions during each build to further alleviate any possibility of a reuse.
Not sure I’d say it was installed over with the above, but maybe.
As for how, I booted off the USB drive, deleted all paritions, re-made them, and chose the program groups I wanted and installed.

I use KDE - Default. I don’t change it, aside from not installing games from the install process.

Yes, typing gkrellm into the launcher search, brought it up. But I installed wine and it didn’t show up when I typed wine in the application launcher.

Haven’t tried the new user yet or messed with the config menu. Not sure I’d know how on the last.

I’ll try creating a new user and see what that does.

I created a new user and gkrellm and wine both show up. Installing the rest of my programs now. My guess is that they will show up as well.

My question is, how is my original profile messed up, when I deleted all paritions, formatted all partitions and now, in two cases, tried completely different drives – where i deleted all partitions and formatted all partitions? There shouldn’t have been anything for it to hold over from some other install – or is that somehow not true?

Problem seems to be solved though.

Thanks everyone for the quick responses!

If the other programs I’m installing don’t show up I’ll reach back out.