SuSE 13.10 Asus PCI AC68 causing hair loss.

OK, hopefully I’ve paid attention and my question is so skillfully worded all you experts will be tripping over yourselves to make me stop pulling my hair out.

I have an ASUS PCE-AC68 network adaptor. According to it has a Broadcom BCM4709 chipset.
YaST => Hardware => Hardware Information shows no entry named Wireless LAN.
Under PCI there is an entry for Broadcom Network controller.
I looked for a line with “UDI” in it but the closest thing I came to the example given by lwfinger was “Sysfs ID: /devices/pci0000:00/0000:00:1c.5/0000:06:00.0”
“dmesg | grep firmware” returns no results
“sudo /usr/sbin/iwlist scan” returns three lines. enp0s25 … lo … and enp4s0 Interface doesn’t support scanning.
I just installed OpenSuSE 13.1 on a separate HDD on a computer I just built. The adapter works well under Windows 8.1 (a most horrid creation) but I can’t connect to my network.

If I were to make an educated guess it needs the broadcom-wl and broadcom-wl-kmp-desktop packages from Packman to work. However the catch-22 here is that you’ll need wired connection for this to work, are you able to do so?

To add the Packman repository:

Then to install the application:

Easiest way to add Packman is to launch YAST -> Software Repositories -> Add -> Community Repositories and checkmark Packman. Done. Then install the required packages and reboot.

Hello and welcome here.

Maybe you have tried to word your question as good as possible, but the first thing I see is you mentioning “SuSE 13.10”. I do not know how you came to the conslusion you have such a beast, but it does not exist. :slight_smile: You probably mean openSUSE 13.1. Please confirm, so we are all sure we talk about the same thing.

Then, did you read the first “sticky” threads in this Wireless forum? They try to give you some basic information on how to get your Wireless device working and on the information you should post here when you want help.

And then something that is not obvious to first time popsters like you, so you are not to blame about not doing this. But we like computer text posted here between CODE tags. You get the CODE tags by clicking on the # button in the tool bar of the post editor. Whenever applicable please copy/past the prompt, the command used, the output and the next prompt in between the tags. Then we can see who you were, where you were, what youy did and what you got in one sweep. And there is not need for additional text like: ““sudo /usr/sbin/iwlist scan” returns three lines”, because we will all see all of it.

Yeah the 13.10 was a mistake. Earlier I installed and then removed Ubuntu 13.10 and by the time I realized my error that SuSE didn’t include the 0 I couldn’t figure out how to edit the title. I was su when I ran all the commands. I was in /var/log when I looked for firmware. I haven’t read all the sticky posts yet. I’ve been up for about 26 hours now and my resolve is fading rapidly. As for cut and paste, I’m entering the text from a computer not connected to the internet onto one that is. I suppose I could cut and paste into a file save to flash drive upload to this computer and then copy and paste again. Not sure if that’s faster but probably more informative.

Apologies to the author of this tip (which I noted down without their name) who was told that with his Asus he should create a file called


with the contents

options asus_nb_wmi wapf=1

Then reboot and the wireless network will come right up.

Might not work as it might be a different laptop but might be worth a try.