SUSE 12.3 - there is no swat file and samba couldn't be configured

Two comps 32bit and 64bit with freshly installed 12.3. Starting up cifs, nmb and smb in system services went fine, but starting up swat in xinetd.d failed. There is no file swat in xinetd.d folder. I do not know if xined creates swat file or swat should be shipped whit samba. I copied a swat file from suse 12.2 and that made xined able to turn swat on but then I got sticked with next problem can not open localhost:901 - no such page. Any help for proceeding with setting up samba will be welcome. Thanks

Open SUSE 12.3 , nVidia 6150 (x64) and Radeon x600 (x32) , KDE 4.10

According to jdmcdaniel3 there is no SWAT for 12.3.
He wrote a cool tool that may be of help to you:
SACT - Samba Automated Configuration Tool - Version 1.02

Yep, just discovered this myself… What the??

On 3/20/2013 6:26 AM, hornetster wrote:
> olegue;2537467 Wrote:
>> Hi,There is no file swat in xinetd.d folder. I do not know if xined
>> creates swat file or swat should be shipped whit samba.Yep, just discovered this myself… What the??

AFAIK, openSUSE did not package SWAT with any of the Samba 3.6.12 releases. Samba 3.6.12 for openSUSE 11.4:Evergreen no
longer has SWAT. If you need to remotely configure a Samba server, webmin provides one web based alternative.

“We’re all in this together, I’m pulling for you” Red Green

not to be too disgruntled, as im in a bad mood and should probably not type too much right now, but this is not the first time there have been some issues with samba that cause it to just not work ootb. They may has well have dropped samba as its been bad since 12.1. There was a huge pulse issue in 12.2 that is barely getting any attention now, and there are several bluetooth problems that I don’t even have time to post bugs for each one or search the lists.

BUT, some things really came together in 12.3, and for that reason I switched. We have a solid distro here but the bugs are honestly overwhelming when it comes to filing a new bug or even just trying to gather enough information to make a post about it and then hopefully get attention and not have to bump a thousand times or just forget about it. With that said I’ll start soft-spamming my own problems in a few days, as it really is a pain in the ass to do each time theres a new bug.

I think I have found a solution and will describe it in steps.

  1. YAST - System - System Services (Runlevel). I set “cifs”, “nmb” and “smb” to “yes”. Click OK and processed with next.
  2. YAST - Network Services - Samba Server. “Shares” section check the “Allow users to Share Their Directiries” and if you like you can check also “Allow Guests”. In ‘Indentity’ section - for ‘DOMAIN CONTROLER’ - ‘Not DC’, for ‘Remote WINS Server’ and ‘Remote WINS Server via DHCP’ - checked, for “Net BIOS Hostname” - some name (that will be the name of the host or comp that appears in your file manager under SAMBA and Domain name). I hadn’t changed “Workgroup or Domain Name” I left it to “WORKGROUP” as it is by default, but you can change it. Click OK and processed with next.
  3. YAST - Security and Users - Firewall. In “Allowed Services” for “External Zone” - I added “NetBIOS Server”, “Samba Client”, and “Samba Server”. Click OK and processed with next.
  4. In a console as a root .

smbpasswd -a username

I was asked for a password and asked again for same password then I was informed the user was created. Proceed with next.
5. In Dolphin or Nautilus file managers choose Networks then Samba and WORKGROUP (or the name you had given in “Samba Server” for “Domain Name”, I’d left it as it is) will appears. Click on WORKGROUP icon and it opens the samba’s hosts registered on your net. Clicking on every host icon will load the shared folders by that host. The first time you attempt to enter a folder you will be asked for a username and password, use those you have set in step 4.
That works for me.

Awesome info, I’m just confirming this works, but also I was able to skip step 3 as step 2 I believe allowed me to open ports, and then when I attempted step 3 everything was setup in firewall, so that was much simpler for me.

Afterwards, everything worked. Put in my password once and done, thanks a million!

I had the same problems with sharing in my network. tried a million things but never succeeded (I’ve been worling on this for at least 3 weeks). Just did not get the linux and the windows machines to see each other. I thought I had a solution via swat but as I red in this post with opensuse 12.3 no more swat available.

Tried the steps as explained in this post which were quite simple and THEY WORKED.
Thanks a lot for the work olegue. A grateful puzzled penguin.