Suse 12.2: Scanning with hplip over the network

Hi.

I’m trying to re-install my hp-scan for commandline on my server (no graphical interface). I have upgraded my server from Suse 12.1 to 12.2 but I cannot get the hp-scan working again. So I was able to add the scanner with the hp-setup tool, but when executing hp-scan it starts and then freezes without doing anything e.g.:

 /usr/bin/hp-scan --mode=lineart --file=/srv/Temp/SCAN-20130512_15031931403520.jpg --logging=debug

HP Linux Imaging and Printing System (ver. 3.12.4)
Scan Utility ver. 2.2

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

hp-scan[13435]: debug: getDeviceUri(None, None, 'hpaio'], {'scan-type': (<built-in function gt>, 0)}, , True)
hp-scan[13435]: debug: Mode=0
hp-scan[13435]: debug: Device URI usb://HP/color%20LaserJet%203550 is invalid/unknown
hp-scan[13435]: debug: Exception: 4 (Unknown/invalid device-uri field)
hp-scan[13435]: debug: hp:/net/psc_2500_series?ip=10.74.78.30: back_end:hp is_hp:True bus:net model:psc_2500_series serial: dev_file: host:10.74.78.30 zc: port:1
hp-scan[13435]: debug: Cache miss: psc_2500_series
hp-scan[13435]: debug: Reading file: /usr/share/hplip/data/models/models.dat
hp-scan[13435]: debug: Searching for section [psc_2500_series] in file /usr/share/hplip/data/models/models.dat
hp-scan[13435]: debug: Found section [psc_2500_series] in file /usr/share/hplip/data/models/models.dat
hp-scan[13435]: debug: hpfax:/net/psc_2500_series?ip=10.74.78.30: back_end:hpfax is_hp:True bus:net model:psc_2500_series serial: dev_file: host:10.74.78.30 zc: port:1
hp-scan[13435]: debug: {'hpaio:/net/psc_2500_series?ip=10.74.78.30': 'psc_2500']}
Using device: hpaio:/net/psc_2500_series?ip=10.74.78.30

And that’s it, nothing more happens. I took a glance at the traffic to the printer with tcpdump, but there were no packages going out from the server.
Printing with this printer works well - so I don’t have a clue currently …

Can someone please help me?

cya

hachtl

Have you got sane and the appropriate backends installed because hp-toolbox calls sane to do the actual scanning?

Sane is installed (I guess this is a requirement for having hplip installed …), but what Backends do you mean? So hp-scan asked previous for python imaging library which I have also installed…