Suse 12.2 Installation problem - Graphical Interface could not be started

I have been excited to see what OpenSuse 12.2 has to offer and now disappointed with the installation.
I have a AMD quad core processor and downloaded the 64bit 12.2 installer.
I have been using 64 bit 12.1 Gnome Desktop on a dual boot setup with Windows Vista and Ubuntu 12.4
My PC has a built in ATI integrated AMD Radeon HD 4250 graphics card

The installation went through quite normally but I was surprised that when it got to the Partioning that there was no display of my Windows partitions - Suse has always displayed the partitions if there. I maust say that I sat and looked at this part of the installation for quite a while wondering whether to carry on - afraid that my Windows partition was going to be overwritten. Suse has never done that to me and I decided to go ahead an trust that it would protect Windows - well it did. At least that is still the same.
Maybe a note or something should still be displayed there to say that it recognises other OSs

The rest of the installation looked fine but at the end when it reboots the system it came up with a blue screen (reminiscent of MSWin) in text mode (having done all the installation in good graphics, and displayed “The graphical interface could not be started” and that it would carry on etc. However, it left me with a black screen and the arrow pointer.

I tried 3 other installations looking for ways around to alter the graphics settings to no avail.
I even went as far as pulling out an old monitor screen to see if the problem was with my LCD monitor.

I eventually used the advanced settings in the boot and chose the recovery boot option. This arrived at a normal display but very slow and jerky.

This graphics problems is very reminiscent of Suse before 10.3 where I used to pull my hair out over graphics problems which were more monitor related then.
This problem seems to be related to the graphics drivers as there are no hassles with Windows or Ubuntu.

Has the driver for my for my Radeon been left out? What should I do?

So it sounds like graphics related and possibly down to Gnome?
Do you get a graphical login? OR did you set it to auto login? (Not a good plan)
At the login, can you try a IceWM session?

yes, I have auto login so I don’t see anything else till the little timer icon comes up and the pointer sticks on the screen.

I have just downloaded the Radeon driver supposedly for my onboard graphics and run it in different configurations to no avail
./amd-driver-installer-12.6-legacy-x86.x86_64.run

It listed the Suse systems and I chose the auto detect
then the Suse 12.1
and I still get the same results.

I see that Suse seems to support the NVIDIA repositories but not ATI Radeon. Would it be a good idea to get and install a NVIDIA graphics card?

Ok. I’ve tried with the auto login off and it still freezes but now on the timer icon and it doesn’t move onto the pointer.

See this post for instructions how to install ATI drivers; it may help: http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/478591-urgent-help-needed-after-upgrading-suse12-1-cannot-open-normal-mode.html#post2488281

http://forums.opensuse.org/content/115-ati-driver-atiupgrade-new-version.html

Thanks guys. I see the scripts and drivers won’t work with 12.2 yet. From the article you gave …

*** Notice that it doesn’t work on openSUSE 12.2 Milestone 3 yet. But it is not because of atiupgrade. The script would work, but the ATI installer fails to build the package. Do not try to install the ATI proprietary driver on openSUSE 12.2 M3 today (April 2012) , using atiupgrade or another method. **

I have ordered a Nvidia Geforce 1GbB GT210 card which I hope will be here tomorrow and I’ll re-install. Probably be better to have a dedicated graphics card in the PC anyway. In the meantime I can at least limp along in the safe boot up mode.

Not always a good idea to jump in early with the latest upgrades, but I like to experiment and I have got to like openSuse over the years. Ubuntu works great too but I still find it’s not as professional looking as Suse and their install and boot loader is “scruffy” :slight_smile:

I have now installed a new nVidia GeForce GT210 graphics card. I re-installed 12.2 and it boots into a display of 800x600 and does not recognise my Acer Technologies 17" monitor. At least I boot into a display now.

I have tried to add the repo for the nVidia drivers using YAST Community Repositories but my large display does not allow me to get to the screen accept buttons - so I cant complete the repo set up. I then looked up the Suse nVidia driver install on the Suse site (I can CTRL/- to shink the web sites displays) and tried the zypper ar -f ftp://download.nvidia.com/opensuse/12.2/ command using Gnome Terminal given to add the repo and it doesn’t accept the command.
So now I am back in Ubuntu to askd for help (interesting that Ubuntu 12.04 knows my monitor and has booted into 1280x1024 (5:4) resolution automatically.

I need help in getting the nVidia drivers running please.
Is there a way to give me a better resolution to work with while getting the right drivers to work? - In past Suse builds we used to be able to Alt/Ctrl F3 to leave the GUI and use init 3 and sax 2 to set up the displays
In what mode / boot up should the repo and drivers be installed?
Thanks

Perhaps you can open a terminal and the the following:

su -
zypper ar -f http://download.nvidia.com/opensuse/12.2/ nvidia
zypper ref

(a) to accept

zypper patch
zypper up

It is fixed. atiupgrade now works on 12.2. See this post: http://forums.opensuse.org/english/other-forums/development/programming-scripting/449058-upgrading-ati-driver-atiupgrade-22.html#post2488647

Tried caf4926 zypper commands and installed the repo and driver.
Suse boots up - still in a display of 640x480 (not 800x600) as I said previously.
I get this display.

none of the selected modes were compatible with the possible modes:
Trying modes for CRTC 310
CRTC 310: trying mode 640x480@73Hz with output at 1280x1024@77Hz (pass 0)
CRTC 310: trying mode 640x480@73Hz with output at 1280x1024@77Hz (pass 1)

I used YAST to display the hardware and I see that the Nvidia card is displayed so I presume thats ok.
I have the hardware saved in a file if it’s of use to see - it’s possibly a bit long to list here

What do I do about changing the display / monitor to get a proper resolution?

Did you really install the driver?


# lsmod | grep nvidia
# rpm -qa | grep nvidia

Been searching through the hardware list and came across this. Looks like the driver is not active.

38: PCI 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.319]
Unique ID: VCu0.4CKYDMYYqbC
Parent ID: _Znp.nwVNs5iQ6K7
SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “nVidia GT200 [GeForce 210]”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x0a65 “GT200 [GeForce 210]”
SubVendor: pci 0x1458 “Giga-byte Technology”
SubDevice: pci 0x3525
Revision: 0xa2
Memory Range: 0xfd000000-0xfdffffff (rw,non-prefetchable)
Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
Memory Range: 0xce000000-0xcfffffff (ro,non-prefetchable)
I/O Ports: 0xd800-0xd87f (rw)
Memory Range: 0xfe980000-0xfe9fffff (ro,non-prefetchable,disabled)
IRQ: 10 (no events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v000010DEd00000A65sv00001458sd00003525bc03sc00i00”
Driver Info #0:
Driver Status: nvidiafb is not active
Driver Activation Cmd: “modprobe nvidiafb”
Driver Info #1:
Driver Status: nouveau is active
Driver Activation Cmd: “modprobe nouveau”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #18 (PCI bridge)

lsmod | grep nvidia # rpm -qa | grep nvidia

Produces no results

You haven’t installed the nvidia driver. If you did already add the repo, as explained in post #9, just install this package:


$ su -l
# zypper in x11-video-nvidiaG02

Then reboot and you should be fine.

Okay. That’s done it. I have a proper display now 1280x1024(5:4) and the monitor is recognised as Acer Technologies 17".

There were errors listed at the end of that install but can I assume I just leave it as it is now?
This is the display at the end of the install and I re-ran the greps on the Nvidia

Installing: nvidia-gfxG02-kmp-desktop-304.43_k3.4.6_2.1[done]
Installing: nvidia-computeG02-304.43-20.1 …[done]
Installing: libXau6-32bit-1.0.7-2.1.2 …[done]
Installing: libxcb1-32bit-1.8.1-2.1.2 …[done]
Installing: libX11-6-32bit-1.5.0-2.1.2 …[done]
Installing: libXext6-32bit-1.3.1-2.1.2 …[done]
Installing: x11-video-nvidiaG02-304.43-20.1 …[done]
Additional rpm output:
grep: etc/X11/xorg.conf: No such file or directory
Warning! MD5DIR is not set: you probably called this script outside SuSEconfig…!
Using MD5DIR="/var/adm/SuSEconfig/md5"…
No changes for /etc/X11/xdm/Xservers
No changes for /etc/X11/xdm/xdm-config

Kernel image: /boot/vmlinuz-3.4.6-2.10-desktop
Initrd image: /boot/initrd-3.4.6-2.10-desktop
Root device: /dev/disk/by-id/ata-ST3500418AS_9VM21H3F-part6 (/dev/sda6) (mounted on / as ext4)
Resume device: /dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL992212-part6 (/dev/sdb6)
modprobe: Module hid_generic not found.
WARNING: no dependencies for kernel module ‘hid-generic’ found.
Kernel Modules: thermal_sys thermal processor fan pata_atiixp ata_generic scsi_dh scsi_dh_rdac scsi_dh_emc scsi_dh_hp_sw scsi_dh_alua xhci-hcd hid-logitech-dj
Features: acpi plymouth block usb resume.userspace resume.kernel

linux-m2qt:~ #
linux-m2qt:~ # rpm -qa | grep nvidia
nvidia-gfxG02-kmp-desktop-304.43_k3.4.6_2.10-19.1.x86_64
nvidia-computeG02-304.43-20.1.x86_64
x11-video-nvidiaG02-304.43-20.1.x86_64
linux-m2qt:~ # lsmod | grep nvidia
linux-m2qt:~ #

It should show the nvidia kernel module with size.

# **lsmod | grep nvidia**
nvidia              11265951  30 

and


# **modinfo nvidia**
filename:       /lib/modules/3.4.6-2.10-desktop/updates/nvidia.ko
alias:          char-major-195-*
version:        304.43
supported:      external
license:        NVIDIA
alias:          pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias:          pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        
vermagic:       3.4.6-2.10-desktop SMP preempt mod_unload modversions 
parm:           NVreg_EnableVia4x:int
parm:           NVreg_EnableALiAGP:int
parm:           NVreg_ReqAGPRate:int
parm:           NVreg_EnableAGPSBA:int
parm:           NVreg_EnableAGPFW:int
parm:           NVreg_Mobile:int
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_RemapLimit:int
parm:           NVreg_UpdateMemoryTypes:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UseVBios:int
parm:           NVreg_RMEdgeIntrCheck:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_MapRegistersEarly:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_NvAGP:int

Anyway, your problem is solved.

Strange
Once I added the repo it pulled it all in with zypper up

Good to hear it is OK
Thanks PTA

Very strange indeed. It doesn’t look like an expected behaviour. How could zypper install the right package? There are 3 different drivers in nvidia repo. “zypper up” doesn’t check the model of your graphics card to find out which driver you need. And even if you had installed the driver from another source before, it would not have changed the vendor by itself.

As you say, it works now.
Thanks guys