Suse 12.2 freezing during the last stage of installation

GREETINGs
Let me get some help before I declare Suse 12.2 a waste of time.
I had problems with suse 12.3 because it was outdated and no-longer being supported. I posted that query here and I was advised to migrate to suse 12.2, which is the latest. Yesterday I bought a Suse 12.2 install DVD and decided to do a fresh install (not upgrade)
I used my old partitions for installing this same version (of course they were formatted again by the installer).
The installation went well, and then the machine had to reboot in order to go to the next and last stage that would complete the installation (the last stage is labelled as ‘Automatic Configuration’). However, when the system comes to this stage, it runs upto the middle (as shown by the progress bar) and then freezes. Nothing happens or progresses again even if you leave it there for hours. I have tried restarting/rebooting but nothing changes.
You get a box telling you that the previous installation failed and will ask you whether you want to continue with it or not. When you click retry, you go back to the same issue. If you click no, Suse Linux will ‘boot’ and the login box appears but despite entering the correct user name and password, Suse tells you that the authentication failed. If you have installed Suse, am sure you know this last stage am talking about.
What is the problem? I can reinstall suse 12.3 without any problem.
I have tested the installation DVD and it is Okay
I have had about acpi and that this prevent certain linux systems from running. Could this be the problem?
what is wrong with this suse thing?

My normal suggestion is to download, create and boot from a openSUSE 12.2 LiveCD and allow it to run from memory to see if openSUSE 12.2 will work. I ask if you have any Linux that works, give us the terminal output of:

su -
password:

fdisk -l

Can you tell us about your computer hardware (CPU, memory, Hard disk) and about your video setup (Intel, AMD or nVIDIA) as well as PC make and model and if a Laptop or desktop? By the way you keep saying openSUSE 12.3 worked, but perhaps you meant to say 11.3?

Thank You,

Before I proceed, thanks for your time.
Sorry for writting that “opensuse 12.3 worked” I meant 11.3.
Am using Emachines E443-BZ602. As you know, Acer bought Emachines and both products have the same specifications. Am using a laptop, its just 6 months old. These are the specifications;

AMD Dual core processor C-50
AMD Radeon (video setup)
2 GB DDR3 Memory
250 GB HDD

This is my Terminal output after running fdisk -l from this same machine when running 11.3.

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x6869deb0

Device Boot Start End Blocks Id System
/dev/sda1 1 13 102400 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 13 4630 37087051 7 HPFS/NTFS
/dev/sda3 * 4631 30401 207005557+ f W95 Ext’d (LBA)
/dev/sda5 4631 14900 82493743+ 7 HPFS/NTFS
/dev/sda6 14901 28999 113250186 7 HPFS/NTFS
/dev/sda7 29000 29011 95232 82 Linux swap / Solaris
/dev/sda8 29261 30401 9156608 83 Linux

This looks like good info to work with. Its early morning in Austin and I am heading off to work now. I will look at this tonight and see what we can do. Sorry I can’t help this morning, but work calls, which pays my bills.

Thank You,

Looks to me the size of swap is odd. Please also post output of

df -h

Thanks. Am still waiting for your help. I hope you have seen all the details that I have posted. I have also been asked to provide df -h details and here they are.

hussein@linux-xorn:/> su
Password:
linux-xorn:/ # df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda8 8.6G 3.7G 4.5G 46% /
devtmpfs 866M 240K 865M 1% /dev
tmpfs 867M 232K 867M 1% /dev/shm
/dev/sda1 100M 25M 76M 25% /windows/C
/dev/sda2 36G 34G 2.1G 95% /windows/D
/dev/sda5 79G 36G 43G 46% /windows/E
/dev/sda6 109G 37G 72G 34% /windows/F

Last night as I was going to bed I thought about something:
The suselinux 12.2 that I was installing was a 64 bit Version. Then I thought - “would I have succeeded if I had tried to install a 32 bit version”? This is a great question