suse 12.1 remote printing issue with wireless print server wps510u


I am running OpenSuse 12.1. I initially configured my HP CP1215 printer as a USB printer using the hplip drivers (either hpijs and hpcups work fine).

I recently purchased a TP-Link WPS51-U wireless print server. I hooked up my printer and configured my other computers and devices to print to it (windows xp, windows 7, android via printershare). All are able to print to it.

Configuring suse 12.1 using ‘yast2 printer’, I have it set up with the following network connection: lpd://<ip address of print server/lp1 . lp1 is the queue name.

I then attempt to print a test page, and get the following output in my cups error_log:

D [02/Feb/2012:21:35:41 -0600] [Job 17] Inserting PostScript code for CUPS’ page accounting
D [02/Feb/2012:21:35:41 -0600] [Job 17]
D [02/Feb/2012:21:35:41 -0600] [Job 17] -----------
D [02/Feb/2012:21:35:41 -0600] [Job 17] New page: %%Page: 1 1
D [02/Feb/2012:21:35:41 -0600] [Job 17]
D [02/Feb/2012:21:35:41 -0600] [Job 17] Found: %%BeginPageSetup
D [02/Feb/2012:21:35:41 -0600] [Job 17] Inserting option code into “PageSetup” section.
D [02/Feb/2012:21:35:41 -0600] [Job 17] Flushing FIFO.
D [02/Feb/2012:21:35:41 -0600] [Job 17]
D [02/Feb/2012:21:35:41 -0600] [Job 17] Starting renderer with command: “gs -sstdout=%stderr -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=hpijs -dDEVICEWIDTHPOINTS=612 -dDEVICEHEIGHTPOINTS=792 -sDeviceManufacturer=“HEWLETT-PACKARD” -sDeviceModel=“HP Color LaserJet 2600n” -r600 -sIjsParams=Quality:Quality=0,Quality:ColorMode=2,Quality:PenSet=2,PS:MediaPosition=7 -dIjsUseOutputFD -sOutputFile=%stdout -_”
D [02/Feb/2012:21:35:41 -0600] [Job 17] Starting process “kid3” (generation 1)
D [02/Feb/2012:21:35:41 -0600] [Job 17]
D [02/Feb/2012:21:35:41 -0600] [Job 17] Closing renderer
D [02/Feb/2012:21:35:41 -0600] [Job 17] Starting process “kid4” (generation 2)
D [02/Feb/2012:21:35:41 -0600] [Job 17] Starting process “renderer” (generation 2)
D [02/Feb/2012:21:35:41 -0600] [Job 17] JCL: 12345X@PJL
D [02/Feb/2012:21:35:41 -0600] [Job 17] <job data>
D [02/Feb/2012:21:35:41 -0600] [Job 17]
D [02/Feb/2012:21:35:41 -0600] [Job 17] prnt/hpijs/hpijs.cpp 268: unable to set device=HP Color LaserJet 2600n, err=48
D [02/Feb/2012:21:35:41 -0600] [Job 17] prnt/hpijs/hpijs.cpp 289: unable to set device=HP Color LaserJet 2600n, err=48
D [02/Feb/2012:21:35:41 -0600] [Job 17] **** Unable to open the initial device, quitting.
D [02/Feb/2012:21:35:41 -0600] [Job 17] renderer exited with status 1
D [02/Feb/2012:21:35:41 -0600] [Job 17] prnt/hpijs/hpijs.cpp 694: unable to read client data err=-2
D [02/Feb/2012:21:35:41 -0600] [Job 17] Possible error on renderer command line or PostScript error. Check options.kid3 exited with status 3
D [02/Feb/2012:21:35:41 -0600] [Job 17] Process is dying with “Error closing renderer
D [02/Feb/2012:21:35:41 -0600] [Job 17] “, exit stat 3
D [02/Feb/2012:21:35:41 -0600] [Job 17] Cleaning up…
D [02/Feb/2012:21:35:41 -0600] [Job 17] End of messages
D [02/Feb/2012:21:35:41 -0600] [Job 17] printer-state=3(idle)
D [02/Feb/2012:21:35:41 -0600] [Job 17] printer-state-message=”/usr/lib/cups/filter/foomatic-rip failed”
D [02/Feb/2012:21:35:41 -0600] [Job 17] printer-state-reasons=none

I’ve tried configuring the printer instead for jetdirect (which the print server supports). This also does not work. I have an opensuse 11.3 workstation also, and it also will not print using the print server (configured either for lpd or jetdirect), but can directly to the printer via USB.

For kicks, I tried the latest ubuntu live cd. It configured and printed a test page easily. In the configuration, I specified the IP address of the print server. So I know at least one linux distro CAN print to this print server.

With the info and the above error log, does anyone have an idea what’s going on?

I find it suspicious that the error log reports the system is trying to set device hp laserjet 2600n.

Thanks for any help you can offer.