WHY Wont suse detect my printer a CANON iP1500 ??
PLEASE Send any help to this email as i dont always lookin here

thanks patrick

Hi, you can find the instructions and the driver from here
Getting canon printer working in openSUSE 11 |

thanks just found your reply today july 4th Many thanks , now how do i download it so it goes in the right place ???

These file are rpms (setup files, just start on of them), YaST will care about the right locations. :slight_smile:

looks like you are getting advice;

are you clear where you are going?

Canon, in their website, give you

a) the files and

b) an instruction guide

you need to read the guide first, and then install the files

here is the guide

Canon Bubble Jet Print Filter Ver. 2.50 for Linux ( Operation guide [Explanation of the iP1500 operation (html file)] )

and AFTER you have read it, try downloading first:

the common file

Canon Bubble Jet Print Filter Ver. 2.50 for Linux (rpm Common package)

and then the specific file for the ip1500

Canon Bubble Jet Print Filter Ver. 2.50 for Linux (rpm Package for iP1500)

let us know how you see it now;

you need to install rpm packages by:

assuming root powers: su and root password

and then in a terminal

rpm -Uvh whateverpackage.rpm

ie for whateverpackage.rpm use the name of the one you wish to install

I guess this is the best spot to post my problem. The only rpm that I can find for ip1500 is for 9.1 Professional; this worked while I was on 10.3. With 11.1- installed, trying to load bjfilter, gtk+ and libxml are not present. What I have found is; - missing - usr/lib/libglib-2.sso.0 installed - /usr/lib/ installed - missing installed

The question is, how do I get the missing procs?

Hi. You should find the missing dependencies when you search for them in Yast with the checkbox “RPM Provides” selected.

Thanks for the rapid response, but no luck with rpm’s. YaST install gives error “Failed dependencies. is needed by bjfilter…etc”.

The problem here is that these rpms were built against older libraries that no longer have that version number.

In no way am I endorsing the following course of action.[size=4]

[size=3]Sometimes when I run across this problem, there’s a little trick that I do. First, I run rpm on the file and see what error it gives me. If it says

[/size][/size]Failed dependencies. is needed by bar

then I locate Let’s say that it returns Then I do the following:

ln -s /usr/lib/ /usr/lib/

And I run rpm again. Usually, it no longer complains about libfoo and goes on to libreallyimportant or something and I do the same with that. And so on until the **** thing installs.

That does not always work

At times, there are breaks in compatibility, and a program for will not work with Secondly, though I have never experienced any problems doing this other than the program I installed simply refusing to work, it is a Bad Idea™ to mess around like that generally.

I just wanted to lay it on the table.