Suse 11 upgrade - Lost sound in some apps

I have upgraded from Suse 10.3 to 11.0 and have lost my Evolution mail notification sound. I have Evolution pointed at working .wav files but the sound doesn’t work - not even the “beep” works. The Evolution bugs guys suggest it is not their problem but a Suse problem.
Banshee works and Totem works and I have sound with Skype.
Shouldn’t there be a basic, default, sound driver that should be retained in an upgrade?
My sound card is a Nvidia nForce2 (Alsa mixer).
What is the default sound driver that Evolution should use? And what do I need to do to get this going?

It is possible this is a pulse audio hiccup. You could remove the alsa-plugins-pulse per something like this blog entry of an openSUSE user:
sontek ( John M. Anderson ) » Achieve Zen with openSUSE 11.0 (i.e Get rid of pulse audio)

Make a note of anything you remove, so you can re-install it later if desired.

Thanks, I have done as suggested and still the same.
I then used YAST to uninstall everything to do with pulse audio, and Evolution is still not producing sound. Banshee still works and if I double click a sound clip it opens and plays in Totem.
I don’t have any volume control icon on the bottom panel. I don’t know if there should be one indicating a default sound driver?
I had two error reports on boot up before deleting all of pulse audio but I can’t copy the screen shot into this note.
Having deleted all of PulseAudio they no longer are appearing. I don’t know if these messages are helpful…

The 1st is a PackageKit Error reporting “an internal system error has occurred” — repo-oss:Valid metadata not found at specified URL(s)

The second error window says:
“The Avahi Zeroconf service is not running. Please make sure that Avahi is installed and activated before starting the PulseAudio Device Chooser.”

Is your desktop kde or gnome?

Sorry I forgot to give the desktop.
Its Gnome and I upgraded from a Gnome desktop on 10.3

I’m a KDE user, … I can’t really help wrt Gnome. This could (by may not) be desktop related.

I can look at your general sound settings, but the probability of my picking up anything is likely very low. If you do wish me to check your regular sound configuration, then post the output URL provided by these two scripts (copy and paste them, and run with your PC connected to the internet):

wget -O && bash 

and in the next script when prompted for a password, enter your root password, and type NO for every question that you don’t understand.

su -c 'wget -O tsalsa wget && bash tsalsa' 

Post the output URLs here.

Also post output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libsounda2
cat /etc/modprobe.d/sound
but as noted, given my lack of knowlege of Gnome, I’m not very optimistic.

Okay, here are the results asked for:

URL FOR alsa: tsalsa.txt - (beta)

garth@garthlinux:~> rpm -qa | grep alsa

garth@garthlinux:~> rpm -qa | grep pulse

garth@garthlinux:~> rpm -q libsounda2
package libsounda2 is not installed

garth@garthlinux:~> cat /etc/modprobe.d/sound
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0

I have in the meanwhile also tested KMail and there is also no sound from the Mail Notification test.
I ran alsaconf from the command prompt and it does play sound.
Hope this all helps.

From what I can see, is you have two separate sound devices, … your motherboard sound, which is an Nivida ALC650 on IRQ20, and a separate PCI sound card, which is an ENS1371 (Ensoniq Audio PCI) on IRQ16. Do you have speakers plugged into both sound cards?

The Ensoniq ENS1371 will typically use a kernel module: snd-card-ens1371
The nvidia ALC650 the snd-intel8x0.

Your /etc/modprobe.d/sound file is only setup for the one sound card (the nvidia ALC650).

The tsalsa script suggests your snd-card-ens1371 kernel module is NOT loaded (hence there will be no sound through that device).

How is your Gnome desktop set up? Any chance it is setup to send sound to the Ensoniq as opposed to the nVidia sound device?

Using Gnomes System Sound setup I have tried all the settings and in their tests the OSS and alsa sounds are fine. Card is currently set for Nvidia.
Looking in the YAST software manager I can’t find any reference to the snd-card-ens1371 that you mention may be missing. If I search for alsa there are various package modules that are not installed eg alsa-tools - Various tools for ALSA including DSP loaders. But nothing else that seems to refer to the kernel.

Sound in evolution works fine on my KDE. I don’t use Gnome. Maybe this is a Gnome problem.

Hi Garth,

These reports could be of use.

I actually just wanted to test sound in Evolution here but seem to be missing the notification option within my preferences?


no firefox etc all no sound

I have to delete the audiocard and auto configure at every reboot to have sound
settings are lost. >:(

so what to do…trash opensuse 11.2 >:)

Please confine your problems to one thread. …

I just back from business/vacation, and I’m surfing thru the forum for users with sound problems, to see if I might be able to help. Please follow up on this thread here (that you started already): no more sound - openSUSE Forums