SuSE 11 on Asus Eee 901 anyone?

I am considering purchase of an Asus Eee PC 901 but the version of linux installed seems to have more than a few bugs and little support. I would like to run SuSE on the Asus but am not sure if it will run on that hardware. Anyone tried it?

I do not own an EEE PC, but I see some enthusiasts have already created a page for openSUSE:
OpenSUSE on the EeePC - openSUSE

You also could look at the openSUSE hardware compatibility list (HCL) and search for the EEE on that page:
HCL/Laptops/Asus - openSUSE

which takes you to page on openSUSE:
EeeUser ASUS Eee PC Forum / OpenSuse 10.3, Compiz-Fusion, All Drivers working, on the Eee PC 8G

Hi. I have a model 701 so the experience could be different. I tried 10.3 and 11.0 but actually i got them to work only after a lot of hassle. Then i tried Ubuntu: no! Then Mandriva spring 2008 and this worked just out of the box. Even if i am an old suse fan in this case i would recommend the last. Don’t hate me please :smiley:

Hi all,

I had everything working with opensuse 10.3 on my eee 901 16gb.
(and was happy…) :expressionless:

Today there was several updates from opensuse and I selected everything except for the kernel updates.

During the update process I noticed that a new kernel was downloaded even though I had unselected it.

After the download was complete I did a restart of the eee and all my eee specific drivers were removed. I knew that would happen If a new kernel was installed.

Now the drivers (rpm’s) cannot be installed anymore and I have a broken/unusable eee >:(

Does anybody have a solution or do I have to compile all the drivers myself?

/Ragnar, Norway


Found it… There were already made new rpms for the updated
opensuse 10.3 here:

Index of /repositories/home:/appleonkel:/EEE/openSUSE_10.3_Update/i586

Now it is working again!!


This is an older thread. But hopefully people are still interested in the SuSE + EeePc combination for it to be relevant. I’ll outline my experience on a 901.

Initially I had Mint 5 (Elyssa) installed. The default Xandros can only be intended to scare people away from linux (my opinion). I waited patiently for Mint 6 (Felicia) and I still needed NDIS Wrapper to enable wireless, and a previous problem with the ACPI not shutting the unit off persisted. I LIKE Mint. Its a great ice breaking desktop distro. But my Eeepc is a work machine.

So I did what I should have done in December '08.Installed 11.1.

My setup-
sda1 / 3.8 GB (default volume HDD0 4GB)
sdb1 /usr 6 GB (second default volume HDD1 16 GB)
sdb2 /home 9 GB (second default volume HDD1 16 GB)

And a neat little trick; for $14 au I got a 2 GB SD card. Hence-

sdc1 swap (when it fails from the constant read/write I’ll buy a 4 GB on for $20!)

All partions are ext2 (NO JOURNALING!!!) Beagle is a no go!

KDE 4 is the desktop. Sound works. Wireless Works. Function keys Work. I don’t use suspend. So i cant testify to its health. gkrellm and top show some nasty spikes in cpu usage- generally very short lived. When you launch a new app. But If you keep your applications spread over the 4 default desktops, all is well. The desktops use the ample swap whilst in the background.

My suggestion- Where else can you find a machine that for around $400-$500 can do all that SuSE can do.

Only the webcam gave me an hours grief.

Buy one and do it! I’m still in awe. SuSE 11.1 on the EeePC is as simple and functional as 11.1 on your desktop.

How did you get your webcam to work? It would be great if you could share that!

Actually, I just reinstalled 11.1 on my 701 4G but this time made sure the webcam was enabled in the bios before allowing OpenSuse to complete its autoconfiguration during the second part of the installation process and voila! Working webcam! That means the driver must already be in the stock kernel as I added no extra drivers to get it to work. :slight_smile:

I have a 900 4gig Xandros Linux box. I missed my beloved SuSE so I bought a USB DVD burner and an 8gig SD mem card. Open SuSE 11.1 Installed without a hitch. If you have wireless at home, make sure it is on and the wi-fi light is lit. I used the DVD install. I plugged in a mouse, keyboard, and LCD screen. Everything runs ok since I loaded most of everything into the SD card. The boot stuff did go into the SSD drive. Hmmmm. Somewhat slow. I went to Radio Shack and bought a 2 gig memory for $69. It runs good now. You may have to configure the display if it comes up to 800x600. You can set the LCD to 1024x768 and the tiny screen to 1024x600. It runs good now.

I was just thinking about getting a 16gig high speed SSD drive. They are only about $80 and are much faster than the standard 4gig and a lot faster than SD mem cards. Hmmmmm, ok where is my debit card.

Master Rod

Got to add some more. Added the SuSeee repository and added the fan control RPM to my EEEPC 701. Also added the OSD display for the hotkeys. Now there are no more fan issues. 11.1 runs beautifully now. It is wonderful having the OpenSuse feel on the EEE. A big thank you to the devs. :slight_smile: