Suse 11 New Instal PPC No Sound. Alsamixer Conf?

I have a G4 Digital Audio, all Apple, tower with Suse 11 installed as a clean install. I also have membership in the audio and cdrom groups. I have no system bel, Yast sound test fails all settings. I have all the normal files and such for complete troubleshooting, but I don’t want to publish the sound files unless someone really needs them. Reading my tsalsa results show that my Amixer pc spkr is set to zero. I think this is the problem, but I can’t find any gui or any files where I would think I could change this setting. It caused my audio to be muted in the past, but now the Alsamixer gui only has two volume controls and no controls for any of the mute functions, etc. I guess all I need to know is where the config file is for the Amixer for Suse 11 PPC.

BTW, Yast sound cfg shows AWACS (built in audio for PPC) as sound card 0. Edit only allows me to turn the system beep on and off and right now a “tput bel” on the terminal is silent. I think the setup will yield sound if I unmute the mixer.

I do not know if it works in suse 11 to run the following commands in the failsafe mode
3)Alsactl store


If you post the URL(s) provided by those diagnostic scripts and paste the URL here, I am confident you will get people look at them. Please paste the URL, and do NOT clutter this thread by copying and pasting the contents. Just paste the URL.

Alsa Script
general pastebin - carltons - post number 1053297

Tsala Script
tsalsa.txt - (beta)

I have all the rev’s and my snd file listings, etc. on top of all this. A lot of clutter unless required.

Alsa Script
general pastebin - carltons - post number 1053297

Tsala Script
tsalsa.txt - (beta)

Thankyou for running the scripts.

So you have a “tumbler” ! Also, it looks to me like your mixer has the sound set to “mute”. Take a look at the tsalsa script output:

Amixer contents for card 0 [Tumbler] _____________________________________        
amixer set 'Master',0 70%,70% on        
amixer set 'PCM',0 70%        
amixer set 'Auto Mute',0 on        

I believe you should set the “auto mute” to OFF.

Please open an xterm and type: alsamixer
Then unmute the mixer.

You can read of another G4 Mac users experience here:
New PPC G4 Install No Sound - openSUSE Forums
in particular, post#13

That’s the problem I thought I had. I did open the alsamixer and the only control I have is the volume. The mute buttons and all are missing. The control I had in 10.3 had the mute buttons and that at least fixed the problem getting sound at all. My applications like Banshee and Kaffeine didn’t work. Banshee blew up and Kaffeine just sat there. I decided to go for broke upgrading to 11.0 thinking that if I had no sound it was probably the same problem as in 10.3., but the alsamixer panel changed. Bummer. At least my Alsa files were up-rev’d.

BTW, unless you install the gui panel for alsamixer it’s strictly terminal for PPC. The default volume control is Pulse, but tweeking that does nothing but wear my mouse out. :slight_smile:

I am surprised you do not have a better alsamixer gui. Can you post the output of:
rpm -qa | grep alsa
rpm -q libasound2

Reference “pulse”, my understanding is it is not essential, and it can be removed without a problem. If uncertain, you could remove it, making note of the exact packages being removed, so you could re-install if necessary.

rpm -qa | grep alsa


rpm -q libasound2


Have you rebooted once since installing to ensure the alsa modules are properly loaded? Alsa-utils provides alsamixer, so I am a bit surprised you do not have a better gui. Only a volume control and nothing else? Is there not a “mixer” button you can click ON ? (kmix has such a button)

You could also try installing alsa-firmware and alsa-tools (followed by a reboot).

Or you could type “man amixer” and try to figure out the commands to manually unmute. I think you need to type “amixer controls” first, to see what controls you have (and get the exact syntax) Then type something like: “amixer -c 1 < specific control > unumute”, substituting the name of the control (from “amixer controls”) into the < specific control > . I don’t know the syntax, (I’m just trying to be helpful) so you may have to explore a bit.

You may also give consideration to un-installing all the pulse audio apps, as I have read of users experiencing problems with pulse audio.

Good luck.

I’ll do all of that and let you know what happened. I do think that I’ve rebooted several times since installing trying this and that, but I’ll do it all again just in case. I too have read about pulse and alsa having problems. 10.3 installed no pulse on my Mac, but 11.0 is chalk full of pulse. This will take some time. Please be patient. I will return. Besides my boss (aka wife ) is calling.:slight_smile:

I got the sound going, sort of. I won’t fill in all the things I did, it will fill up the forum with clutter. I think basically what fixed it was: installing alsa-tools and alsa-firmware. Using the amixer command afterwards didn’t work, so I tried a reboot, but it still was mute.

Then I removed all pulse packages. These don’t go easily. Yast crashed on me several times trying to get rid of them. Do a ‘rpm -qa|grep pulse’ on the command line to make sure that no packages remain. Reboot. Upon re entry, do the following (not clear in the man page):

amixer -c 0 sset ‘Auto Mute’,0 off (no spaces before 0)

then # amixer -c 0 sset "PC Speaker’,0 on. Keep running tsalsa until you’re sure the settings took. Usually if all is correct you’ll have this happen while you are setting the two controls:

amixer -c 0 sset ‘PC Speaker,0’ on

Simple mixer control ‘PC Speaker’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]

Same experience for the Auto Mute command.

Make sure your volume is set up in the panel and then do a:

tput bel

If you are set to sound a system bel you should hear one beep.

To see if this worked on a reboot, I did one and when I came back I had to reset the PC Speaker with the amixer command. I sure wish I knew where the config file was.

I hope I remembered all that stuff correctly because I rebooted several times trying to get this beast to work.

Also, I went back to the Yast config gui to make sure nothing changed in my card setting. I pushed the “Other” button and tried to do a test and the volume jumped up. I turned it back down even though the control setting hadn’t changed and everything was still playing. I am now listening to SOMAFM using RealNetworks player and all is fine. It’s music to get your audio to set by. :slight_smile:

Congratulations !!

Thank you for sharing your solution.

Now that you have your audio working, you could look at adding a Packman rpm repository server (ie a repos) to your software package manager. That will give you access to lots of 3rd party rpms. Many of these rpms are for multimedia.

With x86_64 and .i586 PCs, one can add the packman repository from within YaST -> Software -> Software Management. Then, in the menu: Repositories -> Repository Manager. Now hit the Add -> Community Repositories, and select:
* Main Repository (OSS)
* Main Repository (Non-OSS)
* Packman
* Main Update Repository
However I do not know if the PPC works the same.

Alternatively, guidance for the PPC server for packman is here:
Additional YaST Package Repositories - openSUSE

Where the repository is:

and if you did not use YaST to add this, an alternative method to add this may be (but do not add via both methods as you will have it twice):

zypper ar packman-for-ppc

You can check which repositories you have by checking (from an xterm with root permissions):

zypper lr

Good packman packaged rpms to then install are:

  • smplayer (that should add mplayer automatically)
  • libxine1 and xine-ui (be certain to select packman packaged version and not Novell/SuSE GmbH version)
  • amarok (be certain to select packman packaged version and not Novell/SuSE GmbH version)
  • vlc
    Installing those via zypper or YaST Software-Management (after your repos is setup) should automatically result in all the dependency applications/libraries being installed as well.

Typically you can tell a packman version by the “pm” in the rpm file name.

Good luck.

I plan to hand in a bugzilla also. Two installs in a row for the ppc were doomed from the very start not to have sound which is a vital function in any distro. The guidelines for the bugzilla make it sound like you have to have something that causes the kernel to explode or something to that effect to be a bug, but we’ll see.

Thanks for all your help. I already knew about the Packman site before from my installs on the i386 side, but your suggestion was a good one. There’s not much in the way of PPC stuff there, but every little bit does help. Also thanks for showing me the way to add to the software sites for updates. It’s info that is hard to find when you need it.

BTW, the difference between the operation in 10.3 and 11.0 was because one used amixer and the other alsamixer. They are NOT the same. They have two different authors and totally different interfaces. But still, where are the config files?:confused: