Suse 11 KDE 4.x Compiz not working


I’ve installed Suse 11 and updated it over SuSE update. I have installed nVidia legacy drivers (i have GeForce3 Ti500)and recompiled it for my box. Everything went fine and I have 3D good and running. Checked Composite by runnin’ $grep Composite /var/log/Xorg.0.log" and it’s OK.

When I try to enable effects in “simple-ccsm”, check box to enable effects and press “apply”, checked box just unchecks itself.

Can’t enable Compiz >:(

:confused::confused::confused:to update previous post.

Can’t enable XGL… Dunno why.

I have configured and runned previously Compiz on this box and it worked fine. After disk failure and reinstalling SuSE11, can’t configure Compiz.

I’m using driver from nVidia web site and Compiz from

What coul I miss?..:confused:

You aren’t the only one. The new 7.8.x version in the repo does not work. I have had to go back to 7.4 version or just turn it off.

Hmm… Strange. Last time, I have managed to run 7.8x compiz… somehow… I did had a lot of trouble and at the end I didn’t know what I did when it started to work.


I have reinstalled SuSE11. Didn’t make any updates. Just installed nVidia driver and Compiz from SuSE DVD (7.4.x). After enabling Compiz I’ve got a blank white screen. After pressing Ctrl+Alt+Del I’ve got a window for restart, shutdown… and it was appearing and desappearing using Compiz effects.

P.S. On some forums I’ve found this error (white screen after installing compiz) and posters stated there is no solution for this.

I logged as root from console and removed compiz.:wink:

On 10/03/2008 kojo1984 wrote:
> I logged as root from console and removed compiz.:wink:

If it’s only for the eyecandy, check the KDE4 desktop effects. It wobbles and rotates just fine, without Compiz.


Check this article,
Technosrix: Getting SUSE 11 work with DELL Inspiron 6400

This article explains how to enable Compiz-Fusion on Suse 11.:slight_smile:

I just found this post on the opencompositing forum:
Compiz Community Forums - View Single Post - openSUSE Packages

It might explain some of the trouble. A broken emerald package.

This looks like it could work. Will try today…

I don’t know what repo you are using for KDE4. I’m using the Factory repo and found out how to get compiz working.

In X11/XGL repo is a new catagory. It is opensuse 11 for factory kde4. I used that repo (after disabling the others) and forced an update. Compiz started working - sort of.

I had a gtk script that was running on startup (through the Autostart in systemsettings). I had to remove that. I also had to start emerald through a konsole window the first time(emerald --replace&). After the first manual start of emerald it is working on it’s own now.

I also updated my NVIDIA drivers. There is a new beta on the ftp server: 177.78 (BETA) for Linux x86/x86-64 released - nV News Forums. THESE ARE BETA DRIVERS. They may not work for everyone. Make sure you read up before using them.

After doing those things compiz was working just fine.

Worked just fine! Everything is flawless…lol!lol!lol!

TNX guys!