suse 11 install fails "searching for linux partitions"

I have the boxed version of openSUSE 11.0. I have tried to install it on 3 different computers. 2 laptops and one desktop. only 1 of the computers was successful. My wife’s Asus laptop that i built for her.

The other 2, one a desktop i built (intel quad, 4 GB ram, BFG sli motherboard, (3) 150G WD raptors, nvidia 8800 video,) the other a Lenovo T61 (intel dual, 4GB ram, 250G sata) both fail at the same spot.

After the agree to license screen, there is a screen that shows progress of the installer detecting the hardware. When it gets to about 50% and the line item “searching for linux partitions” is highlighted, the install dumps out to a red screen that says there was an error.

using my camcorder and going one frame at a time i was able to catch the error code:

YaST got signal 11 at YCP file Storage.ycp:1682
/usr/lib/YaST2/startup/ line 480: 7770 Segmentation fault (core dumped) $OPT_FBITERM y2base “$Y2_MODULE_NAME” $Y2_MODE_FLAGS $Y2_MODULE_ARG

the kicker of it is, my wife hardly uses linux, but i use nothing but suse 10.3 currently on both of the other machines.


so far, this has novell tech support stumped too.

odd that it is on 2 different computers.

the fix was simple, really.

booted to a rescue system, fdisk’d all of the drives and deleted all partitions.

but then, after the install, i had to edit the grub menumap file to point hd0 to sda and hd2 to sdc for the grub install to work properly.

now, it boots, but no X windows…

Any help from the X log at /var/log/Xorg.0.log?

I’ll check that and let you know, but i did get it working.

There was an error about needing at least one Device in the xorg.conf file. there was one in there, but it didn’t look complete to me. There was no driver stated.

So, i added the Nvidia repo and installed the driver. After that i did the nvidia-config and everything is happy.

I got the location and driver name of the Nvidia repo by downloading the one-click-install file and vi’ing it. Question, is there any way to do a one-click-install from a shell? i tried ./ and i tried yast2 -i filename.ymp but neither worked.

Click on a .ymp file, and the installer will start up. Open ksysguard and filter on .ymp and you’ll see the yast command(s). I played around with that a bit from the command line, and got the installer to run, but it did not recognize the .ymp. A syntax error. Appears that is should be possible.

If i have no X, i cannot click…:cool:

But i guess you meant now that i have it up and running.

I wonder if zypper can do it?

Well, i have 11 installing in my lenovo laptop. After deleting the partitions the install started. Both the desktop and laptop had linux raid arrays from suse 10.3.

i reloaded my server with 11, it had 10.1 or 10.2 and linux raid. The install went perfectly. No need to delete partitions.

ps. just looked through the Xorg.log file but did not see any errors. probably too long to post here.

I looked at zypper, didn’t see anything. Looks like it works strictly off the repositories. “OneClickInstallUI” appears to be a yast2 qt module. Like all the other yast modules, it can be called from the command line. Each module has its own options.

just thought I should comment on this, perhaps more data helps somebody…

I had the same problem, trying to do a network install of openSuse 11.0 on a brand new machine (core2duo, 4 GB ram, 2x500GB HD@sata, nForce4-based mobo). I didn’t see the full error (to quick , no camera), but it wrote “yast got signal 1 at ycp file storagecontrollers.ycp” over the screen.

After reading this thread, I removed all old partitions on both harddrives (previously held both windows and suse 10.3 and dmraided partitions), then the installation worked without problems. Btw, I had no problems installing this machine with 10.3.

I’ve had this problem a few more times. Each time deleting the partitions before running the install has worked.

Glad this has helped someone.