Suse 11 freezes?

Hi, I have installed Suse 11. The install was probably the best I have ever seen, faultless. However, when I fire up Firefox it freezes after several minutes. I tried using the Konqueror browser and got the same result. Solid lockup. Any thoughts/help would be gratefully appreciated.

AMD 3800+ dual core
Asus Mvn-vx
2 gig Kingston
80 gig Seagate Sata2
Nvidia 6200 le.


Forgot to say. I am using Kd 3.5 desktop.

Is it just FF or K that freezes or the whole system? In other words, do you still have any control: ie; mouse, keyboard.

Open a terminal and enter “firefox”. Do you get any errors?

Thanks for your reply.

Total lockup.

I rebooted since writing my question . Booted using Vesa and for a couple of minutes it appeared flaky, i.e. pressing the mouse select button it would hang for several seconds, then do what the mouse had told it to. But since then (probably a couple of hours) it’s been good.
Looking like the Nvidia?

Still running prob free after several hours of constant use. I think this would point to the Nvidia driver being the prob.

Is this a new install then?

Think it out. Or have you made any changes recently.

If you install the nVidia driver manually, you can choose your driver. Might be worth a shot that.

Download some older or even newer versions than in the repo. (delete the repo installed driver) Place one at a time in /home/username

and follow this:

Alright so here is how to install the nvidia driver manually, in case the one in the repo doesn’t work or u just want to use the latest.

Go to Yast>Software>Software Management

Search for and install if you don’t have these:


Now download the latest Nvidia driver:

Place the file in your /home/username

Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3
At the login

Type “root” then enter and then your root password and press enter.

now type
cd /home/username

*Now remember you can use the {TAB} key to auto complete

so type:
and the whole file name should auto complete

eg: sh

Follow the installer and let it compile the kernel module for you.
Say Yes to everything
Use TAB to move around

Hi , thanks for your reply . It was a new clean install. I d/l, burnt the dvd and then installed. As stated above the install was perfect, one of the best I have ever seen.I had inserted a Nvidia card (my brd has an onboard Viachrome9, but after reading that these don’t work to well i went for the Nvidia) prior to installing.
I was using the safe boot yesterday and followed your instruction re downloading files, but as yet haven’t proceeded with the recompile?. The reason being this morning I booted into normal mode a couple of hours ago and the comp has been running perfectly,
so I will keep it as it is until such time it plays up.

I f you post your /etc/X11/xorg.conf we can see what you have setup.

Also in a terminal:

paste here

Duh, Duh and Duh. Oh!How stupid am I??? or , there’s no fool like an old fool,( I’m 63 ).
I was sitting here thinking about this when I realised that when I had initially ,( right after the installation) gone into Sax2:x11 configuration the 3d box was greyed out, but at the time it didn’t register. Upon realising this I went into YaST control centre and enbled the Nvidia repositories and installed the Nvidia driver from there. So now the 3d box is ticked and It will now hopefully run smoothly.
Many thanks for your replies and help.

Agh well, such is life. It would appear not to be the graphics. Its freezing again and I don’t know where to look for error messages. Help!!!

This doesn’t really seem symptomatic of a Graphics issue. And it’s difficult too because it’s not an application crash, as usually there is an error log.

You could look in hidden /home/username/.xsession-errors

Difficult I know - But what if you don’t open any browsers and just leave it running?


Have you tried running from a terminal: top
or check the System Monitor to see what’s running. Maybe remove Beagle if you haven’t already.

Hi, I have removed Beagle. Regarding the other things you mentioned, hidden home etc, I’m afraid thats a bit beyond me. I Googled them but couldn’t find out much.
I’ll monitor the system sans Beagle and get back.
Again, many thanks for your help.
Just one more thing, if I may, the Update Icon goes from green to red and when I click on it, it says updates are ready. Yet when I click on the install button nothing happens?

In konqueror file browser click the view tab along the top and select view hidden files

go to /home/username

.xsession-errors is in there

I always quit the updater and choose do not start at boot. The thing drives me nuts.

I always manage updates manually - much better.
Yast - Software - Software Management
filter by repo
select updates repo and any showing blue text are updates (any in red are roll-backs)

All the other non official repo’s you have eg: Packman can be updated here too, just move to the packman repo in the selection on the left…

and so on, you can do them all here

you don’t have to click on each if there are loads to update
just click packages tab and then update all in this list if newer ver avail

Hi, Very fast reply, thanks.
Re hidden files. I don’t think this is valid yet, but there is an error in it :
x Error:BadWindow(invalid Window parameter) 3
Major opcode: 19
Minor opcode: 0
/bin/sh: /usr/bin/esd: No such file or directory

I am going to try running Konqueror instead of Ff. Ff crashed about 10 minutes after booting sans Beagel. I could move the Mouse but everything else was locked , requiring a restart.