[SUSE 11.4] System freezes at random times

Hi again,

It has been couple of days since I installed SUSE 11.4 on my system had some issues and I’m happy to say up to this point all those issue were solved with the help of SUSE community :). But recently I have noticed a very annoying behavior which is after sometime working with applications like browser (firefox), amarok, shell, Okular, Dolphin the system get freeze cannot do anything no keybaord interactions, no reactions from ongoing tasks it’s just freeze. I can only move the mouse pointer but no point it’s like clicking on a stone nothing happens. I have my SUSE installation up to date I can’t figure out what causing this issue.

My syatem

4GB Ram DDR3
Intel core-i3-2100 @ 3.1 clock speed
Intel DH67BL mobo
500GB Samsung HDD


Firefox 7.0.1
KDE 4.6.0

Thanks
GT540.

I second that!

It is a behaviour I have observed for quite some time, but up until the beginning of the week this phenomenon occured sparsely.
After a unintentional update of the kernel to 3.1.0-3 (from 3.0.2-x) this has gotten ridiculous.

Just yesterday I had 3 consecutive freezes which did not seem really related.

The freezes occur mostly when I’m using firefox and loading a page, sometimes too if I try to open an application. First firefox freezes and shortly after KDE. Mouse works, but I can second gt540 that the KB does not, I can’t change to shell to restart X or whatever.
I can pretty much exclude overheating as my CPU is undervolted and never exceeds 60 °C in BOINC usage.

Sometimes it looks just like the system is frozen, but if I do nothing for 2-3 minutes (just sit there watching) it sometimes returns to life again.
If I try to switch to shell (Ctrl-Alt-F1) and do it soon enough I will land somewhere in between X and shell, on a blank screen with an underscore-cursor blinking but nothing more.

Running OS 11.4 x64 on C2D E6750@2,8GHz.
Kernel 3.1.0-3-desktop
KDE 4.6.0

Most active processes in background: BOINC (various projects), TOR

One further observation I made is that when the system freezes the HDD LED will be alight constantly - whether or not this has any meaning I do not know.

On 2011-11-09 16:46, Aquinox wrote:
> Running OS 11.4 x64 on C2D E6750@2,8GHz.
> Kernel 3.1.0-3-desktop
> KDE 4.6.0

That’s not the kernel distributed for 11.4. You have changed it.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On Wed, 09 Nov 2011 14:56:02 +0000, gt540 wrote:

> I have my SUSE
> installation up to date I can’t figure out what causing this issue.

Do you have a second machine? If you do, configure the machine that’s
locking up to allow ssh connections and see if you can connect.

If you hit the caps lock key, does the state toggle?

If you hit ctrl+alt+backspace twice, does the GUI restart?

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

I used to experience a similar thing - random freezes for more than several minutes at times, sometimes just the application I was in, sometimes the entire machine. Do you notice any HDD activity while the desktop is frozen? That was my case, and it turned out I had my partitions misaligned. To cut the long story short, I had to make sure that all partitions used by OpenSuse start a sector divisible by 8. I am sorry I cannot provide a link with a relevant discussion at the moment, but if this is indeed your problem and you do some googling, you’ll find enough info.

To me the solution was to use GParted Live CD (the currently latest version), and redo my partitioning so that each partition (root, home, swap, etc.) start at a sector divisible by 8. I did not have to touch any Windows partitions, but those were already aligned properly anyway.

After that, my OpenSuse never hung again.

On 2011-11-09 21:36, hermesrules wrote:

> To cut the long story short, I had to make sure
> that all partitions used by OpenSuse start a sector divisible by 8.

This happens if you have one of the new disks with large sectors. 4KB, I think.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I thinks it’s something have to do with the Firefox because every time my system freezes I was browsing the web. Didn’t find any clue so I downgraded Firefox and relevant packages to 4.0.0-0.3.1 from SUSE 11.4 upgrade repository. Since then I didn’t get any freezes but I still have no clear idea on what causes this issue.

Thanks.

@hermes

It might have been the case for you, but I can definitely ascertain it is not for me.
Going by robin’s post I can say that my OS HDD is quite old (Samsung SP2504C) and does not have any “large sectors” (afaik), or is at least not formatted that way.

Secondly, and here I’m more like hazarding a guess, the problem has to do something with KDE (and probably FF) and maybe graphics drivers.
After I’ve updated my kernel to 3.1.0-3 my graphics were busted so I used XFCE in Failsafe mode with only “x11 failsafe” on the grub command line. This worked perfectly well.
After that I’ve installed Nvidia 285.05.09 driver and went back to KDE in the normal mode of op - the freezes came back.

Update:

I think I have found the source - at least for me.
I noticed it after the system froze again and I did a hard-reset. During startup the log showed some DRDY errors which were occuring previously for one of my other HDDs.
It looks like I changed the SATA cable for that HDD to the OS HDD - meaning that the Errors (ICRC , DRDY) occured because of a defective SATA cable.

And, the way it looks like now, were responsible for the freezes.(probably b/c some data could not be saved to disc)

@gt540
Please try a new user. Do this by creating a new user in Yast > Security and Users > User and Group Management

Logout of your current account and in to the newly created one
See how it is and report back

Also. Please post your repo info by using this code in a terminal

zypper lr -d

Paste result here

I’ll report back about new user. Here’s my repository info

#  | Alias                            | Name                             | Enabled | Refresh | Priority | Type   | URI                                                                  | Service
---+----------------------------------+----------------------------------+---------+---------+----------+--------+----------------------------------------------------------------------+--------
 1 | Compiz                           | Compiz                           | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/Compiz/openSUSE_11.3/ |        
 2 | Packman                          | Packman                          | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_11.4                           |        
 3 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/                            |        
 4 | XOrg_SUSE_11.4                   | XOrg_SUSE_11.4                   | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_11.4/   |        
 5 | google-chrome                    | google-chrome                    | No      | No      |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386                    |        
 6 | repo-debug                       | openSUSE-11.4-Debug              | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.4/repo/oss/       |        
 7 | repo-debug-update                | openSUSE-11.4-Update-Debug       | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/update/11.4/                      |        
 8 | repo-non-oss                     | openSUSE-11.4-Non-Oss            | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/         |        
 9 | repo-oss                         | openSUSE-11.4-Oss                | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/             |        
10 | repo-source                      | openSUSE-11.4-Source             | No      | No      |   99     | NONE   | http://download.opensuse.org/source/distribution/11.4/repo/oss/      |        

Tell me what you get for the following

zypper ve
zypper lu
zypper lp
zypper ve

*Loading repository data…
Reading installed packages…
Dependencies of all installed packages are satisfied.
*

zypper lu

Loading repository data…
Reading installed packages…
No updates found.

zypper lp

Loading repository data…
Reading installed packages…
No updates found.

Try logging in to a IceWM session

This how you switch session: http://dl.dropbox.com/u/10573557/Session%20Login/session.type.png

IceWM is minimal and you right click the workspace to get a menu
See if it behaves

IceWM is working fine I can right click and run any application. Terminal also working

Try using Yast > Security and Users > User and Group Management
To create a new user, and log out with current account and in to that user, in to kde and try it out. Does it work?

Yes working but the freeze didn’t come because it happens randomly.

Then you need to keep testing over some time to get a report back to us

System freeze today when I was browsing the internet with newly created user account (as you suggest). Anyway /var/log/messages outputs this error at exact time when freeze happened.

 kernel:  4794.460088] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU idle, missed IRQ.

I have also opened a new thread regarding this error
[SUSE 11.4] UNSOLVED issue “System freezing”](http://forums.opensuse.org/english/get-technical-help-here/applications/467813-suse-11-4-unsolved-issue-system-freezing.html)

Try googling this part
drm:i915_hangcheck_elapsed] ERROR Hangcheck timer elapsed… GPU idle, missed IRQ.