suse 11.4 install and invalid screen settings

SuSe 11.4 install problem

I’ve installed 11.4 and have the following sequence of events

power on - dell hardware boot options


choice of

standard suse boot
safe mode
windows 1
windows 2

choosing standard goes through a boot sequence
but leaves me with a invalid screen setting
wiith a scrambled display.

are there any options I can provide grub with that will
enable me to boot and trouble shoot the system?

grub has

vga = 0x348

the graphics are

nvida geforce 6150se


dell 22 inch widescreen

SuSE 11.1 worked fine.

the windows side works fine.

Try the failsafe option
Then run this if you can
nVidia Driver via Repo in 11.3 & 11.4 - Guide

The link you provided provided a starting point.

Doing a google search on

→ http download nvidia opensuse

provided a link to

Additional package repositories - openSUSE

which in turn provided a link to


which in turn provided a link to

SDB:NVIDIA the hard way - openSUSE

which had the following information


Disable Kernel Mode Setting (KMS)

openSUSE 11.3 uses KMS by default, which is not supported by the proprietary Nvidia driver, therefore you have to disable it.

Add nomodeset to the boot options in /boot/grub/menu.lst

^^^^^^^^^        < Change 1                                           
|||||||||               <

Also remove it from the initrd.
Edit /etc/sysconfig/kernel and set NO-KMS-IN-INITRD = yes . Then run:

                               ^^^^^^^^^^^^^^^^^^^^^^     < Change 2
                               ||||||||||||||||||||||                       <



starting the system in safe mode enabled me to make the above changes.

The system now boots normally.

I am now trying to resolve another issue.

The monitor is a

→ Dell sp2208wfp

and the native resolution is

→ 1680 * 1050

The install chose

→ 1400 * 1050

and the native resolution is not available
from any of the various system routes.

The monitor is correctly identitied
by the install.

Any thoughts?

Should I start a new thread?

Wow! Can we see if you’re using the nvidia driver now:

rpm -qa | grep nvidia
lsmod | grep nvidia 

i just took a snapshot using rpm -qal and did a sort. here is a grep on nvidia


here is the output from uname

uname -a
Linux linux-j0ta #1 SMP PREEMPT 2011-02-21 10:34:10 +0100 i686 athlon i386 GNU/Linux

was this what you wanted to know?

any thoughts of using 1680 * 1050 ?



I didn’t mean

rpm -qal


rpm -qa **|** grep nvidia

This is a vertical vertical bar (called a ‘pipe’) between two commands.

And I also wanted to know if the nvidia module was actually used, which the following command would tell:

lsmod **|** grep nvidia

As for the resolution, I would fisrt try to add this line in the Monitor section of /etc/X11/xorg.conf:

 Option	"PreferredMode"	"1680x1050"

Or, as you might not have this section, uncomment these two lines in /etc/X11/xorg.conf.d/50-monitor.conf

#HorizSync 28-85
#VertRefresh 50-100

and see if it makes a difference.

Use your mouse to copy and paste code if you don’t know how to type it!

Actually, the first thing I would try is to set the resolution is the Screen section:

Section "Screen"
  SubSection "Display"
    Depth       24
    Modes       "1680x1050"             

And if it doesn’t work, also use the following in the Monitor section:

Option	"PreferredMode"	"1680x1050"

linux-tmec:~ # lsmod | grep nvidia
linux-tmec:~ # rpm -qa | grep nvidia
linux-tmec:~ #

linux-tmec:~ # lsmod | grep nvidia
linux-tmec:~ # rpm -qa | grep nvidia
linux-tmec:~ #

here is a listing of the /etc/X11 directory

linux-tmec:/etc/X11 # ls -la
total 80
drwxr-xr-x 11 root root 4096 Apr 26 18:19 .
drwxr-xr-x 127 root root 12288 Apr 26 18:58 …
-rw-r–r-- 1 root root 1353 Apr 12 2003 Xmodmap
-rw-r–r-- 1 root root 1049 Jun 20 2001 Xmodmap.remote
-rw-r–r-- 1 root root 4017 Apr 22 2009 Xresources
drwxr-xr-x 2 root root 4096 Apr 26 18:19 fs
drwxr-xr-x 2 root root 4096 Apr 26 18:19 lbxproxy
drwxr-xr-x 2 root root 4096 Apr 26 18:19 proxymngr
-rw-r–r-- 1 root root 954 Feb 19 06:21 qtrc
drwxr-xr-x 4 root root 4096 Apr 26 18:19 rstart
drwxr-xr-x 2 root root 4096 Apr 26 18:19 x11perfcomp
drwxr-xr-x 2 root root 4096 Apr 26 18:19 xdm
-rw-r–r-- 1 root root 5708 Feb 18 21:31 xim
drwxr-xr-x 2 root root 4096 Mar 2 12:06 xim.d
drwxr-xr-x 3 root root 4096 Apr 26 18:19 xinit
drwxr-xr-x 2 root root 4096 Apr 26 18:18 xorg.conf.d
-rw-r–r-- 1 root root 849 Apr 26 17:56 xorg.conf.install

did you mean xorg.conf.install?

linux-tmec:/etc/X11/xorg.conf.d # cat 50-monitor.conf
Section “Monitor”
Identifier “Default Monitor”

If your monitor doesn’t support DDC you may override the

defaults here

#HorizSync 28-85
#VertRefresh 50-100

Add your mode lines here, use e.g the cvt tool


where do you want me to add the following line

Option “PreferredMode” “1680x1050”

do i just edit it or use the cvt tool as suggested?

it would seem that there is no equivalent of sax2 in
suse anymore and thus one has to rely on the install
getting things correct.

You came up with nothing?
Then go back to post #2

Wait a minute!

  • If you type the first command and the output is blank, it means that the nvidia module is not loaded.
    Here’s what I get on a machine using the nvidia proprietary driver:
# lsmod | grep nvidia
nvidia              11095262  28

The output may vary but you should at least have one line of output containing the word “nvidia”

  • If you type the second command and the output is blank, it means that you haven’t installed the nvidia package, which might not be required since there are other ways (called ‘the hard way’ here) to install the nvidia driver. But if you installed the nvidia driver from repo, you should get this output (or a similar one) :
# rpm -qa | grep nvidia

That’s why I wanted to make sure that you were using the nvidia driver before explaining you what to change in /etc/X11/xorg.conf - which is by the way seldom necessary.

I did the nvidia driver install and have got the 1680*1050 screen resolution!



Well done