SuSE 11.3 Installation : Monitor "out of range" problem

Hi,

I am installing SuSe 11.3, and during the initial boot after installation, I got “out of range” message on the monitor and nothing happens afterwards. I am a newbie.

My PC is dual CPU (intel), Video card is " nVidia N240GT" and the monitor is Gateway flat screen “FPD2485W”.

I tried both interfaces (gnome and KDE) and got the same problem (“out of range”).

How should I get over this problem?

Thanks in advance,

Dennis M.

I had the same problem with a nVidia 240 GT. Also, I found the sound support worked, but was spotty at best in reliability. I suggest you use the built-in motherboard sound, if that is an option. As for the video, try using a VGA only connection to your monitor and do not use DVI for the installation/setup phase only (install and after the first reboot, then the switch back to DVI or HDMI is OK). What you want to use is the VGA connection on the monitor and a VGA to DVI adapter on the video card is OK to use. The card I tried was from PNY and it included HDMI-VGA-DVI on the back. Once the nVidia driver is loaded as mentioned below, any monitor supported by this card will work with openSUSE.

I suggest it is best to add the kernel load option nomodeset, right off the bat during the install. I add it during the install phase, when you have an option to modify your boot order and other such things. If you look at the /boot/grub/menu.lst file you will notice the nomodeset command is present in the failsafe entry, so just duplicate that one command for normal startup. Once you get openSUSE installed, you are going to need to download and install the very latest nVidia proprietary binary driver, which is free. Here is a small writeup and as well as a web page I suggest you read before installing the nVidia driver:

SDB:Configuring graphics cards - openSUSE

Then, take a look at the procedure I use to install the nVidia driver as I install openSUSE 11.3:

  1. During the install, when you have the option to change your booting setup, I add nomodeset to the kernel load command for the normal load/start of openSUSE. This kernel startup option is already present for the Failsafe selection for openSUSE.
  2. During the first start of openSUSE, I download the latest nVidia Video driver to the downloads folder.
  3. I change/save the System/Kernel option NO_KMS_IN_INITRD from “No” to “Yes” in the /etc/sysconfig Editor in Yast.
  4. I do an update of openSUSE on the first run of openSUSE and then a restart/reboot.
  5. In grub OS selection I add the command line option “3” to the openSUSE start line so that I just go to the run level three terminal prompt.
  6. I login in as root and change to the /home/user/Downloads folder.
  7. I run/install the NVIDIA video driver using “sh ./NVIDIA-Linux-x86_64-256.44.run” and answer all questions as appropriate for my system.
  8. Type in reboot at terminal prompt to restart the system with new video driver.

Thank You,

Hi James,

I have followed all the steps that you advised.
Now, I at the point of running/installing the NVIDIA video driver using “sh ./NVIDIA-Linux-x86_64-256.44.run”.
I am doing at run level 3 (at command line as root) and I got the following error, which has something to with “Kernel Source Tree”, which I know nothing about:

creation time: Sun Aug 8 01:19:24 2010
installer version: 256.44

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
no cc version check : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
compat32 install chroot : (not specified)
compat32 install prefix : (not specified)
compat32 install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
→ License accepted.
→ Installing NVIDIA driver version 256.44.
→ Performing CC sanity check with CC=“cc”.
→ Performing CC version check with CC=“cc”.
ERROR: Unable to find the kernel source tree for the currently running kernel.
Please make sure you have installed the kernel source files for your
kernel and that they are properly configured; on Red Hat Linux systems,
for example, be sure you have the ‘kernel-source’ or ‘kernel-devel’ RPM
installed. If you know the correct kernel source files are installed,
you may specify the kernel source path with the ‘–kernel-source-path’
command line option.
ERROR: Installation has failed. Please see the file
‘/var/log/nvidia-installer.log’ for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at Welcome to NVIDIA - World Leader in Visual Computing Technologies.

Please kindly advise me what should I do next.

Thanks in advance,

Dennis M.

Install kernel-source and kernel-syms of the exact same version number as your kernel version and try again:

su -c 'zypper in kernel-source kernel-syms'

HI puzzled Penguin
HOpe i can help . It is abit long winded but this is how i solved a similar problem

How to configure a Monitor Display not detected.Video Display out of range on opensuse 11.3 to make them permanent stick using xorg.

Please no criticising me for I am a noob too:P.
This approach is a combination of several ideas i obtained from many sources on the net for each individual one did not work.

Disclaimer: Do this at your own risk i shall bear no responsibility for any damage to your hardware or software or losses you make.
Long live Opensuse but make life easier for your subjects.

I used Xorg.conf because it loads almost at the very beginning of start up thus is systemwide.

SAX2 is no more in Opensuse 11.3

Procedure

After installing Opensuse 11.3 for the first time, if your monitor is not recognised you will get a dark and blank screen , then a notification saying Video Display out of sync. shows the vertical and horizontal sync ranges

  1. At this point simultaneously pressing Ctrl,Alt and + several times cycles you through several screen resolutions till you reach one that suits your monitor.

Proceed and either complete the installation or log into your computor.

  1. Next Go to the Kicker icon ( Green icon with chameleon head on the lower left corner of your screen). Klick it and then Select Configure Desktop.

  2. Next Go to the icon labelled Display and in the Size and Orientation section change the Size to the lowest resolution i.e 1280x780, Apply and then accept. Use this section to set up the best display resolution for your computor.

  3. Next open the terminal and type “xvidtune” without the quotes.
    This will open A grey dialogue window , dont change anything.
    Just note and write down the Horizontal sync (Khz) and the Vertical Sync (Khz) figures .
    Click quit to exit.

  4. Next Step is to create a Xorg.conf if none is created automaticallyfor you.

Restart your Computor and at the grub screen.Press arrow up or down to select your default OS i.e Opensuse 11.3
Backspace to delete everything in the editable space and Write the number 3 instead.
Hit return after making sure the number 3 is still there.

Your system will boot into the commandline display where we are going to create xorg.conf.

  1. At the login prompt. Enter your user account name and hit enter.
    Then enter your password.(Go on even if you dont see any asterixes or stars. make sure it is the correct one)
    When your successfully logged into your account in command line
    At the command promp : Type the following command without the quotes.

“Sudo xorg -configure”
Type the administrator password or your account password if you did not aet up admin passwd.

this action will create a new file xorg.conf.new in the /root/

With the next command we shall copy the xorg.conf .new to /etc/Xll(remember Capital X and small letter ll)

sudo cp /root/xorg.conf.new /etc/X11/xorg.conf

Exit and reboot your computor and login in straight to your user account .

In case you get the black screen with the sync out of range message repeat steps 1-3.

  1. Next Open terminal and type

sudo kwrite /etc/X11/xorg.conf ( use whichever editor convineient for you)

This will open Xorg.conf with write permissions so that you can proceed to edit the file xorg which contains the settings you need.)

Now in the xorg file look for a sub section heading “ Monitor”
where you see the following , HorizSync 30 - 80, VertRefresh 50 - 100 substitute the ranges with the figures you wrote down earlier in step 4. So it will look like this when you are done.
HorizSync 64 ( for my computor)
VertRefresh 60

Scroll further down and look for something like this:
SubSection “Display”
Viewport 0 0
Depth 24
On my comutor there were several , but i chose the one with Depth 24( its what seemed to work. Experiment!!)

So below the Depth 24 and the resolution which worked for you best in step 3. like this.
SubSection “Display”
Viewport 0 0
Depth 24
Modes “1280x1024” ( keep the quotes on)

Save your file in /etc/Xll/

  1. Shut down and reboot and you should be good to go.

Disclaimer: I claim no credit for this work. Each separate section is credited to whosoever came up with the original idea . I just picked and put together ideas i got from the internet.