suse 11.3 - flash player no sound

Ηello,

I cannot hear anything from flash player or firefox

ANT1 WEB TV /

no sound

Definition of pending adjective from Cambridge Dictionary Online: Free English Dictionary and Thesaurus

I cannot hear the pronunciation of the world. Τhe sound chip (Realtek ALC88B) is embedded in the motherboard. I think the problem started after an update.
YaST2-> Sound Configuration

SBx00 Azalia(Intel HDA)

* Configured as sound card number 0
* Driver snd-hda-intel

Radeon X1200 Series Audio Controller

* Configured as sound card number 1
* Driver snd-hda-intel

on the down right corner

Other-> PulseAudio_Configuration
an error message apears PulseAudio is not installed or cannot be configured.

if I try to install the package alsa-plugins-pulse
Warning:

!alsa-plugins-pulse-1.0.23-1.9i586 requires pulseaudio, but this requirement cannot be provided.

Yiannis P.

So I don’t know if your problem is a Sound Card issue or if you don’t have flash installed properly or just a general codec problem. I like the fact that you placed pointers to the web page sound in question. I needed that to make sure the issue was not with the web page. Just because a web page makes no sound does not mean the problem is with your computer. That was very smart thinking.

I have two script files that you can run that might help determine your problem, but your must take the effort to download, activate and use these script files if you want our help. As always, these files are totally free and you get the source files to look at and even modify should you get interested in bash script programming. The first file is called START and is used to check out your sound card:

S.T.A.R.T. - SuSE Terminal Audio Reporting Tool

The next script file is called mmcheck, which is designed to check your audio codecs and things like flash installation:

MMCHECK - Check Your Multimedia in 10 Steps - Script File, as proposed by RedDwarf

Message #40 has the most recent version of mmcheck for you to use. If you get through these two script files, you should have a better idea of what the problem or fix might be.

Thank You,

the output from the first test:

1 . Verify your Alsa Packages are installed for Operational Testing …

rpm --query --all --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ alsa alsa-utils alsa-firmware ‘libasound2*’

alsa-utils-1.0.23-1.8-i586 -> openSUSE
alsa-1.0.23-2.12-i586 -> openSUSE
libasound2-1.0.23-2.12-i586 -> openSUSE

You should expect to have at least four Alsa Packages Installed.
32 bit files are not required when using 64bit openSUSE install.

called ----> alsa-utils <--------- from the openSUSE Repository.
called ----> libasound2-32bit <— from the openSUSE Repository.
called ----> alsa <--------------- from the openSUSE Repository.
called ----> libasound2 <--------- from the openSUSE Repository.
called ----> alsa-firmware <------ from the openSUSE Repository.

Press <enter> to continue…

Yiannis P.

I’m not able to play most the videos on that page as they require one register, which I am loathe to do. I do note the sound from the advertisement page works with no problem, albeit it is IMPORTANT one click on the unmute sound on the video, as by default the video audio is muted.

Could you also look at post#5 and #9 in this thread (re: helping with Flash) No sound in Flash videos so that I can try help, with out forcing me to completely retype my previous posts.

Thanks!

I had a problem recently when I installed a new motherboard (Asus M4A785TD-V-EVO) with Via VT1708S Hi def audio. Also plugged in a Creative X-Fi sound card. Found I could only get Amarok to make a noise. But then disabled the motherboard sound and suddenly it all worked, including Flash. Just thought it might help.

When one has two sound devices on one’s PC, the order of sound devices is important in order to get flash to play audio. For example on KDE, one needs to ensure that the following order is the same:

  1. 1st sound device listed in YaST Hardware Sound, is the same as
  2. 1st sound device listed under KMENU > Configure Desktop > Multimedia > Music
  3. 1st sound device listed in the output of the diagnostic script:
/usr/sbin/alsa-info.sh 

Typically only the 1st two are necessary, but I’ve seen cases where the 1st two were the same, and the 3rd was different, and in that case one needs to edit their 50-sound.conf file with an appropriate edit to force the correct order of sound devices. I’ve only just recently learned what the required edit is.

I simple removed the device:

SBx00 Azalia(Intel HDA)

  • Configured as sound card number 0
  • Driver snd-hda-intel

and everything is working fine, maybe I have problem with the TV card or High Definition but I don’t care.

I simple removed the device:

SBx00 Azalia(Intel HDA)

  • Configured as sound card number 0
  • Driver snd-hda-intel

and everything is working fine, maybe I have problem with the TV card or High Definition but I don’t care.
Another happy self-serve customer then. lol! I guess we can call this solved.

Thank You,

"I had the similar problem with the sound …
I solved it doing the following:
1)Open terminal;
2)On the command line type alsamixer and press enter;
3) Use the right arrow key to navigate PCM and then use the UP arrow key to up the the volume.
4)Try now youtube now or other “flashy” site

I don’t know why the PCM volume was set to 0…

OpenSuse 11.3, KDE

No audio from the Firefox browser, youtube videos, etc. Amarok is working fine (also system sounds work)

Audio: Realtek ALC889A (onboard audio)

In Yast, Device 0 is
82801J1 (ICH10 Family) HD Audio Controller

  1. Kmix, everything is at 100% except the mic.

  2. Software management - Updated the Adobe Flash Plugin and Standalone Player

  3. Ran mmcheck and nothing jumped out at me. It shows the two entries (above) for the Flash Player. However, there are 11 repositories, not 4 and it complained about this. Mplayer and Splayer are not present. I couldn’t find any conflicting dependencies.

  4. In multimedia system settings, the ALC889 Digital S/PDIF is #1 in all categories, including music. (again, Amarok works). This is also reported as Device 0 by this dialog. Test button works fine in every output category, good audio is heard.

So we can better understand your setup in your openSUSE-11.3 KDE, what is the output of:


aplay -l

Note the order of sound devices in KMenu > Configure Desktop > Multimedia should match the order in YaST > Hardware > Sound.

The problem with 11 repositories is if you do not know what you are doing you can easily break something, and not have a clue why.

Whew, some quick replies, appreciated. I am -or was - an old hand at UNIX, but that was System V Vanilla. BSD was as daring as we got in those days.

Index 0 in Yast->Hardware->Sound is: 82801JI (ICH10 Family) HD Audio Controller. Two following entries are for the NVIDIA board HD audio.

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC889 Analog [ALC889 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC889 Digital [ALC889 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

Hmm … ok so for playback you have hw:0,0 (analog) and hw:0,1 (digital). It looks nominal.

In particular if system sounds work and amarok sound works, then so should firefox.

I know you checked the mixer, but please check again while Firefox is playing a video. ie when playing a video with Firefox from say Youtube, look again at your mixer, and ensure the Master volume, PCM volume and any Speaker Volume is turned UP. Often the PCM volume will dynamically and unexpectedly drop to zero when firefox is started, and one needs to move the volume levels back up.

The audio is not being muted or adjusted during playback, unless Kmix is not displaying it dynamically.

Some new information, things I discovered this morning:

  1. Audio for videos played via Firefox is being routed to the headphones (analog device).
  2. Amarok is correctly following my device preferences (in the multimedia setting). When I make the analog device #1, it also plays through the headphones.

I switched the two devices and tested it, then switched them back (to speakers #1 slot, #2 headphones) hoping to “force” or rewrite any config files that might be overriding the device for the video playback, but no luck.

I don’t have a .asroundrc. It’s not where alsa doc says it should be, but maybe the alsa doc is obsolete. The only .asoundrc I found is at

/usr/share/doc/packages/alsa/alsa-lib/asoundrc.txt

I don’t comprehend most of the file as of yet.

This issue is also occurring in Kaffeine, it’s not exclusive to Firefox.

So, to recap: video audio is being routed to the headphones, no matter what the multimedia settings are.

Thats good progress !! :slight_smile: … it means the difficulty has been narrowed down to the sound being routed to the wrong device !

If this was openSUSE-11.4 with pulse audio enabled I would recommend installing the application ‘pavucontrol’ (and then run that app) which provides superb control over directing the sound in audio devices. However in the case of openSUSE-11.3 without pulse audio, one likely does either need to better tune the KMENU > Configure Desktop > Multimedia settings, or one may need to put in place a custom /home/username/.asoundrc file.

Thats because you normally should not need a .asoundrc file. The correct location for that file is /home/username/.asoundrc .

I also do not know anything about a .asoundrc file structure to provide any advice there. You have stumbled across one of the reaons why the developers were keen to implement pulse audio, as this sort of audio redirection is easier in pulse audio. Unfortunately for the first 2 or more years after pulse first appeared, it was (and some say still is) buggy.

The issue with Kaffeine is possibly different. It depends on your KDE settings. Under KMENU > Configure Desktop > Multimedia, what do you have set as the audio backend ? Do you have the ‘xine’ engine set?

If so, then you need to tune the xine engine. :slight_smile: … Fortunately this is not difficult (once on knows how).

Ensure your version of ‘libxine1’ is a Packman packager packaged version and NOT a SuSE-GmbH packaged version. Also install the xine user-interface for xine called “xine-ui”.

Then start “xine-ui” and play a video with it. Do you have sound ? If not, right click on the “video” and select ‘settings’ and change to “master of the known universe” for permissions. Close xine. Start again with higher permissions. And tune the output audio mode. Sometimes the ‘oss’ settings work better than the ‘auto’. Or the ‘alsa’ settings may work better. Note when choosing the ‘oss’ settings you are chosing an alsa sound drive API emulation of OSS and not actually chosing the oss sound driver.

xine-ui-0.99.6-1.pm.2.3-x86_64 -> PackMan :: Startseite
libxine1-1.1.19-2.pm.48.16-x86_64 -> PackMan :: Startseite
libxine1-codecs-1.1.19-2.pm.48.16-x86_64 -> PackMan :: Startseite

Installed xine-ui. It looks sweet, but there’s a bad problem.

Whenever I access settings, as soon as I select one and it opens a smaller dialog list window, xine-ui wedges the entire system. (><). Once I was able to vulcan neck pinch it and get to a reboot command; the 2nd time I had to hard reboot the computer. Even changing something as innocent as the xine-ui skin does it.

By wedging I mean it bottlenecks or slows down the entire desktop to the point where it appears to have crashed. Or it does crash.

I tried editing the config file directly, but xine-ui seems to ignore my changes. I’ll keep looking at that. xine-ui is playing videos allright, it’s coming out over the headphones.

Indeed xine-ui is unstable. Start it (ie type ‘xine’ ) . Right click > Settings. Go to the ‘audio’ tab > audio driver to use, and change the audio mode to OSS.

Don’t try to explore the UI further. Close it. Restart your PC. Test. Don’t try to explore that ui as its stability is really really bad.

If OSS does not work, then again run xine and try changing the audio mode to ALSA.

Neither the OSS setting or alsa changes the behavior; video audio is still routed to the headphones no matter what the multimedia settings are at. A

After the alsa setting & tests, xine would wedge the computer any time I tried to access that menu again (to change it back to Auto). Even failed to boot one time, which was scary.

I finally got it changed back to Auto.

At this point I think I’m just going to live with it until a future OS upgrade.