suse 11.3 can't see wireless lans

Hi everybody:

Just installed opensuse 11.3 on a Dell laptop.
NetworkManager and Ndiswrapper, allready instaled(last updated versions), but suse can not detect or see any wireless lans.
Can anybody help?
Thanks for your help?


Hi and welcome to the forums.

There’s no detail for us to go on. So the problem could be any one of thousands of things. The best thing is to refer you to this sequence of diagnostic steps here: My wireless doesn’t work - a primer on what I should do next

and this makes good reading too: Getting Your Wireless to Work

Then you’ll be able to give us information that will allow us to help you.

I had the exact same problem. If it’s a Broadcom wireless card add

to your repositories. And then run

zypper in broadcom-wl broadcom-wl-kmp-desktop

in a terminal as su.

as they said we need more info to tell where the problem is. So we can tell if the driver is loaded or how far through the process of getting it to work you have gotten

I followed swerdna’s what to do next but can’t determine what adapter I have. It’s not broken wither because it’s set up for dual boot and win7 wireless works just fine.
I checked ‘/usr/bin/lsusb’ & ‘/sbin/lspci’ - no string “wireless,broadcom” or anything other than network or ethernet controllers.
I can post the outputs.
switched to win7
Win7 reports that it’s using an intel PRO wireless.

neither /sbin/lspci or /usr/bin/lsusb report intel PRO

I see that openSuse 11.3 software manager knows about intel PRO firmware.

now what?

i switched back to win7 and found my wireless uses the Intel Centrino Advanced-N 6200. From that I could line up the numbers like in the instructions.
Here’s the line from lspci -n => 43:00.0 0280: 8086:4239 (rev 35)
I checked dmesg | less and it looks like iwlagn found it and installed OK.

Here’s a strange one: I went into Yast->Network Devices->Network Settings and got a warning dialog that states “Network is currently controlled by network manager and its settings can not be edited by Yast. To Edit the settings, use Network Manager connection editor or switch the network setup method to traditional with ifup”

What’s Network connection manager?
What does this mean?

I found an applet called knetworkmanager and ran it from sudo and it crashed:
“Can not find the D-Bus session server” “/bin/dbus-launch terminated abnormally with the following error: Autolaunch error: X11 initialization failed”

Please post here this information: open a terminal and enter su (to get rootly powers), then enter these:

  • lsmod | grep iwlagn
  • iwconfig
  • lspci -nn | egrep “etwork|thernet”

and copy the responses back here, enclosing them in the code tags (use the # button)

I think you have maybe a wireless interface that senses the wlan but it’s not configured yet, maybe, so we shall see from those data, maybe :slight_smile:

I had 2 problems; no wireless LAN & intel video trouble.
During the install, when it restarts the notebook as soon as it starts back I lost video. So I crossed my fingers and hoped all installed because I couldn’t see what was happening.

Then I had to shut it down with the power switch and boot in “failsafe” mode. I tried all the ideas here to no avail. Then I reinstalled (from scratch) but checked autologin and ended up with no video. But after shutting down when I return to the grub menu, if I either boot into “failsafe” mode or enter “nomodeset” for the normal boot it comes up and networkmanager works and so does 802.11.

Wireless works.

Before, Yast-network devices-network settings said network manager was in charge and when I went to network manager it said it was disabled!

Guess I need to figure out my intel video problem now.

BTW, this is a very new notebook (hp Elitebook 8440p) and I can’t get 11.2 up with video at all.

this out of lsmod:
iwlagn 215599 0
iwlcore 265091 1 iwlagn
mac80211 243337 2 iwlagn,iwlcore
cfg80211 155663 3 iwlagn,iwlcore,mac80211

this from iwconfig:
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:“linksys”
Mode:Managed Frequency:2.437 GHz Access Point: 00:18:39:FD:61:09
Bit Rate=1 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=70/70 Signal level=-30 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

this out of lspci:
00:19.0 Ethernet controller [0200]: Intel Corporation 82577LM Gigabit Network Connection [8086:10ea] (rev 06)
43:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6200 [8086:4239] (rev 35)

**probably not necessary now, eh?

No, not necessary now, well done

When you first go to install, include nomodeset in the prompt and check auto-login.
I have video at the end of the installation and my wireless works!

Of course once up, you need to edit grub to include nomodeset in the normal boot line.

No more shutting down in the dark.