Suse 11.3 and KDE 4.4.4 multi monitor support

I have not checked for a while but did, before posting this, do a search for multi monitor support with KDE 4.4.4 and found nothing.

From what I understand 11.3 is out sometime next month and KDE 4.4.4 is the KDE environment that will be released with that iteration of SUSe.

About a month ago I read about a number of problems with multiple monitor support under 4.4.4. Primarily these issues seemed to be with no more than 2 monitors. The SUSe 11.2 machine here uses KDE 4.3 runs three monitors (Intel core quad, pair of NVidia PCIe graphics cards). I was wondering whether any of the bugs with this type of configuration have been resolved. From what I understood 4.4.4 worked with problems using Twinview but I was not able to find anything that addressed the configuration of having separate X Screens.

Thought I would post this to try to find out what may be in store for those of us who run more than 2 monitors when 11.3 comes out.


The inability two work with two Xscreens is a bummer for me too, which even made me think of switching back to Gnome. Playing around with Ubuntu 10.04, however, made me realise how addicted to KDE4 I have become… I have this nice pivoting monitor going spare, and I’d love to be able to use it in KDE (Twinview doesn’t help as you can’t rotate just one of two monitors, and RandR 1.2 is not supported by NVIDIA drivers…).

I had the same problem. Some how I randomly fixed it and now have two monitors connected with the second monitor right of the first one (not cloned). I have the GeForce 9800GT and a fresh installation of openSUSE 11.3 (only needed updates). I haven’t even installed the nVidia driver (and don’t think I will now) and am using the default one by nouveau.

I seemed to fix this by going into ‘Start button → System Settings → Display’.

When I first went into here the ‘Multiple Monitors’ bit told me that I did not seem to have it configured for multiple monitors and all buttons were greyed out. I then changed to the ‘Size & Orientation’ bit and mode both DVI 1 and 2 “Absolute” and accepted changes (nothing seems to happen). I then changed DVI-2 to “Right of - DVI-1” and accepted changes… it worked!! This is werid because I tried the “Right of” thing first but nothing happened. It seems like you need to first set them both to absolute in order to get it to recognise them as separate screens!?

Anyway, this has worked for me now and I am happy (I was just about to give up trying too!). I would be interested to know if this helps anyone else?

Gutted! Unfortunately it doesn’t remember the settings after a reboot. A bit naff really but still better than two cloned monitors!!

Same problem as crazzyfool: can set monitors with Start button -> Configure Desktop (Personal Settings) -> Display, but when I logout and log back in, the settings are gone, i.e. I have a copy of the first monitor. System is openSuse 11.3 with ATI Radeon 3100 graphics card and two monitors: one DVI (left) and one VGA (right)

crazzyfool, did you solve the problem?

anybody else?

Ive had the same issues with my dual monitor setup, with the settings being forgotten. Ive just been changing them manually on every boot.

I’ve a Nvidia 9800GT and exactly same problem. After take a time to configure my dual monitor, if I logout and login, my monitors are cloned, not sharing my desktop. I must say that my installation is an upgrade from OS 11.2, but we can be sure that that’s not the problem.

An user needed to install nVidia propietary drivers to make it work properly!!! (but with the nVidia control panel).

What happens with Nvidia and OS11.3? Problem with TwinView!

opensuse 11.3 and nvidia metamode failure

Here is a workaround worked for me to avoid the settings getting lost:

  1. set your dual head as you want using System Settings->Display

  2. Look in /etc/kde4/kdm/Xsetup the xrandr commands to configure your dual head should be saved here

  3. copy these commands into a shell script and store it somewhere like /usr/local/bin (run the script to make sure it works as intended).

You could just run this script when you login each time but we can automate this by creating a link to the script in ~/.kde4/Autostart or indeed simply link to /etc/kde4/kdm/Xsetup directly!

I have one monitor with a resolution 1920x1200 and the second one 1680x1050 left of the first one. Every time I do a restart the settings change back to 1680x1050 for both of them and they are clone, so each time I have to go to display>size&orientation and set them back to the correct values.

Any solution for this problem?

Have a read of this thread.

I have a system with 2 evga graphics cards with Navidia bios, each card designed to support two monitors one digital, an done analog. I have this set up with 4 monitors. Windows has no problem finding and using all four monitors. SUSE can see both cards, but does not see the monitors connected to the secondary card. Both cards are identical PCIE cards. How to get SUSE to see and display all four monitors? I am running 11.2. 11.3 loses all video during the installation process and I cannot get it back.


I am running a similar setup. 2 GE Force 8500’s on PCie, an Intel motherboard with a Core Quad processor. I experienced no problems configuring the machine to work across 4 monitors under 11.2 --which I am still running. After reading about problems configuring multiple monitors under 11.3 I elected to wait and see what the next release was like. I am going to try 11.4 on a second hard drive on another platform here-also multiple monitor…an EVGA X58 Classified motherboard with a pair of GTS 250’s running 4 monitors. If that goes well I will upgrade the quad machine to 11.4 as well. I use the quad in a semi production environment for things like e mail, browsing and chat. Im looking forward to playing with 11.4 since I elected not to try 11.3 because of my monitor configuration.

It might be an idea to wait for 11.4 and try that. Hope this helps.

@owly: You might benefit from reading the following guide

SDB:Configuring graphics cards - openSUSE

Your system has nvidia graphics cards installed, is that right? If so, then once you’ve managed to install openSUSE, you could try using the proprietary nvidia driver instead


@expat1: If you have a working xorg.conf, make sure you back it up before upgrading. It may well be useful to get your graphics cards properly configured with the new OS version.


Many thanks for the reminder. I dont want to think back to how many times I have edited xorg.conf by hand…

This leads to another question. I understand (possibly erroneously so) that the configuration architecture for 11.4 is different from 11.3 and more similar to 11.2. My understanding of 11.4 is that there is an /X11/xorg file for each device on the machine i.e. one for the mouse, another for the monitor, another for the keyboard, another for the graphics adaptor &c. I do not know how accurate this is.

In 11.2 I use the proprietary NVidia driver with its configuration tool and have had great success in getting the displays configured in this method. Any comments or suggestions would be appreciated.

Regards and tia.

The Xorg version used with openSUSE 11.3 is X.Org X Server 1.8.0. The configuration files are located in /etc/X11/xorg.conf.d/, and essentially the former xorg.conf sections now reside in their own individual files (eg 50-monitor.conf, 50-screen.conf). However, for the moment /etc/X11/xorg.conf is still recognised, (and has preference over), the new config files, if it is present. The proprietary driver config tools still use xorg.conf entries, however this will change over time.

I thought 11.3 used something called Xrandr to handle configging X. From the little I have read about it, it seemed totally different than 11.2. I was under the impression that 11.4 was as you describe for 11.3.


The config files are largely not needed for input and display hardware that get auto-detected correctly. For graphics drivers , RandR compliance is required for this to work properly. (The only change that I’m aware of is the move from HAL to udev input handling). However, as with 11.2, xorg.conf entries are still respected if present.

[Phoronix] X Server 1.8 Release Candidate Is Here](

[Phoronix] X.Org Server 1.8.0 Is Here](