SuSE 11.3, 965GM graphics, external VGA not even detected

Hello all,

I got some troubles with my external VGA output of a Notebook. I tried various things (see below) but now I ran out of ideas. I studied the sticky post in this forum about configuring graphics cards but unfortunately this gave me no new hints.
Is here anyone who could give me further hints or advice … ? Thank you already in advance!

My System:

Fujitsu Siemens Lifebook E Series
OpenSuse 11.3 (i586, 32Bit)
Graphics: Intel 965GM
I found lots of questions and solutions concerning the 965GM but they all are just about configuring the VGA monitor/screen in Xorg.conf.d / xrandr. I’d LOVE to do so but in my case the VGA outout isn’t even detected for some reason (please see details below)

Summary of my findings up to now:

  • xrandr version 1.3.2, (1.3 reported by the X server) does NOT detect the VGA output device at all (xrandr -q). I always get only one single entry “default”, connected to 1280x1024 which is the built in LCD screen. I expected at least two entries (LVDS and VGA or something like this)

  • I checked the BIOS settings for the external VGA output which is “auto”. The available options there are “auto”,“external vga”,“external dvi” and “internal”. Setting to external vga brings up the picture (including the boot messages) on my VGA monitor. Therefore I know that the VGA output itself seems to work. However, I don’t want to use this setting since I’m blind as soon as I unplug the VGA cable… I guess that the setting “auto” is the right one?

  • For some reason the xorg.conf.d settings by default do not specify a specific device type for the graphics device. Whatever driver the X server then uses … the systeminfo says “fbdev” for 2D, “swrast” for 3D. Anyway, this configuration is the only one that works at least for the LVDS up to now.

  • The intel driver xorg-x11-driver-video-intel-legacy is installed in version 2.9.1-1.9-i586 which seems to be the latest one of the SuSE repository

  • Whenever I specify the option Driver “intel” in 50-device.conf of the Xorg config, starting the X server fails. It then claims that it found screens but no usable configuration for it. This already happens by just specifying the driver in the default config, even without messing with monitors or screens.

  • Xorg.log shows at least two devices, one on PCI:0:2:0 and the other one on PCI:0:2:1. This gives me some hope that the VGA output is at least known to the system. Also YaST system info shows me two graphics adapters.

    15.091] (--) PCI:*(0:0:2:0) 8086:2a02:10cf:13f5 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller rev 3, Mem @ 0xfe000000/1048576, 0xe0000000/268435456, I/O @ 0x00001800/8
    15.091] (--) PCI: (0:0:2:1) 8086:2a03:10cf:13f5 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller rev 3, Mem @ 0xfe100000/1048576

  • I tried to set up a new device in xorg.conf.d using the second bus number. I also defined a monitor and a screen on it. After some typos the edited configs were accepted by the X server but that does not change a thing. The VGA output stays off and xrandr still does not show a second entry.

Beside this a small note:

  • I need to set nomodeset in the bootloader options to avoid a blank screen after booting. But this is not my problem right now. I also added vga=0x31b to get the full resolution on bootup. The behavior of the external vga output was not influenced by this (up to now).

That’s it. I ran out of ideas. The final situation is now:

  • SuSE (YaST / X server) seems to know about the second graphics output
  • xrandr does not detect it
  • I failed to build a working manual configuration for the X server
  • The VGA output is enabled in BIOS and works fine if the primary display s redirected to it (via BIOS)

This is the output of xrandr:

Screen 0: minimum 1280 x 1024, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024      77.0* 

This is the latest version of my xorg.conf.d files that I modified.

Section "Device"
  Identifier "Default Device"

  BusId "PCI:0:2:0"
  #Driver "radeon"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"
#       Driver "intel"
#       Option "monitor-default" "Default Monitor"
#       Option "monitor-CRT" "CRT"

Section "Device"
  Identifier "CRT Device"
  Driver "intel"
  BusId "PCI:0:2:1"
  Option "Clone" "true"
  Option "MonitorLayout" "CRT"


Section "Monitor"
  Identifier "Default Monitor"

  ## If your monitor doesn't support DDC you may override the
  ## defaults here
  #HorizSync 28-85
  #VertRefresh 50-100

  ## Add your mode lines here, use e.g the cvt tool


Section "Monitor"
  Identifier "CRT"
  Option "Enable" "true"


Section "Screen"
  Identifier "Default Screen"

  Device "Default Device"

  ## Doesn't help for radeon/radeonhd drivers; use magic in
  ## 50-device.conf instead
  Monitor "Default Monitor"


Section "Screen"
  Identifier "CRT Screen"
  Device "CRT Device"
  Monitor "CRT"

I deeply appreciate any help or further idea!
Thank you for reading all this and best regards,

So I am no expert on the xorg.conf file, but I have a Dell Laptop with the same Intel graphics chip. When I saw all of the issues with openSUSE 11.3 and dual monitors with Intel Graphics, I decided, when I loaded openSUSE on my Laptop, to stick with version 11.2. I use the KDE Desktop and I have no problems using a Dual monitor setup. Now chipsets or even Distribution versions is not the only considerations with graphic operation as many other support items in the laptop hardware need to work together in Linux. None the less, at this point and if after having no success, I would either wait for openSUSE 11.4 or consider a downgrade to openSUSE version 11.2. Since I have determined how to install openSUSE on an external hard drive, I will give 11.4 a try out, when its reaches it final release and start a thread on my success, I hope, with Dual monitors and the like. Until then, good luck in what ever you decide to do.

Thank You,

Hi James,

thanks for the hint that it seems to work with 11.2 in your configuration! I’ll give it a try. I used 11.3 just because I had an bootable USB Stick with it on it at hand. I’ll make a 11.2 version and try it.


Personally I’d never buy any laptop for Linux without first clarifying the hardware config in detail AND trying a Life-CD/Stick boot. Unfortunately (luckily?) this is not my personal laptop, I had no influence on the hardware configuration. I got it as it is and I need to run Linux on it, preferably SuSE…

  • The intel driver xorg-x11-driver-video-intel-legacy is installed in version 2.9.1-1.9-i586 which seems to be the latest one of the SuSE repository

This is the package for the “intellegacy” driver. The package is usually installed, but the driver isn’t configured by default. Your xorg.conf.d is configured for the “intel” driver that is included in the xorg-x11-driver-video package. Booting with “nomodeset” disables Kernel Mode Setting (KMS), and that prevents the “intel” driver which only works with KMS. The default alternative to “intel” is the “fbdev” driver, and that’s what you are getting as a lower performing driver with limited display resolution.

It’s not clear to me whether you tried the “intellegacy” driver? It doesn’t use KMS, and leaves the mode setting for X system to accomplish (the old way, as in 11.2). If you haven’t, you should try it by specifying intellegacy in the device statement of xorg.conf.d file.

Hi consused,

you are my hero :slight_smile:
Stupid me, I never tried “intellegacy” … thinking “intel” is kind of a synonym for “intel*”!
Adding the correct “intellegacy” driver to the device config is the solution! Everything works like a charm now! Not only the VGA output also better font display, some effects in KDE and even switching the display output using the function keys. So easy! I can’t believe that I messed around with PCI IDs and manually added devices… :shame:

Thank you very much indeed!

Hi Juergen,

You are most welcome. Absolutely no reason for shame, and I bet you picked up know-how along the way. However for next time, if/when you change to 11.4, do take a look at the Release Notes (available via YaST for 11.3).

Now enjoy the experience. :slight_smile:

I will! I’m a really surprised that exactly this topic is covered in the release notes of 11.3 I think this is the very first time in my life that a problem I encountered with software has been described in its release notes…
I’m used to RN consisting of zillions of details which are incomprehensible for users that aren’t involved in the development of the software. And usually the problem(s) you will run into when upgrading isn’t in the list. That is why I quit reading them at some point.
Good to know that SuSE seems to be different in that topic. :slight_smile:

Thanks and regards,

Indeed, well done consused in picking this up by carefully reading the 50-device.conf file (and noting the user was using nomodeset as a boot code).

Juergen, not so stupid. You are in fact ABSOLUTELY right that “intel” is for the intel 2.12.0 driver in openSUSE-11.3 !

However on some hardware, like your 965GM, an older Intel driver (than the 2.12.0) works better, and hence SuSE-GmbH packaged an older 2.9.1 version of the Intel driver (building it against the lastest kernel and latest X/Mesa) and called it the “intellegacy” driver. Thus in fact by changing “intel” to “intellegacy” you are in fact booting to an older version of the Intel driver that works better with your hardware.

Thanks, oldcpu, for those remarks and additional comments positioning the intel drivers. I did read all of Juergens well-written notes and comprehensive listings. Input like that is so helpful in arriving at an appropriate and timely solution. :slight_smile: