Suse 11.2 sound trouble

Hi there,
I am getting crazy with this:
Amarok plays mp3, webradio in firefox does not give a bleep. Skype’s video works, but not sound.
Test sounds in Yast work.

Any idea?

Many thanks,
Knut

Do any website with streaming multimedia (such as youtube) work with your firefox? (Don’t forget to check the PCM volume control in your mixer).

If immediately after a fresh boot, and BEFORE you run ANY other application, you try Skype, does its audio work then? I ask this because Linux is not so good for multiple applications sharing the same audio device. Sometimes one application will use the audio device and refuse to share it.

Reference anything specific to Skype audio settings, I can’t help with Skype because I never use it.

No, in a running session, youtube does not play any sound.

I will try with a fresh boot.

flash player plays the video, but no sound.

skype after a fresh boot also without sound.

mp3s play with amarok

videos don’t have sound

strange.

If I might suggest that you may want to check out your multimedia setup. If you have looked through your mixer settings and have not missed something there, perhaps the following might help.

MMCHECK - Check Your Multimedia in 10 Steps - Script File, as proposed by RedDwarf

This is a script file you create on your PC and then run through the 10 step check. The original message this was based on is also referenced where you could manually perform the 10 tests if you prefer. I would run through the tests and tell us what you found.

Thank You,

Hi,
thanks for the link. Here we go:

LC_ALL=C zypper ve
Loading repository data…
Reading installed packages…

Dependencies of all installed packages are satisfied.


rpm -qa --queryformat '%{NAME} → %{VENDOR}
’ | grep -i VideoLAN
faad2 → VideoLAN Project (VideoLAN - VLC: Free streaming and multimedia solutions for all OS!)
libdvdcss → VideoLAN Project (VideoLAN - VLC: Free streaming and multimedia solutions for all OS!)
faac → VideoLAN Project (VideoLAN - VLC: Free streaming and multimedia solutions for all OS!)


rpm --verify --query --all ‘libav*’ ‘libpostproc*’ ‘libswscale*’


rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ libxine1 libxine1-codecs
libxine1-1.1.19-1.pm.44.10-x86_64 → PackMan :: Startseite
libxine1-codecs-1.1.19-1.pm.44.10-x86_64 → PackMan :: Startseite


rpm --verify --query --all 'xine


rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ gstreamer-0_10-ffmpeg gstreamer-0_10-fluendo-mp3 gstreamer-0_10-fluendo-mpegdemux gstreamer-0_10-fluendo-mpegmux gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly
gstreamer-0_10-ffmpeg-0.10.9-999.pm.1000.1-x86_64 → PackMan :: Startseite
gstreamer-0_10-fluendo-mp3-0.10.14-42.pm.42.1-x86_64 → PackMan :: Startseite
gstreamer-0_10-fluendo-mpegdemux-0.10.57-42.pm.42.1-x86_64 → PackMan :: Startseite
gstreamer-0_10-fluendo-mpegmux-0.10.4-43.pm.43.1-x86_64 → PackMan :: Startseite
gstreamer-0_10-plugins-bad-0.10.19-999.pm.1003.4-x86_64 → PackMan :: Startseite
gstreamer-0_10-plugins-base-0.10.30-999.pm.1001.1-x86_64 → PackMan :: Startseite
gstreamer-0_10-plugins-good-0.10.24-999.pm.1000.1-x86_64 → PackMan :: Startseite
gstreamer-0_10-plugins-good-extra-0.10.24-999.pm.1000.1-x86_64 → PackMan :: Startseite
gstreamer-0_10-plugins-ugly-0.10.13-999.pm.1001.12-x86_64 → PackMan :: Startseite


rpm --verify --query --all ‘gst


rpm --verify MPlayer
rpm --verify --query --all ‘vlc
rpm --verify w32codec-all


rpm --query --all ‘libav*’ ‘libpostproc*’ ‘libswscale*’ ‘xine’ ‘gst’ MPlayer ‘vlc’ | grep -v avahi | sort
gst-fluendo-mp3-2-37.3.x86_64
gstreamer-0_10-0.10.30-999.pm.1000.1.x86_64
gstreamer-0_10-32bit-0.10.24-3.1.x86_64
gstreamer-0_10-ffmpeg-0.10.9-999.pm.1000.1.x86_64
gstreamer-0_10-fluendo-mp3-0.10.14-42.pm.42.1.x86_64
gstreamer-0_10-fluendo-mpegdemux-0.10.57-42.pm.42.1.x86_64
gstreamer-0_10-fluendo-mpegmux-0.10.4-43.pm.43.1.x86_64
gstreamer-0_10-java-1.3-42.pm.42.1.noarch
gstreamer-0_10-lang-0.10.30-999.pm.1000.1.noarch
gstreamer-0_10-plugin-gnomevfs-0.10.29-28.1.x86_64
gstreamer-0_10-plugin-hal-0.10.22-27.2.x86_64
gstreamer-0_10-plugins-bad-0.10.19-999.pm.1003.4.x86_64
gstreamer-0_10-plugins-bad-lang-0.10.19-999.pm.1003.4.noarch
gstreamer-0_10-plugins-base-0.10.30-999.pm.1001.1.x86_64
gstreamer-0_10-plugins-base-lang-0.10.30-999.pm.1001.1.noarch
gstreamer-0_10-plugins-good-0.10.24-999.pm.1000.1.x86_64
gstreamer-0_10-plugins-good-extra-0.10.24-999.pm.1000.1.x86_64
gstreamer-0_10-plugins-good-lang-0.10.24-999.pm.1000.1.noarch
gstreamer-0_10-plugins-sopcast-0.0.2-6.3.x86_64
gstreamer-0_10-plugins-ugly-0.10.13-999.pm.1001.12.x86_64
gstreamer-0_10-plugins-ugly-lang-0.10.13-999.pm.1001.12.noarch
gstreamer-0_10-schroedinger-1.0.7-4.3.x86_64
gstreamer-0_10-utils-0.10.24-3.1.x86_64
gstreamer-utils-0.10.24-3.1.x86_64
kde3-kaffeine-gstreamer-0.8.8-1.pm.5.16.x86_64
kdebase4-runtime-xine-4.3.80-166.4.x86_64
libavc1394-0-0.5.3-270.1.x86_64
libavcodec52-0.5.22648svn-0.pm.1.1.x86_64
libavcore0-0.6.25512svn-2.pm.5.1.x86_64
libavdevice52-0.6.25512svn-2.pm.5.1.x86_64
libavfilter1-0.6.25512svn-2.pm.5.1.x86_64
libavformat52-0.6.25512svn-2.pm.5.1.x86_64
libavutil49-0.5-0.pm.1.x86_64
libavutil50-0.6.25512svn-2.pm.5.1.x86_64
libgstapp-0_10-0-0.10.30-999.pm.1001.1.x86_64
libgstbasevideo-0_10-0-0.10.19-999.pm.1003.4.x86_64
libgstinterfaces-0_10-0-0.10.30-999.pm.1001.1.x86_64
libgstinterfaces-0_10-0-32bit-0.10.24-2.4.x86_64
libgstphotography-0_10-0-0.10.19-999.pm.1003.4.x86_64
libgstreamer-0_10-0-0.10.30-999.pm.1000.1.x86_64
libgstreamer-0_10-0-32bit-0.10.24-3.1.x86_64
libgstsignalprocessor-0_10-0-0.10.19-999.pm.1003.4.x86_64
libgstvdp-0_10-0-0.10.19-999.pm.1003.4.x86_64
libpostproc51-0.6.25512svn-2.pm.5.1.x86_64
libswscale0-0.6.25512svn-2.pm.5.1.x86_64
libvlc2-1.0.4-0.pm.8.13.x86_64
libvlccore2-1.0.4-0.pm.8.13.x86_64
libxine1-1.1.19-1.pm.44.10.x86_64
libxine1-codecs-1.1.19-1.pm.44.10.x86_64
libxine1-gnome-vfs-1.1.19-1.pm.44.10.x86_64
libxine1-pulse-1.1.19-1.pm.44.10.x86_64
MPlayer-1.0rc4_r31930-1.pm.3.5.x86_64
phonon-backend-gstreamer-0_10-4.3.1-3.3.x86_64
phonon-backend-xine-4.3.1-3.3.x86_64
xine-browser-plugin-1.0.2-1.pm.1.1.x86_64
xinetd-2.3.14-143.2.x86_64
xine-ui-0.99.5-223.3.x86_64

Any idea? Many thanks for your replies.
Best,
Knut

rpm -qa --queryformat '%{NAME} -> %{VENDOR}
' | grep -i VideoLAN
faad2 -> VideoLAN Project ([VideoLAN - VLC: Free streaming and multimedia solutions for all OS!](http://www.videolan.org/))
libdvdcss -> VideoLAN Project ([VideoLAN - VLC: Free streaming and multimedia solutions for all OS!](http://www.videolan.org/))
faac -> VideoLAN Project ([VideoLAN - VLC: Free streaming and multimedia solutions for all OS!](http://www.videolan.org/))

So, on the packages loaded from Videolan, we suggest that only libdvdcss be installed from there. faad2 & faac should be changed to being installed from Packman, plus any supporting programs that might follow these two. This was the only thing I see that should be changed. To do this, open up YaST / Software Management and search on faad2. Once found, go to the versions tab and change to upgrade to the packman version. Do the same for faac. Many other program may require a vendor change, which is OK. Never break any dependencies and try not to downgrade anything. But vendor change to packman is good for any file.

Thank You,

Thanks, will do.

When testing with flash player and when testing with skype, ensure amarok is NOT running (ie it is NOT in lower right hand corner). Ensure this is the case after a fresh boot and test flash player in firefox (check your PCM) and also check in skype AFTER.

Is this a KDE or Gnome desktop? Assuming KDE, ensure order of audio devices in Kmenu > configure desktop > multimedia matches the order of audio devices in YaST > Hardware > Sound (as best possible).

without amarok running, no sound in either flash or skype.

multimedia list within “configure desktop” is matching YaST’s order, except that PulseAudio is top ranked in multimedia list (there is no PulseAudio in YaST). Playing test sounds with PulseAudio fails sound; the second listed sound card plays test sound.

Thanks so far, but still no internet radio possible :frowning:

multimedia list within “configure desktop” is matching YaST’s order, except that PulseAudio is top ranked in multimedia list (there is no PulseAudio in YaST). Playing test sounds with PulseAudio fails sound; the second listed sound card plays test sound.
If I open the KDE menu / Personnel Settings / General Tab / Computer Administration Group / Multimedia / Device Preference and open this up and I pick Music or Video category and you have the PulseAudio Sound Server on top, right? But when you open YaST / Software Management and search on say pulse, you don’t find pulseaudio, libpulse0, alsa-plugins-pulse, libxine-pulse (at least) as being loaded? Further in the multimedia section, Backend Tab, do you show xine as being the top or preferred backend to use? I can only say that PulseAudio should not be the preferred sound device if it is not loaded, though I am not sure that can be correct. To be truthful, if you don’t use gnome, but KDE all of the time, you could just disable PulseAudio as far as I am concerned, however if loaded it can be made to work OK. If yo9u want to use pluse, then make sure the programs I listed are loaded or do not have its sound server listed to be used in KDE.

without amarok running, no sound in either flash or skype.
I normally suggest you again open up YaST / Software Management, search on flash and make sure you are loading only two items - Flash-player & pullin-flash-player. If anything else comes up with a flash search, then uninstall it at once. While here I would search on quicktime as well - you should find libquicktime0 loaded from packman present. If it is not there or you have a bunch of other stuff and you don’t know why, I would uninstall it.

I would make sure my repository listing was using the current packman for openSUSE 11.2 at (don’t use the quotes):

http://packman.jacobs-university.de/suse/11.2/

If I thought that there was anything wrong with Firefox I would make sure I had the following repository added (don’t use the quotes):

http://download.opensuse.org/repositories/mozilla/openSUSE_11.2/

To make sure that all of the Mozilla files are correct for Firefox, after making sure you have added the correct repository I would open YaST / Software Management / Views Button (Top Left) and select Repositories. In the repository listing find and select Mozilla or what ever you called this repository in the list on the left and pick **switch System Packages **at the top middle of the page to use only files from Mozilla for Firefox. You should be very careful using this option, but in the case of Mozilla, it is limited to only their programs and should work OK.

In my previous message, I suggest you use only libdvdcss from the videolan repository and obtain the other two files from packman. Did you do this task as requested?

Thank You,

I recall asking is this KDE or Gnome ? I assume its KDE (I could not find THAT answer in your post). You say Pulse Audio is top in the multimedia list ? Then if this is KDE, pulse audio is not used by default. So per my recommendation (you may wish to read it again) please “ensure order of audio devices in Kmenu > configure desktop > multimedia matches the order of audio devices in YaST > Hardware > Sound (as best possible).” … ie MOVE pulse audio down in priority to the bottom of the list.

You may need to exit and restart KDE afterward.

Yes, KDE, and yes, reduced the listing of Pulse to lowest in the list.

Thanks for the input:
pulse … in YaST are all there.
Multimedia section: xine is top of the list
Pulse is least entry of the list

Flash:
there are five entries:
flash-player 10.1.85.3-0.1.1
flash-plugin 10.1.85.3-release
flash-plugin-64bit 10.0.42.34-1.1
pullin-flash-player 11.2.1-0.1.1
tvflash 0.9.0-90.1

which ones should be the 2 “ones” to remain?

Many thanks for your help.

Many thanks already!

I’ve been on Suse for a few months now, switched from Kubuntu. I didn’t get sound on either of them, I’ve been researching why I didn’t get sound for a while now. Today I finally found the problem and I feel thats it’s my responsibility to share and this seems the best place to post it:

Yast2 control center>hardware>sound>other>Volume… and from their the PCM was 0 and I put it to 100 and now I have sound. I haven’t rebooted the system yet to see if it stays. Hope this helps people and I’m very sorry if someone else put the same thing on this thread or another I didn’t really check.

ps. suse is KDE on my machine

Yes, in YaST, the test sounds play nicely - nice organ tune

I don’t understand this. You are looking (I think) at the wrong section in KMENU > Configure Desktop > Multimedia.

Here is what I have for YaST:
http://thumbnails30.imagebam.com/10366/f0da92103657410.jpg](ImageBam)

Here is what I have for the order of sound devices in my KDE desktop.
http://thumbnails12.imagebam.com/10366/db9128103658136.jpg](ImageBam)

Here is my desktop backend.
http://thumbnails16.imagebam.com/10366/27cc96103657408.jpg](ImageBam)
I hope that helps.

On my 32-bit PC where I have only two, the are:

oldcpu@athlon:~> rpm -qa '*flash*'
pullin-flash-player-11.3.1-2.1.1.i586
flash-player-10.1.85.3-0.1.1.i586

thanks for your directions, I did the same with my settings. please see the screenshots:

http://www.imagebam.com/image/ee48d2103661176

http://www.imagebam.com/image/264b8c103661177

http://www.imagebam.com/image/281677103661178

and only two entries in YaST with flash:

see the image
ImageBam - Fast, Free Image Hosting and Photo Sharing