SUSE 11.2 Server hung at login - checking...

OpenSUSE 11.2 server
Gnome GUI
Gigabyte GA-MA790X-UD4P
Sony SDX500C SCSI tape drive

Situation: Started a tape backup last night using a terminal box in Gnome and all was well. This morning the first tape was completed so, after changing the tape cartridge, I logged in to continue the backup, which is configured to span tapes. Now the screen shows the login box with my account name, an empty password box, and the notation “checking…” It has been this way for an hour – I may have entered the password incorrectly and it cannot seem to recover from that error.

Problem: The screen is locked. I can log in with a new terminal [alt] [ctl] [f1] but the old backup session is not present. When I switch back to the GUI [alt] [ctl] [f7] the login box is blank - although the login box outline is visible. Looks like it’s glitched, although SAMBA is working fine from remote XP machines.

Question: Hate to lose 6 hours of backup time. Is there a way to continue the backup from a different terminal session? Is it possible to re-initialize the old session with the various windows intact? The last time this happened I had to reboot the machine; wouldn’t be a disaster, but I’d rather not go that route.

Following up on this post, I finally rebooted the server from a terminal. As it shut down, the glitched GUI screen popped up momentarily with the various windows still open, including the one asking me to hit “return” to continue onto the next tape. Since the windows were all live, I suspect there may have been a way to resurrect that session.

This is the second occurrence for me. If anyone has a potential solution to this problem, please reply for the benefit of other users. GK

I’m assuming that the problem seem to be with the screen saver re login.

Also I’m assuming you are running your process as root but are logged into the GUI as a normal user. Never log into a GUI as root!

So I guess we need to know more about how you are doing things.

Have you tried KDE?

Correct on all assumptions:

  1. Logged into gui as normal user
  2. Using a Gnome terminal, logged in as SU & started tape backup session there.
  3. Tried KDE months ago but I prefer Gnome, and I uninstalled KDE.
  4. You may be on the right track ref the screen saver. I have experienced a similar problem once or twice in the past 6 months when the screen did not recover and the only apparent solution was reboot. …I didn’t make that connection until now.

Why should one never log into GUI as root?

Thanks, GK

Many many reasons you can inadvertently change ownership of files just by browsing a user directory while in a root GUI which breaks the users ability to log in. It opens the machine up to possible attack vectors. There is nothing that you NEED to use the GUI as root for.