suse 11.2 SB X-Fi installation issues

I have recently upgraded my workstation from 11.1 to 11.2. Since this i am experiencing major issues with the sound configuration.

I have a dell T3400 workstation with opensuse 11.2 64bit
On board Intel soundcard
Creative labs sound card Xtreme Audit ( SB0790 X-Fi XA)
it is recongined as CA0106

I have tried may tings described in the troubleshoot guide but have managed to get this to work.

The intel card will generally work until I try to configre the SB card
When I try to build the modules for the kernel it appers as if it will onyl retain one of them.

Where should they be configured Yast or configure desktop.

Many thanks for your suggestions

Not sure if this is still needed but in the past your user account need to be a member of the audio group for SB’s to work.

The SB X-Fi is very recent. YaST has not been updated to work with the X-Fi, and hence some of the recommendations in the audio troubleshooting guide do not apply to the X-Fi with the current version of YaST.

Go to your /etc/modprobe.d directory and remove the file 50-sound.conf it is there. Then reboot and test your sound. Use the 3 speaker tests from the audio troubleshooting guide for a test. Its common that 2 of 3 of those tests will fail. You only need 1 to work to prove your audio works.

Ensure you move up master, pcm and any speaker volume controls in your mixer when testing.

Thanks for your suggestions unfortunately I did already try all this.

The strange thing is that the card worked fine with opensuse 11.1

The card is a Creative labs Sound Blaster X-Fi Extreme Audio.
My other card the on-board intel works just fine.

Starting tomorrow, I am away on business/vacation for 2 weeks with minimal to no Internet access. So I likely will not be able to follow this thread.

If you have tried what I suggested and if you “think” you tried what was in the audio troubleshooting guide, then you could try the latest alsa versions. That IS referenced in the audio troubleshooting guide and its possible you did NOT do this, but rather only just read it.

Note you MUST ensure you not only added the alsa-driver-kmp version applicable to your kernel (and ONLY the one applicable to your kernel, not the debug, nor desktop (if you have default kernel) nor default (if you have desktop kernel), AND ensure the various alsa versions are also updated. Many users say they went for an update and the packages are already installed and so they don’t update. Of course they are installed, but the installed versions are older. One needs to update. CHECK the version numbers to ensure you update.

I suspect your alsa is 1.0.20/1.0.21 and you have not updated to the 1.0.22a where the audio troubleshooting guide that you say you followed has links explaining how to do that.

Apologies if the above is a bit rough. I’m struggling with a headcold that I can’t shake and not looking forward to my business trips.

If in the end nothing works for you, write a bug report against openSUSE component “sound”, reporting this different behaviour in openSUSE-11.2.

Attach (don’t copy and paste, but attach) to the bug report the text file from running:

/usr/sbin/ --no-upload

and that will create the file /tmp/alsa-info.txt which can be added as an attachment. That has bunch of technical info that may show the alsa dev what is wrong with the alsa driver, IF you also describe the audio symptoms.

Note the openSUSE packager for sound is also an alsa developer, and if he fixes this, the fix gets sent upstream and ALL linux distributions will benefit.

There is guidance here for raising bug reports: Submitting Bug Reports - openSUSE … The alsa developer/openSUSE packager, may ask that you try a few different alsa versions, and hence if your schedule is too busy for such support (and I definitely know what that can be like) then its probably best NOT to write such a bug report.

Don’t reference this thread, as the openSUSE packager will refuse to read forum threads. Hence your bug report needs to have everything included.

Good luck and sorry that I can not help more.

Just to make certain we are talking about the same audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

… note also the alsa update page gives zypper commands for updating the alsa apps: Alsa-update - openSUSE

My experience is that update does not work for many users, and instead you may be better off adding the repository to YaST, using YaST (not zupper) to update the rpms, and then REMOVE the repository. Its VERY important you REMOVE the repository afterward. Do NOT forget nor ignore that.

Thanks for your all the details and fast reply. I will find a few quiet hours and go again through the troubleshooting guide.

I am pretty sure that I had the latest driver I downloaded yesterday and to make sure I had un-installed the current version with yast.

In the mean time get better and enjoy the time off I may bug you when you come back