Suse 11.2 locking up

After installing Suse 11.2 and getting the first bunch of upgrades after installation, Suse is just locking up on me once I bring up a window or try to do most anything using my mouse. I try clicking on buttons, like Close or Cancel buttons once Yast is started, and nothing happens. I also notice that when I am able to get anything to happen, a single click opens an application from the desktop window rather than the more normal double-click. I am about to re-install the release again but I wanted to check here to see if this is a common problem with any others in this new release. I have no idea why using my mouse and trying to click on items is not causing the screen to react. I did not have this problem with Suse 11.1, using the exact same hardware so I am baffled that 11.2 is just not working. I have a feeling it may have something to do with the way that the latest KDE is working, but I have no idea what I have to do to change it.

boot with nolapic parameter

The double-click never has been normal on (open)SUSE / KDE

Somehow in 11.1 I was able to set things up so that a double-click was needed to open an item, not a single-click. But I could not find how to do this with the latest KDE and Suse 11.2.

And this means … ?

it means to boot with the nolapic option which disabled the APIC controller on the CPU… what else will it mean?

when you get the grub bootscreen where you choose the OS/kernel, type in nolapic
or open /boot/grub/menu.lst and add nolapic in the kernel line to make it permanent

I tried this and it worked really well for a long while. Then I went to set a screen saver and Suse came to a complete halt. I will try using 11.2 with that ‘nolapic’ switch at bootup and I guess I will just have to avoid setting a screen saver. If the freeze still occurs in other situations it looks like I will have to bid Suse goodbye until some later release, or go back to 11.1 and install it again.

Thanks for the help.