SuSE 11.2 & K3B burning Problems

Having problems with K3B burning data and ISO files.

Can someone please help me with this.

Disc Media: Datawrite DVD & CD Discs

Old Box

OS: WinXP Pro SP3 32bit
Burning Software: Nero

Mobo: Asrock P4V88+
Processor: AMD AthlonXP 2800+ Single Core CPU
Memory: 2GB DDR
Optical Drive: NEC DVD RW ND-4550A (2x, 4x & 8x write speeds)

New Box

OS: SuSE Linux 11.2 64bit
Burning Software: K3B 1.0.5 using KDE 3.5.10 release 32

Mobo: Gigabyte GA-MA770T-UD3P
Processor: AMD Phenom II X4 965 SKT AM3 “Quad Core”
Memory: 8GB DDR3 PC3-1200 1600HHZ
Optical Drive: LG GH22LS50 (4x & 8x write speeds)

My Current / Old box (WinXP)can burn 2.9GB of data over a LAN from a mapped drive using Nero in 7 minutes and maintain file & directory names as they are complete with upper and lower characters, spaces between words and special characters without shortening file / directory names out of the box.

My new box (SuSE 11.2) was initially incapable of burning anything, “Access Denied” I added the user to the cdrom group this allowed the burning of data but the process changed file and directory names. It changed all letters to capitols, replaced blank spaces and special characters with underscores. I still can’t burn ISO files, “Access Denied”. The time it took to burn the 2.9GB of data on the hard drive of the SuSE install was sort of acceptable but a full 5 to 6 minutes longer and I was forced to shorten file names too.

I changed a setting to allow the full ascii character set hoping this would preserve file and directory names as they are during the burn process. I changed a setting to allow long file names too.

I now have another problem, on starting the burn process and after a minute’sh K3B displayed the fact that it was going to take over 1 ½ hours to finish! Yikes. After an hour it was going to take a further 2hrs and 10mins. This didn’t include read varify.

I aborted the burn process, this can’t be correct.

I placed the LG drive in my old box, burn process took a second or two less than 7mins to complete using the same data over the same LAN. I’ve tested the drive for hardware errors, the drive is perfect.

Am i missing something, failing to do something or doing things wrong. Is the optical drive or some other component incompatible in some way.

I’ll be burning many gigabytes of data on a daily basis and i’m hoping to be able to burn a full DVD disc of mixed data types in less than 10mins whilst preserving the full ascii character set, file & directory names inc special characters and blank spaces. I still need to resolve my “access denied” problem when trying to burn ISO files too.

Hoping somebody can help me here.


Sorry not much help, but the k3b 1.69 that goes with the stock KDE4 works just fine. Do you have to use KDE3.5?


Thank you for your response.

"Do you have to use KDE3.5? "

No idea, forgive me, KDE 3.5 was installed by default. Whatever i do here must not change anything regarding the running of Apache2, Sshd, VSftpd and the Samba servers or Dazukofs or Avira Antivir.

I ask that i am treated as a complete beginer with this although i have had a SuSE box for several years running a number of servers i have never really used Linux as a daily user at all whatsoever.


To get KDE3.5 with 11.2 you would have had to specially install it yourself. The default KDE that comes with 11.2 is KDE4. Are you sure you don’t really have KDE4?

How do i find out?

I only know what K3B tells me when i click on Help > About KDE or Help > About K3B.

SuSE 11.2 64bit was downloaded from the OpenSuSE website roughly 3 weeks ago.


If i open Help from the start menu and click help > about KDE i get KDE 4.3.1 release 6

I would recommend the K3B from packman. PackMan :: Search results

See this for adding the packman repo if you don’t already have it. Repositories/Packman - openSUSE-Community

Read this Zypper/Usage/11.2 - openSUSE to learn how to use zypper.
You can also use YaST YaST/Modules/Software Repositories - openSUSE and YaST/Modules/Software Management - openSUSE

If you have more questions, please don’t hesitate to ask.

Thank you for all your help thus far.

Downloaded K3B and it installed with an error, "k3b -arts could not be installed. However i now have a different version of KDE when i use K3B now.

tried to burn a data DVD disc, i quickly get:

“cdrecord has no permission to open the drive”

with the following debug info


HL-DT-ST DVDRAM GH22LS50 TL01 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R96R, Restricted Overwrite, Layer Jump] %7]


mkisofs print size result: 1511531 (3095615488 bytes)


K3b Version: 1.69.0
KDE Version: 4.3.1 (KDE 4.3.1) “release 6”
QT Version: 4.5.3

Used versions

mkisofs: 1.1.9
cdrecord: 1.1.9


/usr/bin/wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.scsidev: ‘/dev/sr0’
devname: ‘/dev/sr0’
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Wodim version: 1.1.9
SCSI buffer size: 64512
Beginning DMA speed test. Set CDR_NODMATEST environment variable if device
communication breaks or freezes immediately after that.
TOC Type: 1 = CD-ROM
Driveropts: ‘burnfree’
Device type : Removable CD-ROM
Version : 5
Response Format: 2
Capabilities :
Vendor_info : ‘HL-DT-ST’
Identification : 'DVDRAM GH22LS50 ’
Revision : ‘TL01’
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x001B (DVD+R)
Profile: 0x0012 (DVD-RAM)
Profile: 0x0011 (DVD-R sequential recording)
Profile: 0x0015 (DVD-R/DL sequential recording)
Profile: 0x0016 (DVD-R/DL layer jump recording)
Profile: 0x0014 (DVD-RW sequential recording)
Profile: 0x0013 (DVD-RW restricted overwrite)
Profile: 0x001A (DVD+RW)
Profile: 0x001B (DVD+R) (current)
Profile: 0x002B (DVD+R/DL)
Profile: 0x0010 (DVD-ROM)
Profile: 0x0009 (CD-R)
Profile: 0x000A (CD-RW)
Profile: 0x0008 (CD-ROM)
Profile: 0x0002 (Removable disk)
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Supported modes: PACKET SAO
Drive buf size : 1048576 = 1024 KB
Drive DMA Speed: 16712 kB/s 94x CD 12x DVD
FIFO size : 4194304 = 4096 KB
Speed set to 11080 KB/s
Track 01: data 2952 MB
Total size: 3390 MB (335:53.74) = 1511531 sectors
Lout start: 3390 MB (335:55/56) = 1511531 sectors
Current Secsize: 2048
HINT: use dvd+rw-mediainfo from dvd+rw-tools for information extraction.
Blocks total: 2295104 Blocks current: 2295104 Blocks remaining: 783573
Starting to write CD/DVD at speed 8.0 in real SAO mode for single session.
Last chance to quit, starting real write in 2 seconds.
1 seconds.
0 seconds.
Operation starts.
Waiting for reader process to fill input buffer … input buffer ready.
Performing OPC…
Sending CUE sheet…
Starting new track at sector: 0
Track 01: 0 of 2952 MB written.
Track 01: 1 of 2952 MB written (fifo 100%) [buf 99%] 0.2x.
Errno: 5 (Input/output error), write_g1 scsi sendcmd: no error
CDB: 2A 00 00 00 02 2E 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 2A 00 00 0E 21 02 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x21 Qual 0x02 (invalid address for write) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.132s timeout 200s
/usr/bin/wodim: The current problem looks like a buffer underrun.
/usr/bin/wodim: Try to use ‘driveropts=burnfree’.
/usr/bin/wodim: Make sure that you are root, enable DMA and check your HW/OS set up.
write track data: error after 1142784 bytes
Writing time: 26.095s
Average write speed 111.0x.
Min drive buffer fill was 99%
Errno: 5 (Input/output error), close track/session scsi sendcmd: no error
CDB: 5B 00 02 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 5B 35 30 0E 72 03 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x72 Qual 0x03 (session fixation error - incomplete track in session) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.590s timeout 1000s
Errno: 5 (Input/output error), flush cache scsi sendcmd: no error
CDB: 35 00 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 35 72 03 0E A0 80 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0xA0 Qual 0x80 (vendor unique sense code 0xA0) [No matching qualifier] Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.006s timeout 1000s
Trouble flushing the cache
Fixating time: 0.609s
/usr/bin/wodim: fifo had 82 puts and 19 gets.
/usr/bin/wodim: fifo was 0 times empty and 4 times full, min fill was 90%.

cdrecord command:

/usr/bin/wodim -v gracetime=2 dev=/dev/sr0 speed=8 -sao driveropts=burnfree -data -tsize=1511531s -


Warning: creating filesystem that does not conform to ISO-9660.
Warning: creating filesystem that does not conform to ISO-9660.
Warning: ISO-9660 filenames longer than 31 may cause buffer overflows in the OS.
I: -input-charset not specified, using utf-8 (detected in locale settings)
Using ABBEY - MAKE A PAYMENT RECEIPT000.URL for Beaty/Favorites/Abbey - Make a Payment receipt M&S.url (Abbey - Make a Payment receipt M&S Nov.url)
Using ABBEY - MAKE A PAYMENT RECEIPT001.URL for Beaty/Favorites/Abbey - Make a Payment receipt debs.url (Abbey - Make a Payment receipt Debs Nov.url)
Using MARKS AND SPENCER CHECKOUT THA000.URL for Beaty/Favorites/Links/Marks and Spencer Checkout Thank You.url (Marks and Spencer Checkout Thank You (2).url)
Using NETGEAR FORUMS VIEW TOPIC - D000.URL for Beaty/Favorites/Router topics/Netgear Forums View topic - DG834G Signal drops - drops connection.url (Netgear Forums View topic - DG834G Reboots spontaneously.url)
Using XVIDEOS_COM - MOTHER ****S HER000.FLV for Beaty/My Documents/My Videos/RealPlayer Downloads/XVIDEOS.COM - Mother ****s Her Sons Best Friend - XVIDEOS3.flv (XVIDEOS.COM - Mother ****s Her Sons Best Friend - XVIDEOS2.flv)
Using XVIDEOS_COM - MOTHER ****S HER001.FLV for Beaty/My Documents/My Videos/RealPlayer Downloads/XVIDEOS.COM - Mother ****s Her Sons Best Friend - XVIDEOS2.flv (XVIDEOS.COM - Mother ****s Her Sons Best Friend - XVIDEOS.flv)
0.03% done, estimate finish Mon Jan 4 22:59:02 2010
0.07% done, estimate finish Mon Jan 4 22:34:56 2010
0.10% done, estimate finish Mon Jan 4 22:26:24 2010
0.13% done, estimate finish Mon Jan 4 22:22:17 2010
0.17% done, estimate finish Tue Jan 5 01:41:01 2010

mkisofs calculate size command:

/usr/bin/genisoimage -gui -graft-points -print-size -quiet -volid Beaty -volset -appid K3B THE CD KREATOR (C) 1998-2009 SEBASTIAN TRUEG -publisher -preparer -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-akwe-xavante/k3bE27413.tmp -rational-rock -hide-list /tmp/kde-akwe-xavante/k3bV27413.tmp -no-cache-inodes -full-iso9660-filenames -relaxed-filenames -max-iso9660-filenames -disable-deep-relocation -iso-level 3 -path-list /tmp/kde-akwe-xavante/k3bY27413.tmp

mkisofs command:

/usr/bin/genisoimage -gui -graft-points -volid Beaty -volset -appid K3B THE CD KREATOR (C) 1998-2009 SEBASTIAN TRUEG -publisher -preparer -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-akwe-xavante/k3bo27413.tmp -rational-rock -hide-list /tmp/kde-akwe-xavante/k3bB27413.tmp -no-cache-inodes -full-iso9660-filenames -relaxed-filenames -max-iso9660-filenames -disable-deep-relocation -iso-level 3 -path-list /tmp/kde-akwe-xavante/k3bE27413.tmp

Please note the data being burned is not my data but the data belonging to a customer.

Just noticed the rather dodgy files listed for burning!!!

Burn process started at approx 22:10

Note the expected finish time of 01:41!!!

Try a lower speed like 4x. Not all drive/media combinations are capable of 8x speed. Also turn on burnfree as the message suggests, it’s one of the options in some k3b settings.

The estimate of 01:41 is because it hit a snag, slowed down a lot, and then bombed out. As such it isn’t to be trusted.

When you run K3B for the first time, you need to run the K3B setup tool.
Go to Settings>Configure K3B>Devices.
See K3B’s FAQ for more info. FAQ - K3b

The DMA speed test shows that the max that the DMA channel the drive is on can achieve is 12x. So there isn’t much room above 8x. Are you able to put the drive on a faster channel? Are there any BIOS settings that can affect the DMA speed? (I doubt it, these days BIOSes tend to autodetect suitable settings.)

The file name problem isn’t a problem it’s a feature!
Nero usualy adds a Joliet (file system) to the ISO 9660 file system and k3b adds a Rock Ridge (file system) which is not accessible under Windows to be able to see (they’re still there) the full file names under windows, in k3b -> settings enable joilet.
There’s no difference if U use the older k3b v1 (kde3) or the newer k3b (that comes with kde4) as k3b is just a frontend to cdrtools which are command line aka console applications.
And most newer DVD-/+R’s can’t be burn at lower speeds, as DVD burners are getting cheaper and cheaper maybe a new burner is the way to go :wink:

Thank you all for your replies.

If i was to replace my DVD optical drive for a new one, would this create further problems with drivers etc.

Will the new drive have to be manually setup and configured or will the OS recognise the fact that the drive has changed and auto setup new drivers for it etc.

If i have to manually setup new drivers etc how is this done?

Lastly can anybody recomend a specific DVD RW optical drive that best suites SuSE 11.2 and K3B?


Don’t waste your time/disks/money, CD/DVD writing is broken in openSUSE 11.2!

It’s only a fortunate few that can actually use it, and it seems to be with the expensive drives and media.

For the rest of us poor people, IT DOES NOT WORK.

I just tried it again on ANOTHER fresh install of openSUSE 11.2 64bit, and get the same errors as usual -

p, li { white-space: pre-wrap; }

/usr/bin/wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.


CDrecord had no permission to open the device.

There is NO setup K3B option in either the standard or Packman versions of K3b, however there is in Kubuntu 9.10. Kubuntu 9.10 also failed to burn CDs/DVDs with much the same errors.

My latest install was completely verified at burn time, and a media check performed before installation.

Messing with device permissions will not help, nor will messing with groups.

My conclusion is that the wodim backend is knackered.

Thank you growbag, i am hoping CD / DVD burning isn’t broken in 11.2.

I’m still happy to buy a better quality optical drive if someone can suggest a drive that best suites SuSE 11.2 & K3B.

If i fail to get K3B working efficiently enough to use then i’m going to have to build a new MS Windows box for burning customer data with :frowning:

If a new optical drive fails theres no great loss becuase i’ll put this drive in the MS Windows box.

I just burnt the exact same image using the exact same computer onto the exact same CDRW disk that K3B (wodim or whatever) rejected.

I burnt the image from windows xp (which I have on my desktop system for gaming) and I,m writing this from that very same LiveCD, which also passed the preboot disk test.

I just wish I knew what to file a bug against, I don,t believe its a K3B problem.

PS I use commas instead of apostrophes in this post because openSUSE never honours the keyboard setting I choose on boot and I cannot find the blasted thing!

I’ve just changed my DVD burner for a new one, the same brand name and model though.

Burn process is ongoing but things are still not acceptable insofar as i still have to shorten file names to comply with joilet standards and the burn process after the first 5 mins informs me its going to take another 1hr 35mins!!!

This isn’t an acceptable time. My MS Windows box burns the same data to the same drive using the same media discs without shortening file names in 7 minutes.

No matter what speed i select for writing it defaults to 0.5X at 692kbs and the device buffer fluctuates widely from 2% to 80%.

The write speed is now fluctuating between 0.1x to a max of 0.5x.

After 12 minutes my estimated time left has now increased to nearly 3hrs!!!

This time i’m going to let it continue and finish just see what happens.

I hate to be the bearer of bad or good news depending on how you see it, and for being unhelpfully contributing to a yes it does, no it doesn’t argument, but k3b works for me in 11.2 as it has had in 11.1. It’s only one data point against your one data point, but still…

Not just with a SATA DVD writer but also with an old IDE CD writer that must be some 5 years old. BTW, if DVD burning doesn’t work, you can’t blame wodim, because DVD burning is done by growisofs which comes from the dvd+rw-tools package.

However I do believe both of you when you write that you have a problem. But I have no idea what could cause that kind of symptom of jerky data transfer.

However I will say this: CD/DVD burners are some of the most unreliable pieces of hardware that I know of in a computer. I have thrown out more drives from donated computers than I have in use. I have seen weird symptoms, like a drive that would read DVDs fine but not CDs (probably different lasers), or one that works for a while until it gets warm. You may have the same model of drive in another identical machine with a different OS, but you really need to swap the drive with the other machine or alternatively boot up a different OS on the same machine to check if the drive is AOK.

See if you can test the drive with another OS on the same hardware, e.g. boot a live CD of another distro. Other things to check are the cabling and even the motherboard interface. See if there are any drive or interface errors from the output of dmesg.