suse 11.2, intel 945G dual monitors

I have two monitors, 1280x1024 each, and intel 945G card. When I am trying to use both of them, Xrandr gives me the error( because of the small virtual screen size ):

xrandr --auto --output VGA --mode 1280x1024 --output TMDS-1 --left-of VGA --mode 1280x1024
xrandr: screen cannot be larger than 2048x2048 (desired size 2560x1024)

I have generated xorg.conf with the sax2 and made all “virtual resolution” strings 2560x1024. It was the workaround in suse 11.1; unfortunately in 11.2 this doesn’t seem to work. After the restart of gnome, I’ve got exactly the same error.

When I push “test” button in SaX2, both monitors are used properly.

How can I change this 2048x2048 value? It looks like xorg.conf is not used anymore.

AFAIR, this is an unfortunate limit with many intel (prior to GM965) chipsets. This xrandr guide mentions

Note that the maximum supported size of the virtual desktop for the Intel 945GM series of chipset with 3D acceleration enabled, is 2048x2048. The virtual screen can be larger but DRI will be disabled. This may matter if you like games and compiz desktop effects, or if you want Google Earth to display in better than geological time. Obviously the larger the virtual desktop, the more graphics memory is used. So for good performance with a shared graphics system such as Intel the Virtual should be no larger than necessary.

It is possible to set a higher virtual resolution, but you would lose DRI support.

BTW: You’re correct about the xorg.conf requirement with openSUSE 11.2 onwards. The X-server does not require it by default, unless for custom user configuration reasons.

deano_ferrari, thank you for the answer. I was using both monitors in suse 11.1, probably without 3D acceleration ( compiz is not needed on this machine).

I’ve tried to remove all the strings with ‘DRI’ from xorg.conf:

Load “dri”;

#Section “DRI”

Group “video”

Mode 0660


But these changes didn’t help. I would like to use monitors in native resolution, even without 3D acceleration. Is there any solution without the return to the suse 11.1?

Not sure what to advise here as I don’t have intel graphics hardware to experiment with. The xrandr guide (I linked to) mentions

With recent distributions which use KMS, the virtual size may be larger such as on the Intel 945 where the virtual size is now 4096x4096. However going beyond 2048x2048 still has implications, such as no support for 3D graphics (Compiz) and no Xvideo

but I’m not suer if openSUSE 11.2 uses KMS intel driver or not. Maybe someone else more about this.