suse 11.2, firewall must be down for wireless printer

basically I have a home wireless network and running openSuse 11.2 and using Yast … hp j6480 wireless (setup with hplip) printer (multifunction fax/scan/printer), toshiba laptop wireless, and netgear wireless router … as long as the firewall is not running I can print just fine … as soon as I start the firewall I have connection errors … I have noticed the wlan0 and eth0 are configured in the external zone for the firewall so I added “cups” in the Firewall Configuration: Allowed Services … the Firewall configuration: Summary displays

Firewall Starting
Enable firewall automatic starting
Firewall starts after the configuration gets written

Internal Zone
No interfaces assigned to this zone.

Demilitarized Zone
No interfaces assigned to this zone.

External Zone

RTL8101E/RTL8102E PCI Express Fast Ethernet controller / eth0
AR5001 Wireless Network Adapter / wlan0
‘unknown’ Unknown network interface.

Open Services, Ports, and Protocols


TCP Ports: ipp (631)
UDP Ports: ipp (631)
Broadcast Ports: ipp (631)


also in the hplip forum it mentioned that hplip uses ports 161, 162 1and 9100 …

now being a confused noob … am I missing something very simple?

I’m a bit confused. Are you saying you need to bring down the openSUSE firewall to print to the HP J6480? If so, that does not make sense to me.

I have an HP Photosmart Premium c309a wireless printer, and all I did was add cups support to the openSUSE firewall. I can print to that printer with no problem from an openSUSE-11.2 PC on the same LAN (and even those openSUSE-11.2 PCs on a subLAN).

There are settings in the openSUSE firewall for “mDNS/Bonjour Support for HPLIP” and “ZeroConf/Bonjour Multicast DNS” but I’ve never needed those. Adding cups support to the openSUSE Firewall (under YaST) did the trick for me for printing.

Scanning is more difficult re: the firewall.

Previously I had 11.0 and everything worked fine (print,scan,and fax) … then I installed a larger harddrive to the laptop and installed only 11.2 it started having problems … but yes I have to stop the firewall for it to connect to the printer … so any direction you can lead me to try?

Well I tried the mDNS/Support for HPLIP, it loaded and everything just worked right away …

Consider this SOLVED and thanks for your help