SuSE 11.2 and KDE4 (Desktop Icons howto?)

Hi,

I have SuSE 11.2 and KDE 4.3.1 installed.

How can I add a new Desktop Icon?

In my $HOME/Desktop are many files but only some are shown,
some I can’t get to be displayed on the desktop …

Is it possible to go back to KDE 3 with this distro?

Thanks
Marcel

On Desktop - Right click unlock widgets
Right click add widget - search for ‘folder’
Select and add Folder View
Configure, re-size etc
Right click Lock widgets when done

Hi
In the menu system if you right-click and add to the desktop (not the
desktop folder).

If you right-click on the desktop you can change the option to a
‘plain’ desktop, maybe this is similar to KDE3? Note I’m mainly a Gnome
user :wink:

No, it’s KDE4 now…


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 16:44, 2 users, load average: 1.15, 0.50, 0.20
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

You cannot go back but if you open YaST>Software>Software Management and look under Patterns (AFAIK) you should find KDE3; you can install it and when you next login, choose Session on the login screen and select KDE3 before you log in.

You can swap between the two by accessing Session each time you log in.

Depending on what you want to do, you may have to make some adjustments to hidden files in /home. It is also not advisable to use equivalent programs in both KDE3 and KDE4 as they store their data in different hidden files. Decide which programs you want to use in each session and stick to them.

Hi
Only KDE4 now…
http://thumbnails25.imagebam.com/5580/f8b4c655794690.gif](http://www.imagebam.com/image/f8b4c655794690)


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 17:36, 2 users, load average: 0.00, 0.11, 0.15
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Could you add this repo?
Index of /repositories/KDE:/KDE3/openSUSE_11.2

Not saying I would, or advise it though.

Ok, I gave up, I’m using Linux now since over 15 years
but KDE 4 made me failing doing simple things like adding
a desktop icon :frowning:

But - this helped to see the KDE3 icons again on the desktop:

vi $HOME/.kde4/share/config/plasma-desktop-appletsrc

Replace

plugin=desktop

to

plugin=folderview

and after login all desktop icons appear.

Now I can again right click on the desktop and get a menu
to “Create New”->“Link to Application”.
But adding a desktop icon fails again as it wants to add the .desktop file to
/usr/share/kde4/templates/.source
where I have no permissions.

So I end up going to $HOME/Desktop and copy one of the
.desktop files and editing it manually, this works.

I’m quite sure that the KDE4 developers are very motivated
and do technically seen an excellent job, but how do you expect
that a normal user can be happy using Linux with such elementar
hazzels? Every Desktop user in my environment will directly
move back to Windows.

Just my two cents
Marcel

“You cannot go back but if you open YaST>Software>Software Management and look under Patterns (AFAIK) you should find KDE3;”

This does not exist anymore in SuSE 11.2

Desk-Top Icons: I have had same accident & LOST my Desktop Icon-Folder

Someone, but SOMEone must have produced a downloadable Widget to do this Function??

thanks

Anna

Seriously,

There are three ways you can achieve this.

1.) Right click on the Desktop. Make sure the widgets are unlocked (if it’s locked there will be an unlock option; if it’s unlocked there will be a lock option)

Click on the application launcher, choose whatever program you want, you can even type in the name of the program and it will show up in the menu, then drag it to the desktop. There’s a new desktop icon. Easy as that.

2.) Or if you want the icons from the Desktop folder to be shown, you can do as caf said and (still making sure widgets are unlocked) right click on the desktop, choose add widget, type in Desktop Folder, then double click it to add it to your desktop. Hover over it then choose the wrench that’s on the tab. For location make sure Show the Desktop folder is chosen. There’s your Desktop Icons. Easy as that.

3.) Or as someone else said, You can right click on the Desktop, then choose Desktop Settings. Under the category Desktop Activity, change the Type to Folder View. Now you have a “regular” desktop. Just add icons to the desktop folder to add them to your desktop or the same as the first paragraph suggested, but instead it will ask you to copy or make a link - choose make a link. Easy as that.

I’ve been using KDE4 since I started with linux at the beginning of THIS year so it’s a lot more apparent to me now, but I tried stuff out in order to figure this out. Things like, drag the program to the desktop to make a desktop icon. It seems simple enough and KDE4 lets you do it.

Take Care,

Ian

Ian - thank you so much

. . . there are so many things that are confusing me at present

:slight_smile:

and


How can I switch between Multiple Desktops


using Keyboard Short-cut ??

Ctrl+Tab used to work, but my new openSuSE 11.2 can not help me at present ??

  • many thanks
    Anna

Ctrl+F1,F2,F3,F4 and Ctrl+F8 shows all desktops
That is how it works on mine.

Also if you click on the application launcher then choose Configure Desktop (Personal Settings), then under the category Computer Administration click into Keyboard and Mouse. Click the category Global Keyboard Shortcuts and for the KDE component choose Kwin. Here you can change other shortcuts for desktop effects, like switching a desktop to the right by holding in ctrl+alt+right arrow like in compiz.

Take Care,

Ian

Hello Ian & linclkh

Switching Desktops


  • thank you both . . . problem solved :slight_smile:

Anna