SUSe 11.2 and Intel High Definition Audio


This is my PC, Intel GMA 900 Dynamic Video Memory Technology 3.0 is off im using GeForce 8600 GS

HP Pavilion - Specifications

Sound is not working cant find anything to fix it, just not working on OpenSuSe 11.2

Any one have idea HOWTO:sarcastic:, mayby someone had same problem ready…

im not sure but im thinking to change ICH6 to ICH5 older one havnt so many problems… is there any option to do that??


About internet connection is working now… REINST…:X

Yipes sorry to hear about your issues, usually linux is pretty good with HP’s and intel audio cards, I know I use one.
What version of openSUSE 11.2 did you install, KDE or gnome?
There is pulse to consider too, if you use the gnome install its there by fefault.
What about any mixer applets, like main audio and secondary audio channels?
I would help to know if you have the gnome or KDE version.

Right, all i know is that the sound when i logof is playing, but any others sounds is not… Youtube music players ETC…

This is my sys info.

If you need more let me know what U need ill paste here

Linux i686
System: openSUSE 11.2 (i586)
KDE: 4.3.1 (KDE 4.3.1) “release 6”

This is Drivers INFO

This is main settings for sound

Sorry for multi post, but also system TEST sound is working only for ANALOG devices and only 2 speakers works, but any other configuration is not. also any other sound is not working on analog only TEST sound :sarcastic:

Very odd then, by the way sorry for the late reply as I work nights and sleep at odd hours.
Anyhow you say youtube works and basic audio playback works, well its obvious that the OS is taking to your audio card but you may want to add some extra configuration.
You may want to install pulse audio, maybe your issue is caused by running multiple sound apps at once.
Linux has or at least had for some people issues using more then one sound application at a time, its just the way linux uses audio devices, its different then it is in windows.
A good cheat around this is to install pulse audio, I know above I said it might be the cause of your issue but it might also be your solution.
I know you can make linux play multiple audio apps without pulse but setting it up can be harder then installing pulse.
The reason for openSUSE not having it installed is that for some folk pulseaudio has issues, though personally I dont.
If you need help setting it up, I can help.

No youtube is not working only one thing is working Sys Test sound when u can test device to chose analog or digital and only analog is working that sound anything else isn’t

I might have a immediate solution, you see the volume icon in your “taskbar” at the bottom of the screen?
Right click it and select “show mixer window”
in the mixer window go to “settings” and then to “configure channels” and click.
Here you have a mini window with many selections, enable all of them as each audio card is different so what channels to enable I cannot say but enable them by clicking the checkboxes on the left side of the name of the channel.
once everything is set up you can move volume levels up on channels that might be muted or turned down.
PCM and CD should be unmuted and turned up.
I had issues with flash not having volume in openSUSE, mucking about with the sound channels did help.
By the way did you install flash from openSUSE’s repos or the one from adobes web site?

I recommend you ensure your multimedia applications and codecs are properly sorted. Along those lines, please read and follow this (very carefully - do not deviate if you do not understand what you are doing): Multi-media and Restricted Format Installation Guide - openSUSE Forums

ok thanks very much, i think pulse audio help im not sure… :smiley:

Youtube works Amarok also and 5.1 sound play nice.

For any one who have problems same like me, ill tell You what i do.

Used alsa looking after this info.

SDB:AudioTroubleshooting - openSUSE


Pulse Audio

and last

i think i should start in Yast… stupid…

YAST > HARDWARE > SOUND > OTHER > TEST and test your sound. If you have no sound then,

YAST > HARDWARE > SOUND > OTHER > VOLUME and move your PCM and Master Volume up to about 75% and test your sound.

NOW I think i need good codecs do any one know any good codecs??

Quailty in Youtube is bad but amarok is ok.

Thank u all

In polish.

GG/Kadu 623862 masz ten problem to pisz i pomoge

OLDCPU ill read more about, there i can find good info, thanks

ok. sound is working but it is not so laud and not good quality as on XP
do any one “Know How” make it better??

Typically one increases the volume in their mixer (kmix in kde and alsamixer in gnome). Move the volume UP for Master, PCM, and speaker (if present).

Sometimes going to YaST > Hardware > Sound > Other > Volume and one can move the volume up there.

Good luck !

I am using Pulse Audio and Intel audio card in an X200 Thinkpad and everything works OK after changing from Conexant Digital to Analog at the Playback tab MoveStream option on the speaker icon. However, Banshee keeps changing it to Digital and then it does not sound anymore. Good audio quality but I have to figure out how to keep that setting fix.

Forget it, I found my solution. Went to the Applications-Systems-Configuration-Volume Control and picked the Playback Intel -Conexant (PulseAudio Mixer) and now Banshee does not change the setting anymore. Too many applications in order to control the audio output, this is not good for regular users, hope somebody comes upwith a single control for every singel device in our computers in Linux.

Good luck on your problem.