Suse 11.2 and encrypted/secured iwl3945 wireless

I can connect fine to unsecured networks with KDE 4.3.x I can connect to any secured or unsecured network with Gnome 2.X (whatever ships with Suse 11.2)
When I had Suse 11.1 on this laptop KDE had no problems connecting to secured/encrypted wireless networks

I started here:
Getting Your Wireless to Work - openSUSE Forums

Here is the output of the commands listed there.

WLAN: PRO/Wireless 3945ABG[Golan] Network Connection (wlan0)
Kernel Driver: iwl3945
dmesg | grep firmware
22.310834] iwl3945 0000:0b:00.0: firmware: requesting iwlwifi-3945-2.ucode
22.871425] iwl3945 0000:0b:00.0: loaded firmware version

sudo /usr/sbin/iwlist scan:

wlan0 Scan completed :
Cell 01 - Address: 00:22:75:94:AB:8F
Frequency:2.437 GHz (Channel 6)
Quality=26/70 Signal level=-84 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s
Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
Extra: Last beacon: 155ms ago
IE: Unknown: 001842656C6B696E5F475F576972656C6573735F3934414
IE: Unknown: 010882848B960C183048
IE: Unknown: 030106
IE: Unknown: 0706555320010B1B
IE: Unknown: 2A0100
IE: Unknown: 32041224606C
IE: Unknown: DD180050F2020101000003A4000027A4000041435E00612
IE: Unknown: DDA20050F204104A00011010440001011041000100103B0
Cell 02 - Address: 00:1F:33:26:71:2A
Frequency:2.412 GHz (Channel 1)
Quality=34/70 Signal level=-76 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Extra: Last beacon: 3094ms ago
IE: Unknown: 00056C6F63616C
IE: Unknown: 010882848B962430486C
IE: Unknown: 030101
IE: Unknown: 2A0100
IE: Unknown: 2F0100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32040C121860
IE: Unknown: DD090010180200F0000000
IE: Unknown: DD180050F2020101800003A4000027A4000042435E00623


/usr/sbin/iwconfig wlan0 | grep Mb:
Bit Rate=18 Mb/s Tx-Power=15 dBm

uname -r:

Any help is greatly appreciated.

I use the same device no problem
WPA Personal

On 11/30/2009 09:56 PM, caf4926 wrote:
> I use the same device no problem
> WPA Personal

In the “Manage Connections” option of the applet, delete the connection
and re-add it.

On 11/30/2009 11:44 PM, Larry Finger wrote:
> On 11/30/2009 09:56 PM, caf4926 wrote:
>> I use the same device no problem
>> WPA Personal
> In the “Manage Connections” option of the applet, delete the connection
> and re-add it.

To add to my previous answer. If you get a popup requesting the secret,
the current version of NetworkManager will never connect. It is a bug in
NM that should be corrected in the future. You need to use the Manage
Connections => Edit to enter the encryption method and the secret.

Tried that 2-3 times and it’s still the same.

Can you be more explicit?

If you have any connections you have already attempted to make - Delete it/them.

Make New wlan connection (Presumably you can see your access point in the range/list it shows) and go thru step by step. You must know what security your access point is using if any!? And obviously you need the passphrase/key for that.

So are you getting the working symbol as it tries to connect?

Tried that many times and it doesn’t work. If I login with Gnome it works perfectly, but KDE is borked. Is there a fix coming?

No, it doesn’t even try. It just goes back to the normal symbol. The Wireless light/LED never flashes or anything that would normally happen when it connects.

Newer KDE version do not have this bug, you have encountered. See on the signature of caf4926. He has fixed NM provided with KDE4.3.4. The initiali version of KDE provided with installation CD is 4.3.1, and is buggy.