suse 11.1 sound not working

Sound was working on 10.3,after installing 11.1 it stopped working.
Tried to follow instructions in
SDB:AudioTroubleshooting - openSUSE. Noluck.

Here is a ALSA url which lists the details of sound configuration:

please help

What was your sound test pass/fail criteria? Note, to test your sound I recommend you try each of these sound tests (as both a regular user, and with root permissions) to see if one might work:
speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 75%. Note the test for surround sound is different.

If that test yields errors, try instead this more simple test: speaker-test -c2 -l5 -twavTry as both a regular user and with root permissions.

You should hear a lady’s voice saying ‘FRONT RIGHT’,‘FRONT LEFT’ 5 times. If you hear that, post here, as your problem is more likely in badly setup applications/codecs than basic sound.

I took a look at your mixer settings, and highlighted in RED some areas for you to consider:

!!Amixer output
!!-------Mixer controls for card 0 [NVidia]
Card hw:0 ‘NVidia’/‘HDA NVidia at 0xfe028000 irq 22’
Mixer name : ‘Realtek ALC660-VD’
Simple mixer control ‘Master’,0
Mono: Playback 39 61%] -25.00dB] [on]
Simple mixer control ‘PCM’,0
Front Left: Playback 147 58%] -21.60dB]
Front Right: Playback 147 58%] -21.60dB]
Simple mixer control ‘Front’,0
Front Left: Playback 36 56%] -28.00dB] [on]
Front Right: Playback 36 56%] -28.00dB] [on]
Simple mixer control ‘Line’,0
Front Left: Playback 21 68%] -3.00dB] [on]
Front Right: Playback 21 68%] -3.00dB] [on]Nominally, the volume levels should be ok. But for testing for basic sound functionality, I recommend you move those levels up to 95% or so, and then once you have basic sound established, back off to lower levels to reduce distortion.

Also go to YaST > Hardware > Sound > Other > Volume and move up both the PCM and Master volume settings there to 95% or so. Close YaST. Then go to your mixer PCM and Master and move up the volume settings in your mixer (as described above).

Be certain to check your hardware (jacks plugged in correctly and all the way).

Please also let us know what rpms you have installed for your audio setup. You can do that by providing the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I note this for your kernel from the script: “Kernel release:
why the “trace version” ? That looks wrong to me.

Please also provide the output of:
rpm -qa | grep kernel