SUSE 11.1 running slow (nvidia problem?)

I am running openSUSE 11.1, x86_64, KDE4.1.3; on this hardware: AMD64 3200+, 2GB of DDR2 RAM, Nvidia GeForce 8600 GTS, and a 160GB PATA HD with a 2GB Swap. Now I remember some time ago that there were problems with Kwin for KDE4 and the Nvidia drivers, as far as I know this was fixed. I installed XFCE just to see if that was faster, and it wasn’t. Which leads me to believe that there is something in the kernel that’s different, or the display manger. I am sorely tempted to revert back to 11.0, it ran faster, the artwork was better, and it has Jack lab repos (I use linux for all my music stuff, which means i need low latency, and this slow down isn’t helping). Someone I ran into before said he had the same exact problem, so he switched to Mandriva 2009 and everything is working several times as fast as before. Note: I experience minor lag even when the desktop effects are turned off, Xorg uses about 20% of my CPU at all times, and I am running Windows XP on a separate HD and it runs fine.

Have you added the following in the xorg.conf file the section called
“Screen” (just after the color depth);

Option         "AllowGLXWithComposite" "True"
Option         "DisableGLXRootClipping" "True"
Option         "RenderAccel" "True"
Option         "AddARGBGLXVisuals" "True"

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 3 days 10:46, 4 users, load average: 0.02, 0.03, 0.06
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Have you tried running with CPUFREQ=no on boot, or setting the “performance” governor in the powersave application?
(dynamic ondemand should be ok after next kernel update)

Are you running PulseAudio? Frequently that’s been a source of issues for ppl in 11.1.

But Xorg using 20% CPU does suggest the Nvidia driver is still a problem.

If you run “top” command from konsole that may help you diagnose the processes that occupie most resources (ram,cpu)

xrestop is the other one to run :slight_smile:

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 3 days 11:53, 3 users, load average: 0.18, 0.07, 0.15
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Thanks for the suggestions, I’ll edit my xorg config as soon as possible and see if that works. I am running phonon with xine, so I don’t think pulse auido is a problem.

I compiled the Nvidia 180.25 driver and installed it. It solved a few issues wrt restarting x when logging out, suspend/hibernate and a few other minor issues. Anyway it runs smoothly with NVS 140.

I had a similar problem (posted in here) with a lowly spec’d 8400GS on and AMD 5600X2. I tried everything except compiling. I swapped the card for a 7950XT. Ran the sax setup ia run lvl 3 and all my bad CPU usage was gone. xorg was constantly using 20-30 % of CPU at idle. I also had no issues with 11 on the same hardware.

Thanks guys! I added the lines to my X-Server conf and everything runs like a dream now! I have full 3D acceleration, desktop effects running smoothly, CPUFREQ=no sped up my clock speed by about 10mhz, nothing special, but good to know. I followed the short tutorial in openSUSE news about fixing the DVD access problem, now I have a fully working system and am much more satisfied with 11.1. Thanks again.

Hey guys,

 I am facing the same problem with 11.1 Its running **** slow .But Suse 11.0 worked fine .My lap config is Dell Vostro 1500, 2 GB RAM,1.6 GHZ Core 2 Duo,8400 NVIDIA 128MB  Graphic card.So ,thers no prob wid my lap config..

I installed latest version of compiz.But still its very slow.Sometimes when I switch between windows I have to hover with mouse so that all content appears:(
Ofcourse this happens even when very few applications are running.Should I also edit my xorg file as mentioned above?.Plz help me…