Suse 11.1 & Lilo

I need to use Lilo for my Suse instillations. I use a third party bootloader for Windows and Linux, but for it to work it needs to copy a Lilo configuration onto the windows C: drive. This has worked out for me fine, all the way up to 11.0, but when I tried to select Lilo for 11.1, the installer told me it wasn’t supported (even though it gave the option).

I tried installing with GRUB, then running Lilo but that didn’t work out too good. For some reason Suse 11.1 doesn’t like Lilo.

So the question is, is there some way to get Lilo and 11.1 to play nice together? Or will I forever be stuck with Suse 11?

GRUB is not an option, since the bootloader I use doesn’t even know GRUB exists.

Lilo is still available as a package, just not supported any more by YaST. You can install it and then configure lilo.conf by hand and then run lilo every time you make a change in that file or the kernel or initrd files.

i think the basic question is do you really need to hang on to the
third party any longer…i know you might like it, and be used to it,
and have all your windows/linux needs dependent on it…but, i think
grub is probably capable of doing all you need to boot both windows
and linux…and can wholly replace the third party…

just a suggestion for you to fathom…(as you already have key yap’s
expert opinion on how you can have your lido and 3rd too)

by the way, a lot of the third party stuff i’m familiar with had it
beginnings in the OS/2 Warp world of the '90s which had to deal with
the very aggressive attempts to lock everything non-Redmond out of
all consumer computers…Partition Magic in particular was (and maybe
is) built on OS/2 code and was a big “shareware” hit…imho, there is
nothing really magic about it (or its spinoff BootMagic), except the

on the other hand, as far as i can tell grub may be REAL magic…

and suggest that someday (if it has not already happened) bootmagic
and all the other third party stuff will actually be grub code
enhanced and marketed…


/( )\ natural_pilot

The third party in question is HyperOs 2004FE, and it has a number of other benefits, rather than just being a bootloader. I get to drag and drop Windows instillations, I can assign big games an entire operating system to themselves and it helps kill rootkits stone dead, etc. It’s all Windows wrangling though and I know you folks aren’t really interested in that. The point being, only one version offered Linux compatibility and it only dealt with LILO.

Link to illustrate

So my choices are, Windows only, Windows + Suse 11.0, or Windows + Suse 11.1 if I can get LILO working. And I’d prefer number 3. Any help at all would be gratefully appreciated.

When I tried to change the bootloader from GRUB to LILO via YaST, I got this error message.

LILO version 22.8, Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2006 John Coffman
Released 19-Feb-2007 and compiled at 11:12:39 on Dec 3 2008
Running Linux kernel on x86_64

raid_setup returns offset = 00000000 ndisk = 0
BIOS VolumeID Device
Reading boot sector from /dev/disk/by-id/ata-ST3160827AS_3MT012JM
pf_hard_disk_scan: ndevs=2
0800 1885573E /dev/sda
0810 05DD05DD /dev/sdb
device codes (user assigned pf) = 0
device codes (user assigned) = 0
device codes (BIOS assigned) = 0
device codes (canonical) = 3
Warning: Unable to determine video adapter in use in the present system.
Using MENU secondary loader
Calling map_insert_data
Secondary loader: 18 sectors (0x3600 dataend).
bios_boot = 0x80 bios_map = 0x80 map==boot = 0 map S/N: 1885573E
Mapping message file /boot/message
Fatal: /boot/message is too big (> 65535 bytes)
Removed temporary file /boot/map~

I’m guessing that the second last line is important.

Sounds good to me. I’ll try that next.


I tried running Lilo as root and got the same message

Fatal: /boot/message is too big (> 65535 bytes)

TrapperQ wrote:
> And I’d prefer number 3. Any help at all would be gratefully appreciated.

i can’t help past what ken yap wrote…i guess you have to install it
by hand…maybe there is a LILO forum somewhere…and, an expert there
can give you the guidance you seek…

hmmmmm…i but it just works with all distros and you just need to
read the documentation…i didn’t look at it long, but i guess this
map can be followed:

if not i’d bet google can provide plenty others…

oh, look what google found:

/( )
^^-^^ natural_pilot

It looks like SUSE’s GRUB uses /boot/message to hold the graphical splash screen but LILO doesn’t support such usage, hence the message about the file too big. This may be one of the reasons for wanting to drop support for LILO in YaST. My guess is you should point LILO to a different file with just a simple text message for the message.

If you have the menu.lst file for GRUB, you should be able to translate by hand the essential elements of that to their equivalents in lilo.conf.

My thought was similar to @ken_yap’s - take a look at the lilo config file. I’m guessing it is pointing to /boot/message. Try removing that. If that works, you can consider creating your own boot graphic or you can use lilo’s very basic dos-like gui commands in the config.

Thank you for your kind assistance, I’ll try that out at the weekend.