Suse 11.1 Kernel Update problem

I took a kernel update over the weekend and now my system will not boot. /var/log/messages has Modprobe: FATAL: Could not load /lib/modules/ I checked this location and there are no files listed in the dir. I do have the Modules under It seems that my software raid will not start. When booting it goes to check the filesystems and says to run e2fsck on md0. Any help would be greatly appreciated. Thanks

Looks like you are still booting the old kernel Do you have got choices to boot into different kernels in your grub boot entry?

In other words: How does your file /boot/grub/menu.lst look like?

I can’t mount boot because that was in a mirror raid. The only options to boot are the kernel. I was trying to find where the setting is for modbprobe.


I was able to mount boot mount -t ext3 /dev/md126 /tmp
cd grub
I only see vmlinuz- and initrd- config-

I fixed the problem. My /etc/sysconfig/bootloader file did not have the updated kernel entry.

Hi all,

Got the same problem. The same entries in /var/log/messages. But this is from the moment the new kernel installed. If i boot now these messages are not loggged. My Grub menu.lst is oke it lists the new kernels and the menu.lst.old lists the old kernel but it’s no longer available. The change in the /etc/sysconfig/bootloader doesn’t work also. Anyone have an idea?

Maybe, it is not exactly the same problem:
As sampson1 showed, his system is a raid mirror and there is no menu.lst in his /boot directory. Yours has.
His system did not boot and stopped when trying to load the modules. Your system boots, now, without errors…:
So - exactly - what is your problem now? Which errors do occur at what stage of booting?

Hi, solved it. I think it went wrong during the last automatic update and the kernel did not install right. During the boot none of the modules got loaded (network, usb and so on) so not nothing worked. I did a new make and install of the kernel, installed the latest nvidia drivers and it’s working again… Much faster laptop now :). Learned from it and instandly made a backup kernel to load ;).


I have a similar problem after kernel update ( no usb, no network ). How can I install a new kernel ?