SUSE 11.1 KDE 3.5 screensaver config problem

SUSE 11.1 64 bit, KDE 3.5 (Kdesktop environment Release 3.5.10 “release 21.11”). I can’t find any “help about” for this package. This install used the openSUSE-11.1-DVD-x86_64.iso install DVD. There were no install poblems.

In the Configure – Kdesktop, Screen Saver I have the Start Automatically check box selected for 5 minutes. After the first install login (directly from the installer) when I select the Screen Saver the Window briefly shows a “loading” message, then the list of available screen savers appears in the Screen Saver Window. I selected a screen saver.

I did add the Packman repository and loaded some new software packages before the first real boot. The KDEartwork3-kscreensaver, KDEartwork3-xscreensaver and xscreensaver software packages are still installed and I never touched them (I only looked to verify there are installed). I didn’t do anything that should have affected the screen saver configuration that I know about.

I searched the forum for “screen” “saver” and “screensaver”, but didn’t find anything useful. When I added 3.5 to the search there were no results returned.

After my very first shutdown and real boot, when I select the Screen Saver the Window stays blank and never shows me a list of screen savers (i.e. the Screen Saver Window is always blank). The Start Automatically check box is still checked. Any idea of what is happening here?

BTW, I checked out KDE4 and it still has too many critical problems for me to use it yet, but its getting better. Maybe someday.

Interesting. Same thing here, the screensaver list is empty.

Me three. (Mine was an upgrade from x32 openSUSE 11.0 to 11.1 using the DVD.) Curiously, the entire screensaver list is there in KDE 4.


Anyone else have any information? Does this look like an 11.1 OpenSUSE distribution bug?

It’s been reported as a bug.

In the meantime, you can put your screensaver of choice in ~/.kde/share/config/kdesktoprc manually, e.g.


and set it up by running the corresponding binary, e.g.

/opt/kde3/bin/klines.kss --setup

Thanks for locating that information. Since it was a known bug in beta 5 that made it into the final release, I suppose it will not get fixed anytime soon.

I also upgraded from OpenSuSE 11.0 to 11.1 and have the same problem. For what it’s worth, the screensavers are available if I go into the Gnome desktop. But none of the openGL screensavers work, which seems to be a different problem.

If I use the ATI proprietary driver, I can’t use tvtime because of a YUY error, but glxgears works. If I use the default SuSE driver, tvtime works fine, but I have no openGL. Neither glxgears or glxinfo work.

Same thing here on Screen Saver list

Same here for me. Upgraded from 11.0 to 11.1 and nothing shows in the list (although I thought it did straight after the upgrade - maybe I was dreaming).

I have the same issue after upgrading to 11.1 from 11.0. However, if I use KDE4, the screensavers show up. Looks like 11.1 is NOT quite ready for prime time. An unrelated issue is I cannot get the proprietary ATI driver to work. I make a Suse 11.1 x64 rpm, yast installs it with no errors, but does not work. I have followed the procedures in other threads on the ATI driver, but no go. I have an MSI hd3650…

I installed openSUSE-11.1 KDE-3.5.10 on my mother’s old Dell Dimension 2100 PC (512MB of RAM, 1.1 GHz processor).

I also installed:kdeartwork3-xscreensaver-3.5.10-1.62
xscreensaver-5.07-6.41and her screen saver works fine. :slight_smile:

Has there been a fix since the complaints in this thread? … or did I, by this very simple install, work around the reported problem?

With tongue in cheek let me say… "Next time I look for a prime time criteria, I’ll be sure to add screen savers to the list … I mean, how can one do anything with out a screen saver ?? ".

But hey, lets get real. There is an easy work around to add the screen savers.

I definitely have a different assessment of “readiness for prime time” compared to those who think a screen saver is a prime time criteria.

My wife and I have spent a lot of time trying to sort my mother’s WinXP boot partition. What a mess. Now if ANYTHING is not ready for prime time, I would put winXP in that category, … although … come to think of it, winXP is the most popular OS out there. … I guess that means nothing is ready for prime time … or saying it differently, is the expression “ready for prime time” being over used and exaggerated to an unrealistic extent by many?

I have the three packages installed, and have even re-installed them. No change. When I go the configure them, the list box is empty. When I navagate to /opt/kde3/share/applnk/System/ScreenSavers and bring up the properties on the (pick any one).desktop config file, I get the following error:
The desktop entry file /opt/kde3/share/applnk/System/ScreenSavers/anemone.desktop has an invalid menu entry

My 11.1 install is on a 64 bit Intel 945 dual Pentium at 3.4 GHz w/ 1 gig or memory, parallel ATA DVD ROM, parallel ATA DVD writer (separate ATA channels/connectors) with a pair of 300 GB SATA drives.

I didn’t comment on any ready-for-prime time (certainly not about a trivial screen saver list) and my screen saver has always worked. The malfunction I have experienced is in the screen saver configuration application and still exists right now. The list did appear one time on the very first boot directly from the installer, but has never reappeared since my first boot from power up.

Speaking of comparing readiness with Windows, I would say that since 10.2 the hald-addon-stor uninterruptable wait on blk_execute_rq bug has been and still is giving me a Windows experience in Linux. I have to reboot every single time I burn each individual DVD / CD, or I get coasters. Now I have constant rebooting nightmares again :), whats next a Linux blue screen of death :)! This unpredictable bug screws up my DVD drives anytime it wants, but usually allows one good disc write after a reboot. Now, the zippy-the-pin-head libraries really sucked in 10.2 (since they were introduced in fact). Really not ready for prime time, but it has been fixed in later releases and is probably overall one of the nicest updaters available now.

Which 3 packages? Which versions? If I search for “saver” in screen saver, I get:
mymother@linux:~> rpm -qa | grep saver
mymother@linux:~>Do you have all 4 of those installed?

Also, I do NOT have special desktop effects enabled. Do you have that enabled? (and if so, could that be related to your problem)?

Why navigate anywhere? I just installed the above noted rpms, and the screen saver “just worked” in 11.1.

I see we posted almost simultaneously. Please see my comment above that the problem is not with the screen saver itself.

I’ve got the same problem as everybody else, but I’ve disabled the screensaver (i.e. the file ‘kdesktoprc’ includes the line “[ScreenSaver] Enabled=false”).

However, a screensaver comes on when I lock the screen, and I’d like to customize it (right now, the screensaver is changing, so it’s probably set to “random”).

Does anyone know which file I need to edit in order to do that?



It’s looking for:


instead of:


To test, try creating /opt/kde3/share/applnk/apps
and copy your ScreenSavers directory there… then logout and login.

It’s looking for:


instead of:


Excellent! That solved it for me. (For now, at least …)

Actually, I just created a symlink(*) from apps to System in the /opt/kde3/share/applnk/ directory, instead of copying the System subdirectory including ScreenSavers; that works also :slight_smile:

(*) in a terminal:
cd /opt/kde3/share/applnk/
sudo ln -s apps System