Suse 11.1 Installation Error - no valid root partition found


I am trying to install Suse 11.1 on a middle age PC (Pentium III 1.26Ghz) with no success.

The system had Xubuntu 9.04 installed without any difficulty. The hard drive was replaced so there wouldn’t be any issues with dual booting, etc.

The installation media is a Suse 11.1 Installation DVD obtained from On-Disk. The installation appears to go well until the system reboots. The Grub menu appears but both choices produce the same result - Error 15 “file not found”.

After booting the system using the DVD and selecting “Repair Installed System”, I chose the Expert Tools and tried “Boot Installed System”. The response was “No Linux root partition found”. Trying to install a new boot loader produced “No valid root partion found”.

Using the Partition Tool, I discovered that the hard disk (/dev/sda) was partitioned into three partitions.

/dev/sda1 753MB Linux Swap
/dev/sda2 7.32GB Linux Native Ext3
/dev/sda3 10.59GB Linux Native Ext3

The “Volume Management” tab does not list any partitions.

The “Unused Device” tab list all three partitions.

I have tried the installation multiple times with the same result. If the installtion sequence is generating an error and writing a notification to the screen, I am missing it.

Any help would be welcome.


First, have you tried checking the md5sum of the dvd?
What DE are you trying to install? Kde or Gnome?
During the installation did the installer threw some error messages?
Do you want to try reinstalling it again, while it is still not functional.

Just a suggestion:
Your machine is a bit older maybe you can try xfce because it is lighter and a bit faster for the installer to finish. With your situation with suse having a problem finding the installed system in reading the partitions, try to start the installation using the expert partitioner so you can assign and know which partitions are assigned for /, /home, swap and maybe /boot. Lately I encounter problem installing opensuse in an older pc using extension 3 (not really sure if some had encounter this too) so probably try using “xfs”,.With xfs if you use it and your /boot is in / partition suse will be unbootable. To make it bootable you have to create a /boot partition formatted in extension3. I checked my machine’s boot partition and the content is only 21 mb (I use 50mb for my /boot partition maybe you can search for the right size of yours to save more disk space)
During the installation, after you have already filled up the necessary things e.g: partitioning, password, etc, you will be presented with the choices you have made by the installer, try to review all before proceeding with the system installation. The first thing you have to look is the boot loader option,
have a look to where it is installing the loader, look for the fstab entry, etc. and make a note for future trouble shooting/reference or for posting question in the forum.

Just in case you’re not familiar with the boot options buttons in opensuse installer, when you click that boot options there is a drop down button in the lower right corner of the window called “other”.

Hope this help if you decide to reinstall.

Thanks so much for the help.

I tried re-intall again and for some reason it worked. I have no idea what, if anything, I did differently. Fouirth time was the charm.