SUSE 11.1 install not recognizing PATA hard drive


I have an Intel MB (855GME with 6300ESB) that I’m having trouble installing OpenSUSE 11.1 onto the IDE drive. It will install to a SATA drive but for various reasons I need to install on IDE (PATA on 6300ESB). The install fails to find any ide drive (I know the drive/interface works because I can install XP on this same ide drive and boot from it, also RHEL4 boots). If I parse the dmesg output I see the message “ata_piix 0000:1f.1 device not available because of BAR 2 (0x0-0x7) collisions”. I’m trying to determine if there’s some workaround for this. I’ve tried various kernel parameters and no joy.

I’ve tried Ubuntu with similar results. I’ve tried the all_generic_ide kernel param too.

Older kernels WILL install onto this same MB/PATA controller (Ubuntu 6.06, 2.6.15 and RHEL4) so it seems that something changed in the ATA driver as the kernel has matured and my bios isn’t up to snuff for these pickier drivers.

Any ideas?? THANKS!

Make sure the jumper is set to Master

Yes, thanks, that has been done.

It’s alone on the cable isn’t it?!

Yes, it’s the only drive on the cable. I can remove this drive and place another (already imaged drive) on the same connection and it will boot from this drive (or alternatively I can install XP on this drive). I’ve tried multiple drives. I’ve tried ide0 and ide2 individually and they both generate the same result. I’ve even tried multiple MB’s that are identical (we manufacture SBC’s for VME and so we have many of these board’s on the shelf) so I know it’s not a physical problem with the hardware (i.e. ATA controller section of 6300ESB).

So did you try something other than 11.1, which will end support soon (end Dec 2010)

Are you installing this to a stand alone IDE on what kind of board? Chipset numbers do nothing for me, I need to know the motherboard’s identification and features.

I think 11.1 is when the kernel departed from describing devices as /dev/hdx to /dev/disk/by-id/uuid
When the openSUSE CD/DVD gets to the partitioning selection, you chose custom and does that show you all of the attached drives?

Ok, so this is not a COTS motherboard. This is a custom Single Board Computer (VMEbus-based form factor), based on an Intel reference design. It uses the Intel 855GME northbridge and Intel 6300ESB southbridge. The PATA/SATA controller is built into the 6300ESB. OpenSUSE never gets to the partitioning screen. It fails before that point with a dialog that says basically ‘no hard drives found’.

Yes, I’ve tried Ubuntu 9.04 and Fedora Core10. Same failed results.

RHEL4 and Ubuntu 6.06 WILL recognize the hard drive on PATA and install though.

I’m wondering what options are set in the bios,(involving hard disks and there controlleres) ? Could you enter the bios and let us know what you find?

So are you sure that the southbridge 6300ESB supports IDE/PATA? I see it supports SATA and USB but … ?

Not sure why the older OS recognizes the IDE and the new OS doesn’t but can you check the bios to enable optimal compatibility. Obviously, I’m leaning towards a hardware issue with the motherboard rather than an issue with OO 11.1 or Ubuntu 9.04.

Okay google is my friend and can be your friend. Definitely a problem with the Intel northbridge/southbridge of the motherboard. The way Intel setup the SATA drives, these show up as /dev/hdx instead of /dev/sdx and that makes sense for your collision errors to me. IOW, SATA and PATA are fighting over /dev/hda.

possible solutions :
Intel IDE/PATA driver (ata_piix.ko) for Linux Automation DS6.8SP2 to DS6.9SP2 | Symantec Connect

Less likely but still:
boot error ata_piix 0000:00:1f.2: no available legacy port [SOLVED]