Suse 11.1 install help please

I’m having some trouble installing opensuse 11.1. I’m running vista 32bit and ubuntu 9.04, and I’m trying to add opensuse 11.1. When I boot from CD and I run the installer - on text mode because the other resolution modes were giving me issues - it works fine until it gets to this part where it asks me for a linux account and password. I have no idea what this is, and whatever I type is incorrect. I’ve read on other forums that it’s asking for the root account and password. I’m not sure why, this is a fresh install, and I have not had any prompt ask me to create an account/password so I have nothing to work with here. Can someone tell me why I’m being prompted for account/pass and what to type in :\

thanks in advance,

Hey does this have anything to do with my boot level? like before it asks me for the linux account name and password, I remember reading something that states its at boot level 3, or boot level 3 skipped, if I could change the boot level would that change whether or not it asks for linux account/password?

At any time did you enter a username, like your name? And then a password in a slot plus a confirmation password in a slot below the first slot?

porkpork wrote:
> Hey does this have anything to do with my boot level? like before it
> asks me for the linux account name and password, I remember reading
> something that states its at boot level 3, or boot level 3 skipped, if I
> could change the boot level would that change whether or not it asks for
> linux account/password?

because neither booting the Live CD nor installing openSUSE 11.1 does
not require either a “linux account name” or a password, this sounds
like one of a few things:

  • you downloaded a faulty CD image and didn’t md5sum check it for
    errors prior to burning the disk/trying to boot or install (see items
    2, 3, 4, and 6 in

  • you downloaded some version of 11.1 that did NOT come from the
    source listed in item 1 of that same page–for example: the KDE folks
    recently released a new version of KDE4.x on top of openSUSE 11.1
    which DOES require a user name and password…and, some magazines and
    book publishers give away disks…who knows what they require [if that
    is the case then you need to ask the disk/iso maker what you should use]

-if your disk came from the “openSUSE community” community page AND
is absolutely 100% perfect then your problem is likely either too
little RAM (plan 500 MB min) for it to all fit in [remember, Live CDs
run in RAM]

-OR, the installer doesn’t work will your graphics–and, that is a
little too involved to include until you/we know that none of the
other faults (above) are the problem.

prove to yourself that you have a perfect install disk (from us) then
write back with how much ram you have AND that you ran the install
medias “memory check” at least a couple of hours with zero errors AND
your graphics info (nVidia, ATI, Intel, whatever)…

oh, and welcome to open source, Linux and openSUSE…you will love
it, once this beginner hill is behind you.


Well I have 4096MB of memory, so I’m certain that’s a non-issue. I was as aforementioned having issue with the installer displaying properly with my graphics setup. Regardless of the resolution I chose, it wouldn’t display. Either way, this was quickly overcome by executing the installer in text mode. I have a Radeon X1650 graphics card, I’m not sure if this is an issue. I downloaded the ISO from this website, version 11.1. If I remember correctly I had checked the hash with WinMd5Sum and compared it, and it was good. However, since I’m not completely sure, I’ll download the image from again, and burn it onto a fresh CD. I’ll try booting it again, and post the results. Thanks for your replies. Cheers.

If you still have the .iso you downloaded first time you can just do a re-check in bittorrent.
How are you downloading it? In bittorrent? In a browser (what browser)? What files system is it (NTFS,FAT)?

Oh, well I already re-downloaded it using the options: 32bit PC, LiveCD, Standard (ftp or http), same as before. I checked the md5sum after downloading the ISO, it was fine. Then I ran Suse’s media check from the install menu after I booted the CD I made. The md5sum checked out okay. However I still have the same problem as before. One being that I can only use text mode, as the resolutions listed keep failing. So I run text mode and after it jumbles off a lot text and finishes loading, it again greets me with the text:
Welcome to openSUSE 11.1 - kernel (tty1).
After which it prompts me for a “linux account”, however this time I typed in “root”. It didn’t bother asking me for a password, it simply said something like “Welcome, have a lot of fun…” So I assume root is an acceptable account. However it then gives me a regular linux console prompt. And that’s it. I don’t really know any commands so I don’t know what to do from here. Are there some commands that I can type that will finish my install for me?
Also note that I have not made a partition in my hard disk for suse, as I have heard that suse 11.1 creates a partition/swap drive for itself during the install process and you only need to defrag you drive before hand to supplement the process.

Also, getting back to the resolution problem, I’ve noticed when running the installer on any given resolution that my monitor displays all the text loading just like text mode does during install, but when it gets to the part where it should prompt me for a “linux account” like text mode does, my monitor simple turns off and starts blinking like it isnt able to recieve any input from the computer. Also my optical drive eventually stops spinning so it not like I’m not waiting long enough for something to load, it’s just come to the part where it wants me to enter in a linux account name and password, and at that point my monitor stops responding.

Sorry for rambling on but this seems like a fairly unorthodox problem, so I’m really trying to supply you with as much info as I can, some of which might be completely trivial, but I’m new to multibooting operating systems so please bare with me.

Sorry I didn’t catch your response earlier; no I didn’t. This is a fresh install and I haven’t entered anything like that. This is why I find it strange that its requesting an account/password without it ever giving me a chance to create one.

Check here
Installation Problem Suse 11 - openSUSE Forums

Awesome :slight_smile: I followed that link and read the info on it, I used the install option “3” and the command sax2 -r -m 0=vesa to change my resolution and I was able to start it. THANK YOU :slight_smile:

However once in suse, after I click install and get to the part that partitions my disk, it is automatically set to delete my Ubuntu 9.04 partition and write over it. I’m fine with this option as long as I don’t run into any MBR problems where I can’t load any of my operating systems. If I choose to overwrite my Ubuntu with Suse, is it safe to say that the suse installer will handle everything well enough so I can choose to boot either vista of Suse from a boot menu when I start my machine. I want it so I can choose to boot either OS. Also when suse overwrites my ubuntu I assume I’ll also lose the GRUB boot loader as well. Does suse have its own boot loader, because I’d much rather use a 3rd party boot loader than microsofts, I want my operating systems to remain modular and not become dependent on one another.

Oh and one more thing, what the difference between installing suse from the LiveCD versus the DVD. Is it the same thing? or is the DVD better?

Thanks again for all your help.

OK. There is quite a bit to consider here. First you don’t have to delete Ubuntu - they way around that is to use custom partitioning. But how much free space do you have? I’m concerned you may not have sufficient knowledge to tackle Custom Partitioning (No offence)

Might be an idea to boot with the live cd or if you can still do so in to Ubuntu and in a su terminal do

fdisk -l

Post the result. I or others will be able to see what partitions you have. I have a feeling we’ll find other than the windows NTFS well see an extended partition containing one linux partition and one swap partition. That would be Ubuntu’s default I think.
What you can do is tell suse not to install a bootloader. Then once done, you can add an entry in to ubuntu. If you know how, all this is lot’s simpler than it sounds.

I would also advise making a backup of documents etc you simply can’t afford to loose.

The DVD is a better method for install IMO and I’m not alone in that opinion.

No offense taken, I don’t know much about this stuff, and it probably best not to assume I do.

Here is the result of sudo fdisk -l:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x7bfe52ae

Device Boot Start End Blocks Id System
/dev/sda1 1 1274 10233373+ 27 Unknown
/dev/sda2 * 1275 31055 239215882+ 6 FAT16
/dev/sda3 31056 58252 218454744 7 HPFS/NTFS
/dev/sda4 58253 60801 20474842+ 5 Extended
/dev/sda5 58253 60440 17575078+ 83 Linux
/dev/sda6 60441 60801 2899701 82 Linux swap / Solaris

Again I don’t have a problem overwritting Ubuntu with Suse, as long as I don’t get stuck with microsoft’s bootloader and as long as overwritting ubuntu’s partition like that won’t cause errors. I was probably gunna uninstall Ubuntu anyways, SUSE seems better.

Btw, sda1 is my EISA configuration partition (10GB), I’d rather not touch that. sda2 is my Vista partition. Sda3 is an NTFS drive I use mostly to store movies, songs, games, and other large file on. sda5 is my ubuntu partition, sda6 is the ubuntu swap drive. However sda4 the resulting empty 20GB partition that I made from shrinking my D:/ drive (sda3), to make room for the opensuse 11.1 install.

Again I’d rather just overwrite ubuntu and get it over with so as long as at start up I get prompted with a boot menu and am able to chose to either boot vista of suse I’m fine. I would just like to have a good linux distro and vista as a comfortable fallback until I become really familiar with linux.

/dev/sda2 * 1275 31055 239215882+ 6 FAT16
I’m not sure about this partition - What is the Computer?
See the * it means this has the boot flag on it. I wasn’t expect that partition or the boot flag on it.

Is the computer using grub to boot now?

Thats my vista partition it came with the computer.

Oh, I missed that, yeah I believe it is. But I modified my grub menu with ubuntu to make my vista partition the default boot partition. So when my computer starts it lists my operating systems, and the vista partition is highlighted as the OS that will boot unless a key is pressed in 10 seconds.

So what is sda3?

I dunno its just an NTFS formatted drive. It my D:/ drive, windows vista has full control/access to it, but until recently it didnt really have anything on it. I recently started using it to hold my large files as explained above (videos, songs, games, etc).

When I got my computer it had sda1, sda2, sda3 primary partitions on one disk.

sda1 is my EISA configuration (some sort of windows recovery partition).
sda2 is my “C:/ drive” where vista resides.
sda3 is a usable NTFS partition as stated above.

sda4 was recently created by shrinking my sda3 20GB to make room for suse.
sda5 was fairly recently to hold my ubuntu 9.04 install.
sda6 was created at the same time as sda5 as a swap drive for ubuntu 9.04

As stated above I currently use GRUB boot loader on startup which displays a boot menu with options to boot either ubuntu (and various ubuntu recovery and old kernel options, as well as a linux memtest) and windows vista.

If I can safely overwrite my ubuntu with suse so on startup when the GRUB boot menu displays it gives me the option to boot either vista or suse, then I’ll do that.

Well consider removing ubuntu, it will be easier.
Or let suse installer use that space.
It should be as simple as that.

FYI. Partitions that are being formated will show red in the summary.

If it were me, I would do it all manually in Custom Partitioning.
You migh pick up some ideas/knowledge from these:
Watch a SUSE 11.1 install Slideshow - openSUSE Forums

Install Demo - With Pics and Video - openSUSE Forums


Thanks for the info and help. I’ll check up on these links and try and learn how to properly custom partition for the future. I got it working by downloading and using the DVD installer instead of the LiveCD, you’re right it was much easier. Thanks again for all your help, cheers.

Oh btw, I ended up using the DVD KDE4.1 install and replacing my Ubuntu with suse, so now I have suse’s GRUB loader screen on start up with the option to load either suse or vista. This is exactly what I wanted :slight_smile: