Suse 11.1 hijacked MBR during install, and new GRUB penguins

When I installed 11.1 as a second Linux distro about a month ago, I selected to place SUSE’s grub on that root partition, thinking to add a chainloader entry to the pre-existing boot menu. The installation summary listed correctly; it said that grub would be installed to sda3, SUSE’s root partition. However, rebooting showed SUSE’s grub (in all its green glory) first. Now, there was an entry for the first Linux distro, and that’s nice, but accessing it brings up that boot menu with the same SUSE green grub theme.

In addition, the grub boot menu has recently (last week or so) acquired strange, animated penguins. It only shows up occasionally, but I have no idea where they’re coming from. Is it some new feature from the latest grub update? I didn’t check what packages have been getting updated, but a look at /var/log/zypp/history showed:

root@compy #: cat /var/log/zypp/history|grep grub
# available bootloader for your platform (e.g. grub, lilo, zipl, ...).
# available bootloader for your platform (e.g. grub, lilo, zipl, ...).
# available bootloader for your platform (e.g. grub, lilo, zipl, ...).
# 2008-12-10 06:56:27 grub.rpm installed ok
2008-12-10 06:56:27|install|grub|0.97-156.3|i586|root@build19|home_rpmdir_rpms|d32bb356fb650aa371b6a0cd7d0df59c3318cd12

Since I only installed SUSE a few weeks after 2008-12-10, I assume that date is either on the package in the repos, and/or it’s the version rolled with the distro release–as in, hasn’t been updated since distro’s installation.

Anyway, how can I get SUSE’s grub splash off of the first distro’s grub boot menu? And what can be done about the strange, grub penguins?

If you will chroot into your previous distro via openSUSE or a LiveCD and reinstall grub (google for tutorials) you will have the first grub menu back. Then just add openSUSE if desired to the menu.lst. The penguin frequency is enabled or disabled in the gfxboot.cfg file which is compressed in /boot/message. An edit to this file with “penguin=0” appended will eliminate their appearance.

Thanks, Cryovac!