SuSE 11.1 freezes after some seconds


I use SuSE Linux on my Thinkpat A31p since, since I have forgotten my first version. The last one was 10.3 with KDE 4.0. It was not perfect, but working.

Now I did a new install of 11.1 (KDE 4.1) and my laptop freezes after a short time. The freeze is complete, no mouse move, no ctrl-alt-backspace, no ctrl-alt-F1 and so on.

The fan keeps working hard, so the cpu seems to do something.

I reinstalled: freeze. I installed Gnome: freeze. I changed the xorg.conf from the one of my backup: freeze.
I suspected the sound driver (snd_intel8x0) and tried to delete it in yast: freeze.
I tried to boot with brokenmodule=snd_intel8x0: freeze. May be it’s not the sound driver.
Obviously I tried the failsafe boot: freeze.

ext3 and reiserfs are really robust! :-)(

When I boot from the DVD to do the install it works for hours. It’s the resulting system which has somewhere a hitchup. I don’t know how to trace it. Sometimes it freezes after some minutes, sometimes after some seconds.
When I reboot and do nothing, it freezes also.

I am using another operating system to write this and will revert back to 10.3. But it’s a pity. Has someone an idea how to trace it?


I don’t think, despite the excitement, that 11.1 is the best release. Suse is still great, but until the bugs are fixed, go back to a version that works for you.

I don’t give up so easily. Yes, I will revert soon to 10.3, but there is a bug and I want to help to find it.

The help I need is how to isolate the wrong module. But I am not a deep linux expert.


  • when I boot failsafe the display resolution is a different one. Without studying the boot parameters I supporse that failsafe uses the frame buffer instead of the radeon driver. Is it right? If yes the error is not in the radeon driver.

  • when I boot in init 3, there are no problems. It’s the desktop which freezes. But both kde4 and gnome freezed, so it’s not the desktop itself.

  • it might be the X-server. Is there a chance to play with different X-Servers?

  • when I boot from the install DVD all works. Which is the environment which is in use during install? Where is the difference to the normal use?

  • I have detected the sysconfig file and will try different window managers.

  • I don’t love to boot windows to write to this forum. Is there somewhere a how-to to install a second linux upon the same partition and insert it into grub?


same here, please file a bug and put the number here.

Core 2 U2400, 1GB ram, Intel 945 GM, Dell Wireless 1390 WLAN. I think it’s an X problem because audio files keep playing for a few seconds.


I’ve seen an issue in Debian Lenny Release notes, relating to Thinkpad CPU fans and 2.6.26 kernel.

They mentioned a workround, you might see if that helps you, if so a bug report would be especially useful.

another note: it seems to be correlated with closing windows (just experienced it twice with terminal windows); I think it freezes before the window actually closes. This is now occurring on my desktop, which has a core2 4300, 4gb of ram, and an nvidia gtx 260 driver version 177.82 on 64-bit opensuse 11.1.

robopensuse: could you post more specifics? I’m not sure exactly what to look for. The release notes (Release Notes for Debian GNU/Linux 5.0 (lenny), Intel x86) are very long…


Is your Caps Lock light flashing during the freeze?

If so, this is almost certainly due to a bug in the wireless driver. Maybe disable wireless and see if you get the same problem.

There is a patch for this, if it turns out to be your problem.

I have experienced similar problem but to a lesser extent. In my case desktop freezes if idle for some time. I use gnome. KDE is
almost unusable since 11.0.

Yes, during freeze the num-lock and caps-lock keys flush. Where do find that wireless patch?

I just spent over 15 minutes looking for the thread with the patch info, but with no luck.

I would appreciate if you’d at least confirm that the problem is caused by your wireless card before I waste any more time looking for this thread.

This can easily be done by disabling your wireless card and waiting to see if you still get freeze ups. Thanks.

Here is the thread:

freeze up problem, may be related to 4965 card (?) - Page 5 - openSUSE Forums

Good luck.

I had a different card (Trendware with an atheros chip) and I would get freeze ups until I unplugged it. That would be a good place to start.

It is related to network card. Here are two kernel failure messages that popped up on my desktop.

I find Ubuntu guys have released a patch. Is there any news
from Suse folks?

Kernel failure message 1:
------------ cut here ]------------
WARNING: at include/…/net/mac80211/rate.h:152 rs_get_rate+0x14c/0x187
Modules linked in: aes_x86_64 aes_generic ip6t_LOG xt_tcpudp xt_pkttype
ipt_LOG xt_limit af_packet xt_physdev sco bridge stp bnep rfcomm l2cap
snd_pcm_oss(N) snd_mixer_oss(N) snd_seq(N) snd_seq_device(N) ip6t_REJECT
nf_conntrack_ipv6 ip6table_raw xt_NOTRACK ipt_REJECT xt_state iptable_raw
iptable_filter ip6table_mangle nf_conntrack_netbios_ns nf_conntrack_ipv4
nf_conntrack ip_tables ip6table_filter ip6_tables x_tables ipv6
cpufreq_conservative cpufreq_userspace cpufreq_powersave acpi_cpufreq fuse
loop snd_hda_codec_idt(N) arc4 ecb crypto_blkcipher snd_hda_intel(N)
snd_hda_codec(N) iwlagn iwlcore hci_usb(N) snd_hwdep(N) snd_pcm(N) rfkill
dcdbas(X) snd_timer(N) btusb led_class uvcvideo snd(N) sdhci_pci mac80211
video compat_ioctl32 sdhci ohci1394 iTCO_wdt battery soundcore
iTCO_vendor_support kvm(N) output ricoh_mmc mmc_core wmi cfg80211 ac button
bluetooth ieee1394 intel_agp videodev sky2 rtc_cmos snd_page_alloc(N)
v4l1_compat rtc_core nvidia(PX) rtc_lib i2c_i801 sr_mod i2c_core cdr
om joydev pcspkr uinput sg usbhid hid ff_memless linear sd_mod crc_t10dif
uhci_hcd ehci_hcd usbcore dm_snapshot edd dm_mod ext3 mbcache jbd fan
ide_pci_generic piix ide_core ata_generic ata_piix ahci libata scsi_mod dock
thermal processor thermal_sys hwmon
Supported: No
Pid: 1938, comm: iwlagn Tainted: P W #1

Call Trace:
<ffffffff8020e42e>] show_trace_log_lvl+0x41/0x58
<ffffffff804a1e97>] dump_stack+0x69/0x6f
<ffffffff80240eb2>] warn_on_slowpath+0x51/0x77
<ffffffffa0aec887>] rs_get_rate+0x14c/0x187 [iwlagn]
<ffffffffa0a44591>] rate_control_get_rate+0x79/0xeb [mac80211]
<ffffffffa0a49c2a>] invoke_tx_handlers+0x286/0x56a [mac80211]
<ffffffffa0a4a755>] ieee80211_tx+0xa9/0x1d2 [mac80211]
<ffffffffa0a4b385>] ieee80211_master_start_xmit+0x182/0x1c1 [mac80211]
<ffffffff80442542>] __qdisc_run+0xc3/0x1e2
<ffffffff80431596>] dev_queue_xmit+0x21b/0x34b
<ffffffffa0a43b18>] ieee80211_sta_work+0x1fc/0x39a [mac80211]
<ffffffff80250d37>] run_workqueue+0xa4/0x14c
<ffffffff80250eb7>] worker_thread+0xd8/0xe7
<ffffffff8025434d>] kthread+0x47/0x73
<ffffffff8020d7b9>] child_rip+0xa/0x11

— end trace eb2b81f8eadfc333 ]—

Kernel failure message 1:
iwlagn: WARNING: Requesting MAC access during RFKILL wakes up NIC
iwlagn: WARNING: Requesting MAC access during RFKILL wakes up NIC

purna chakra wrote:
> It is related to network card. Here are two kernel failure messages that
> popped up on my desktop.
> I find Ubuntu guys have released a patch. Is there any news
> from Suse folks?

The code is completely different in current kernels, thus I think
there is a fix. I cannot speak for the openSUSE time frame to
implement these changes, but if you want the latest wireless drivers,
download the campat-wireless code from and build it.
Unfortunately, there is no RPM package for this material.


Having the same problem on a Dell Vostro 1400, core2 2.4, 4GB, intel wireless. System freezes 5-10 minutes after login. Numlock and scoll lock flash on off at a steady rate. Same thing with a brand new install of Ubuntu 8.10. Sometimes Ubuntu lasts long enough to patch. I turned off the wireless and it has been running for about an hour fine. Sort of useless without wireless but hopefully I’ll find a fix I can handle.

The modules failed to load. Showing some “Invalid module format” message.


here is a detail of the bug :

I don’t have a wireless card.

eth0 Link encap:Ethernet HWaddr [deleted]
inet addr: Bcast: Mask:
inet6 addr: fe80::219:dbff:fe6d:a79f/64 Scope:Link
RX packets:15917 errors:0 dropped:0 overruns:0 frame:0
TX packets:4614 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3711867 (3.5 Mb) TX bytes:900453 (879.3 Kb)
Interrupt:23 Base address:0x8000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:269 errors:0 dropped:0 overruns:0 frame:0
TX packets:269 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:13125 (12.8 Kb) TX bytes:13125 (12.8 Kb)

uname -a
Linux oliver #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

It always happens when I try to close windows. Some applications, e.g. kwrite, never freeze, whereas others, such as Firefox, freeze sporadically, and kate – when I’m using my default 3-window session, almost always freezes. The freezes are of varying length: sometimes as short as 20 seconds, usually around 30-40, and I’m sure they’ve exceeded a minute.

Also, audio continues to play but Amarok won’t advance to the next track (waiting for a UI update?). All X11 actions (keyboard and mouse input) are delayed until the screen un-freezes, where they happen all at once.

Any updates would be appreciated; after living with it for quite a while, I’m finally starting to think about switching distros…


filed a bug

I had a similar problem that i solved changing the defaults into yeast partitioning tool.
Into the fstab options dialog, the partitioning tool is set normally to mount your hdd partitions identifying them by id.
So you have an /etc/fstab file with rows like:
/dev/disk/by-id/scsi-SATA_XXXX_YYYY_ZZZZZ-part6 …

I solved the problem changing the radio button, into fstab options dialog of the partitioning tool, to “device name” from “id name”.
When you apply your change you will have an /etc/fstab file with rows like:

/dev/sda6 …

In this way i solved my (and your, i hope) crash.