Suse 11.1 Error : no greeter widget plugin loaded

Hello

I ran an update on my suse machine & rebooted …

After I rebooted I got this error message

“No greeter Widget Plugin loaded”
I click on okay and it bring me to dos prompt to type my id & password

Has anybody seen this problem before and How did they resolved it?

thanks

After your id/pass try re-installing kde4-kdm or kdebase3-kdm (dep.on your KDE version) from the officially supported repos.

After your id/pass try re-installing kde4-kdm or kdebase3-kdm (dep.on your KDE version) from the officially supported repos.

Thanks for replying to me, Cryovac

what do I type in the command for Kde4-kdm? (Details)
Do i just type kde4-kdm at the command line?

thanks

See if the package is installed:

$ sudo zypper search kde4-kdm
S | Name                       | Summary                                           | Type
--+----------------------------+---------------------------------------------------+--------
i | kde4-kdm                   | KDE login and display manager                     | package
i | kde4-kdm-branding-openSUSE | KDE login and display manager                     | package
  | kde4-kdm-branding-upstream | KDE login and display manager - upstream branding | package

If not installed (note the “i”):
$ sudo zypper install kde4-kdm kde4-kdm-branding-openSUSE

If installed then be sure the pkg is from an official repo.
$ man zypper

thanks Cryovac

your suggestion work … the only thing I did …at the prompt, I type the $ sign and it did not work …

the command by itself work fine at the prompt … thanks anyway …it work

Hi

since 11.1 latest update (Feb 20,2009) I also got console login and had to login and start “startx” manually instead of getting an x-login.

In /var/log/messages I found “Abnormal termination of greeter for display…”

Updating kd4-kdm exactly as suggested by you solved the problem !

Great!

Thanks
Werner