Suse 11.1 + Epson R200 = Slow Printing


Sorry for my english first. I have a problem with Epson R200 in my system. If it prints any kind of graphics (even in OO Writer or in testpage) in prints slow and waits up to 1 second between easch head move. On testpage it only prints slow the part with color wheel and radial lines and Imageble area section. I found that lspci shows only 2 EHCI ports on my ASUS P5K PRO. May be this is the problem…
I am using CUPS 1.3.9 and SUSE 11.1 with KDE4.

can we ask which printer driver you have installed; to run your R200 please;

Sure! Yast tells that it uses “Epson Stylus Photo R200 - CUPS+Gutenprint v5.0.2”. If you need to know more - tell me, where can I get it. I am not experienced user, it`s my second month under linux :slight_smile:

if you look at this page,

OpenPrinting database - All Epson Printers

you can see that OpenPrinting, the best source of advice, says your printer is partially supported; newer iterations of the R200, eg the R280 are more fully supported;

Epson do offer drivers of their own for linux; I can only suggest you try their driver as a comparison, and perhaps let us know how it compares to gutenprint;

Download Inkjet Printer [AVASYS CORPORATION]](

if you select your printer, and download the file: you can see it asks you to specify your distro of linux; so presumably it will offer you an rpm file; if you download that, and right click on it, and select install with software manager, that should open YaST: you enter your substitute user, su, (also called root) password;

you may then need to go into CUPS:

open your browser: Firefox, and copy and paste this line


and that should open cups for you; it is a local entry, so do not worry that you are using a browser; you can then configure the Epson printer driver, if you choose to install it;

best wishes, let us know what you opt for;

the above options are free, as in beer;

if you really love your printer, and wish it to work well;

go to turboprint:it will cost you a few dollars;

ZEDOnet | TurboPrint Linux | Printer driver for Linux

install turboprint; it will work quickly and well, and give you optimum performance for your printer; we use it for our Canon inkjet printers

Yeah! Thank you for help! With avasys drivers printer works fast as Windows drivers. It prints with same quality but there is one big problem: it fails to print graphics from GIMP.
If I send a jpg or postscript file to it using lpr - it prints fine and fast. But after printing from GIMP it fails and CUPS shows this message near printer name: “/usr/lib/cups/filter/rastertopips failed”.
In terms of options avasys driver is poor: there are no advanced color and printer settings, but it has all, what really needed: color/mono mode, paper size, print quality (full list). It doesnt provide services, like calibration and nozzle check/clean. So if gutenprint wouldnt be so slow, Ill prefer gutenprint. Now i am digging about turboprint... Thanks again! Sorry, I am not correct: gutenprint only supports buttons for maintainance, but cant print this jobs and says: “/usr/lib/cups/filter/pstoraster failed”.

same here with a Canon ip6700D accessed over a printserver using LPR protocol.
Testpage works fine, but printing anything gives me this error.
Am I missing some userrights / wrong group? Tried to add myself to lpd, but that did not help.

Hi WhiteWind;

thanks for the feedback on the avasys driver; well done on getting it installed and running; did you need to open CUPS and change the default driver?

support for Epson drivers seems to have been variable: if you want to get your printer working well; get turboprint; (you don’t have to pay for virus checkers on linux) so that can pay for turboprint;

Hi Grexe; welcome to the OpenSuse forums;

I do not know about printservers; if you post on the network/internet sub-forum, someone like swerdna may be able to help;

if you were running the 6700D on a USB off one computer, I see that canon do NOT make a linux driver;


they do make drivers for some inkjets; it would be nice to think it is each new inkjet they now release; but I am not sure if it is so

First of all - thanks to you, pdc_2, you help was exactly what I needed. After I installed new driver CUPS showed me two printers installed: with old driver as default and with new driver. Drivers work together with no problems (i have not tried to enable both at the time) and I didn`t need to cunfigure it again (but I done it as i missed understanding what i have two printer drivers installed first time). I read all info about turboprint and found it very useful for my needs, especially because it have advanced options for high quality printing (profile support and more). Hope to buy it soon. Thank you again!

glad it worked out well; if you get turboprint, let us know how it goes for you

One day before I have tried again to fix “rastertopips failed” error, I was googling almost a hour :). After all I just kill all printers and start to reinstall my R200. And I found a strange solution (may be its starange for me, not for others): Ive tried to install avasys driver not on avasys detected printer, but on the default one. In CUPS administration I choose not “pips” device of my printer and now it works with no errors and with full speed. This solution is good, before I get turboprint. If I get it - I`ll write here and share my experience.

Now, I just want to pin the problem )) I am not a newbie in linux now, but I still have a printing problem in suse 11.2. So I tried to install Turboprint (trial) to see if it can solve it. But result was the same. After some googling with “turboprint slow” keywords, I found a probable solution: TurboPrint & PrintFab • View topic - Slow printing - Suse 10.1 It seems, that its my case. Ill try to check this out and post a result.

Well done! FYI, those printer configuration changes you made largely reside in /etc/cups/printers.conf

so any time you’re interested in checking out that configuration, you can view the entries contained with

cat /etc/cups/printers.conf