Suse 11.1. dvd drive broken PermissionDeniedByPolicy

Every time I load a DVD, either a movie or a data DVD I have burned myself (so no DRM), Dolphin V1.1 on KDE3 4.1.3 on Suse 11.1, 64 bit always gives me the same error:
An error occurred while accessing ‘dvd_label’, the system responded:
auth_admin_keep_always ← (action, result).

I can’t even look at my old data backup DVDs. What’ the scoop?

I have to manually mount it as root:
root@godzilla2:/etc# mount /dev/dvd /media/dvd

Then, I can look at it.

If I hit the eject button on the drive, I get 3 popup error windows:

  1. klo_media_mounthelper. Unfortunately, the device system:/media/sr1 (/dev/sr1) named ‘[dvd_volume_label]’ and currently mounted on /media/dvd could not be unmounted. Unmounting failed die to the following error;
    Cannot open /media/.hal-mtab

2)Error - artsmessage
Sound server fatal error
Can’t create mcop directory.

3)kde crash handler
Tha application KNotify (knotify) crashed and caused a signal 11 (SIGSEGV). Bla, bla, bla.

Here’s the backtrace info:
#5 0x00007f6dad5acaf4 in KDE::Multimedia::ArtsChannel::setupArtsObjects() ()
from /opt/kde3/lib64/kde3/
#6 0x00007f6dad5ad88f in KDE::Multimedia::ArtsChannel::ArtsChannel(KArtsServer*, QString const&, QString const&, QObject*, char const*)
from /opt/kde3/lib64/kde3/
#7 0x00007f6dad5ab44a in KDE::Multimedia::ArtsBackend::createChannel(QString const&, QString const&, KDE::Multimedia::Channel::Direction)
from /opt/kde3/lib64/kde3/
#8 0x00007f6dae04f75d in KDE::Multimedia::factory::createChannel(QString const&, QString const&, KDE::Multimedia::Channel::Direction)
from /opt/kde3/lib64/
#9 0x00007f6dae050e07 in KDE::Multimedia::SimplePlayer::SimplePlayer(QObject*, char const*) () from /opt/kde3/lib64/
#10 0x00007f6dae2604ad in KNotify::notifyBySound(QString const&, QString const&, int) () from /opt/kde3/lib64/
#11 0x00007f6dae26364f in KNotify::notify(QString const&, QString const&, QString const&, QString, QString, int, int, int, int) ()
from /opt/kde3/lib64/
#12 0x00007f6dae264483 in KNotify::process(QCString const&, QMemArray<char> const&, QCString&, QMemArray<char>&) from /opt/kde3/lib64/
#13 0x00007f6db25748b7 in DCOPClient::receive(QCString const&, QCString const&, QCString const&,( QMemArray<char> const&, QCString&, QMemArray<char>&)
from /opt/kde3/lib64/
#14 0x00007f6db2579b9c in ?? () from /opt/kde3/lib64/
#15 0x00007f6db2579f3d in DCOPClient::processPostedMessagesInternal
from /opt/kde3/lib64/
#16 0x00007f6db257a048 in DCOPClient::qt_invoke(int, QUObject*) ()
from /opt/kde3/lib64/
#17 0x00007f6db3c9f0df in QObject::activate_signal(QConnectionList*, QUObject*)
() from /usr/lib/qt3/lib64/
#18 0x00007f6db3ca1452 in QObject::activate_signal(int) ()
from /usr/lib/qt3/lib64/
#19 0x00007f6db3cbf8c5 in QTimer::event(QEvent*) ()
from /usr/lib/qt3/lib64/
#20 0x00007f6db3c40755 in QApplication::internalNotify(QObject*, QEvent*) ()
from /usr/lib/qt3/lib64/
#21 0x00007f6db3c4153a in QApplication::notify(QObject*, QEvent*) ()

Thank you,

Try adding yourself to the cdrom group.

Do you have the latest version of hal?

rpm -qi hal

Should output 0.5.12-39.1. The latest version should be available via the opensuse updater.

I added myself to the cdrom group. Same problem. The latest hal shown by yast2 is 0.5.12-10.12.1. It shows nothing else available. Here’s my version of hal.

godzilla2:/tera # rpm -qi hal
Name : hal Relocations: (not relocatable)
Version : 0.5.12 Vendor: openSUSE
Release : 10.12.1 Build Date: Tue 20 Jan 2009 09:03:52 AM CST
Install Date: Fri 30 Jan 2009 12:32:47 PM CST Build Host: albeniz
Group : System/Daemons Source RPM: hal-0.5.12-10.12.1.src.rpm
Size : 1813252 License: GPL v2 or later; AFL
Signature : RSA/8, Tue 20 Jan 2009 09:04:10 AM CST, Key ID b88b2fd43dbdc284

Even after updating it, I get the same hal version/release. I added myself to the haldaemon group too.


Try adding yourself to disk. If you check /dev/cdrom, /dev/dvd and /dev/dvdrw, you will see that they are all members of the disk group.

I looked at my working Ubuntu fstab and it had 1 /dev/cdrom0 device in it. Suse didn’t think I needed any. Suse apparently calls them "SR"s (whatever that is). By monkeying around with my fstab and adding these 2 lines, I slam a dvd in and it mounts. I hit the eject button on the drive or drive->right_click->eject from dolphin, and (within a few seconds) it pops out.

/dev/sr0 /media/bluray udf,iso9660 user,noauto,exec,utf8,ro 0 0
/dev/sr1 /media/dvd udf,iso9660 user,noauto,exec,utf8,ro 0 0

godzilla2:/home/brianp/download # grep media /etc/mtab
/dev/sr1 /media/dvd iso9660 ro,nosuid,nodev,utf8,user=brianp 0 0
/dev/sr0 /media/bluray udf ro,nosuid,nodev,utf8,user=brianp 0 0

I wonder why a fresh install of Suse 11.1 didn’t find and install them. The Blu-Ray is a SATA device whereas the dvd is a dumb old 16x, IDE writer, a master on the PATA controller. Hmmm.

In the voice of Ricky Ricardo, “SuuuSeee, you got a lot a splainin to do!”

Thanks for your help,


The explanation has already been given in the forums but I don’t have the link. As I said, you only need to go into YaST>Security and users and add the ‘disk’ group to each user and the problem is solved. Much quicker than making new entries in fstab.