Suse 11.1 and windows 7 install

Hello everyone,
I am having big troubles trying to install windows 7 and suse 11.1 on the same PC

I never had problem when using XP, what I usually did was:

  1. Install XP first, leaving during the disk partitioning an unallocated space for the linux installation
  2. Install suse on the unallocated disk space; linux recognized automatically the windows partition and set the proper mount points for it.

Now I am trying to do the same with windows 7, but I get the message “Impossible to resize the … windows partition due to fs inconsistency”
I don’t know why it tries resizing instead of just mounting, how it used to do on Windows XP.
On Windows I have an OEM partition, a Recovery partition (NTFS) and two others set by me (NTFS and FAT32). I got the PC with windows already installed, the OEM partition should be for the DELL utilities if I have to reinstall, the Recovery partition was also already set.

what makes me wonder is that if I look in disk management the OEM partition has no filesystem type declared, and actually when I try to install linux the OEM partition is not recognized at all.
Could this be a reason for being unable to set the windows mount points?

In this case I should make a complete installation of windows 7 and retry.
If it is a different reason, I cannot imagine what is it. I already tried defragmenting the windows disk or turning off the swap disk space, it did nothing

I really hope someone can help,

I would install windows 7 first and allow it to use the full drive, then use the computer management program in windows 7 to shrink the partition size and leave unallocated free space to install openSUSE in. OpenSuse is usually pretty good about finding free space on the drive. Just make sure before you install that your installing into the correct partition. Computer Management has a disk management option that will allow you to do this. Here is a link that maybe helpful

How to Resize Disk Partition in Windows 7

Almost forgot welcome to openSUSE!!

I would download and burn a copy of Parted Magic and use that to get the output from

fdisk -l

Isuspect you may already have four(the maximum)primary partitions.
And any way Parted Magic goes well in your tool kit!

Nice:) didn’t even think about that, Windoze does root your brain after allrotfl!

I just bought a Laptop (Lenovo G550) with Win7 on it. It had 4 primary partitions (I suspect you have the same) - I just deleted them all, but for you this might not be possible. I have the advantage of have a full win7 dvd.

As has been suggested, post result of fdisk -l from a RoxTerm in Parted Magic
Using Parted Magic an Introduction - openSUSE Forums

the disk partition on windows is not the problem, I did without any trouble, and I got the unallocated space to install linux.
From the error message it looks like it cannot mount the windows partitions, but the free disk space is there, it should find it.
The only reason I can think on is that OEM partition, which has no filesystem type associated to it, the others are NTFS and FAT32, they are recognized, but suse tries to resize them instead of mounting.
What I cannot do is a complete new installation of Windows 7 (which would get rid of the OEM), since I have only the re-installation dvd.

I ll try with Parted magic anyway
(thanks for the suggestions)

Post the fdisk info and we can tell you more…

Yeah that is odd, I had the similar partition setup when I bought this machine but never had an issue dual booting.

The only reason I can think on is that OEM partition, which has no filesystem type associated to it,

fdisk -l will show it,it will be a ‘hidden partition’.

I tried fdisk -l with parted magic and I got the following

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/tracks, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf8000000

Device Boot Start End Blocks Id System
/dev/sda1 1 10 80293+ de Dell Utility
/dev/sda2 * 11 1020 8108032 7 HPFS/NTFS
Partition 2 does not end on cylinder boundary.
/dev/sda3 1020 32891 256000000 7 HPFS/NTFS
/dev/sda4 32891 36970 32768000 c W95 FAT32 (LBA)

the only thing that looks odd is the message after the second partition, but that should be the recovery partition, it was already there and I left it untouched

You need to resize the partition, certainly not mount it.
fdisk -l will give the info needed.

You have 4 primary partitions!

You can not resize a partition to create others,you need to save data from a partition and delete it to create logical partitions on the extended that needs to be created.
Bring on Parted Magic!

I assume sda3 is your actual windows install
sda2 looks like the boot parttition, hence the *
sda1 is some dell rubbish

delete sda4 and recreate it as an extended partition taking up all the free space
Then create logical partitions inside your new extended partition - An extended partition is just a container for logical partitions.

well, I wanted a FAT32 partition to be able to transfer some data from linux, I guess I cannot delete the Dell stuff, but do I need to create an extended partition from windows?
what I did with XP was to leave some free space unallocated to install there linux. The problem I have now is that linux wants to resize the windows partitions instead of just mounting them, and I don’t understand why.
I am afraid it is because of the Dell partition (which is not recongnized when I try to install linux), in this case a new windows installation would be the only solution

You should be able to override the suggestion using the expert mode.

Even though you can resize a partition,you can not use the free space from that partition to create new partitions because you already have 4 primary partitions.
This is why you need to delete a partition and create a new one as an extended primary,after you have done this you can create a number of logical partitions inside your extended partition.

my bad, did’nt realize that they were 4 primary partitions, I thought the FAT32 one was a logical one
If I have an extended primary that I subdivide in 2 logical ones, can these 2 be formatted as NTFS and FAT 32?
My problem is that of those 4 partitions, 2 cannot be touched, one would be for linux, and the remaining one is where I should re-install windows
If I want a FAT32, it has to be as logical partition next to the one where windows is installed.
I am thinking on ordering a complete windows 7… (it’s the university money, who cares)

If I have an extended primary that I subdivide in 2 logical ones, can these 2 be formatted as NTFS and FAT 32?

Yes , but you need to delete one of your current primary partitions,and continue as suggested.

Actually you do not "subdivide"the extended but create logical inside it.There can be many logical partitions inside your extended.