suse 11.1 24 hours

It is holiday season, I have time to play my Linux system

Two days ago , I did install Suse 11.1 on my notebook (old system was Suse 11.0)

My computer is notebook HP Compaq 6910p:
Ram 4G
video card: ATI X2300

Anyway, I did fresh installation with Gnome and KDE4. The installation seemed very good and very fast (took less installation time than any old Suse system). Normally, the problem I may have after installation is about wireless and video card.

---- Wireless worked automatically after installation ( like Suse 11.0 ) , great.

---- Since there was no ATI repository for Suse 11.1, I compiled ATI driver for my system as rpm and installed it. It worked well . For Suse 11.0, you can install ATI from YaST, but not Suse 11.1, now.

Then , I found the big problem.

During installation , I used power from plug for my notebook. When removed the plug and used battery. I could not use my computer:

Suse 11.1 starts very normal until login window. In fact “login window” would not show up, just nothing on screen . I have to “turn off” computer by press power button…

I believe that it was x window could not start…

Anyway, I could not figure out how to fix this problem, What I did was :

remove Suse 11.1 and reinstall Suse 11.0…

From installation to installation, it took me 24 hours.

Welcome to our forum.

Next time, you run across such a problem, why not first post to our forum looking for help, before you roll back to an older version of openSUSE ? While in the most part we are a volunteer forum, we do have some knowledge volunteers on this forum.

Just an FYI. I have one system that I just updated and when booting, the screen goes blank for a full 60 seconds. The pc seems to be locked up with no disk activity. But, after nearly a minute, the boot continues normally. I shut the machine down a least a half dozen times before I got distracted by something and turned away for a minute to find that when I came back, the boot completed. :\

Thanks All:

Problem of Suse 11.1 in my notebook was nothing on screen when the login window was expected to be there and it only happened when it was booed from battery …

It was normal if booted with power from the wall plug.

It may relate with power saving in x window or with ATI driver, I am not sure about this.

I didn’t try the system without ATI driver.

Since I have to use my notebook to do my work, no time to try more.

I have been using Suse for about 6 years. It is the first time for me to have installation problem and have to remove it.


I have experienced the same problem and additionaly I have tried without ati driver too.
If it was connected to the wall plug than the screen was ok. 3D effects were working everything was ok. When I started the laptop with only battery I got a big white screen, nothong else.
Aaand check this out, when I booted with wall plug that was ok, than I removed the charger for result the 3d effects have gone and when I connected the charger again the whole system was frozen. No mouse or button reaction…nothing, only with the power button I could shut down the system. :frowning:

I got the same type of laptop. HP 6910p with ati card.

Hi, Kistj:


Yes, you did more test than I did. However, we have got the same conclusion: cannot use SUSE 11.1 in Compaq 6910p.

I am not sure that this problem is really only for this model or also for other laptop. Maybe , we should post this message as cannot start Suse11.1 from battery …not like my title: 24 hrs.


Hi gejeff,
I couldn’t stop trying to get it work, and my workaround is quite simple…
During the install process I have removed the “Desktop Effects” patterns all together. Now it is working nicely and stably with battery and with the charger too.

If you think give a try for it. :slight_smile:


Hi, Kistej:

When I was installing SuSe 11.1, I did not select or unselect any
“Desktop Effects” , I just used default setting ( with “Desktop Effects”)… If I understood correctly, it should be unselected and then should work even boot from battery.

Great and thanks. Hope that I will find time to retry, It seems to me it will not be this year — 2008. I have so many things to do and to finish.

Thanks and have a good new year…


Hi gejeff,
Yes, you understood absolutely correctly.
Good luck for your doings and happy new year.

Thanks for the workaround/tip… I will try to reinstall it in my daughter’s laptop (is the same model as yours)… Probably I will succeed this time :smiley:

Happy New year


I have had the same problem on my Compaq 6820s.
Under 10.3 I had no trouble with compiz-fusion, although I couldn’t watch videos while it was turned on.
Under 11.1 I can’t boot on battery, and if I disconnect the AC cord the screen distorts and the laptop apparently locks hard.

I suppose I’ll try it with desktop effects turned off again…