[SuSE 11.0] Windows installer uninstall problems

Hello to everyone!

A few days ago I installed SuSE 11.0 using the Windows installer in MS Windows Vista, which concluded its actions as it should and was expected – it copied the SuSE installer and added an entry in the Vista bootloader. Afterwards I successfully installed the OS and everything was fine fine.

Then I booted back to Vista, and the uninstaller autostarted, but could not complete its actions becouse of the antivirus blocking it (Kaspersky dela burek). And that is sad. No big deal; both operating systems work as they should. With one minor adversity …
after Grub loads and I select the Windows entry, the modified bootloader menu shows up with two entries, “Windows Vista” and “SuSE 11.0 Installer”, where the second entry is not in function as the installer uninstaller deleted the files it pointed to.

I tried the first thing a good christian would, to reinstall the installer and then uninstall it correctly without Kaspersky interfering. But the installer said it could not execute bcdedit.exe. Nice. A minor inspection in the command terminal, reveals that it can not load due to …

The boot configuration data store could not be opened.
The system cannot find the file specified.


Funny stuff.

Then I tried a third party BCD editor (VistaBootPRO 3.31), which proven itself useful only in reminding me THAT MY BCD IS ****ING GONE! Like six times only during startup and then every time I selected an option.


Even tried some sort of build-from-scratch selection, it offered, with no visible changes to the way my system loaded whatsoever. Then I tried another third pary BCD editor (Easy BCD 1.7.2), which could not even recognize the system partition (guess its more of a Grub problem, this time) … aaaand I gave up. Although there is another option, that could do the trick – the Windows Vista recovery console. But then, I guess this would generate even more problems as it sure would delete the Grub installataion from the MBR and then I would have to reinstall and reconfigure that one.

Any further suggestions? http://joker.si/mn3njalnik/style_emoticons/default/online2long.gif

I feel your pain.
And, that’s partly because I ran into undocumented Vista bootloader problems myself when I dual-booted two Windows OS (not a Linux OS) awhile back…

And unfortunately although I was able to work through the problems getting it to work I can’t promise the same thing for anyone else because there’s just so many complex issues to consider… You need to know your arcpaths, assigned drive names, and be able to figure out the syntax of the statements to get the database configuration set right.

So, I recommend one of two approaches…

  1. If you decide to continue to use the Vista bootloader to switch between OS, be willing to spend time researching and learning what I just described. You may still end up having to take the machine to someone with enough knowledge in the end.

  2. Use the Vista Repair console to restore your Vista bootloader to original OEM and follow the posts in this forum that describe how to configure the SuSE Grub bootloader to switch between OS.

IMO the second option is the easier if you already know the first is over your head.


In openSUSE run fdisk or cfdisk and look at which partition has the bootable flag set. You may be getting that error because the Vista partition’s active partition is not set. You can also use bcdedit to rebuild or modify that database, the commands reference is here BCDEdit Commands for Boot Environment. Or you can use the Vista RE to fix it.

Once done, getting openSUSE bootable is pretty easy. You have several choices. If openSUSE is on the same drive and /boot is located on a primary (i.e., not a logical) partition, you can install grub in the openSUSE partition boot sector and then change the bootable flag from the Vista partition to the openSUSE partition; the Vista MBR bootstrap will boot openSUSE. Or, you can install grub in the openSUSE root partition, even if it is on a logical, and use EasyBCD to create a bcd entry for openSUSE, and the Vista bootmgr will boot openSUSE. Or you can have grub take over the MBR with a pointer to where openSUSE is installed, and then chainload back to Vista to boot it (that is what you probably originally had); it easiest to do this with the DVD Repair Module (it can also be easily done from the grub shell in the live-CD or DVD Rescue Mode, if need be).

I had a similar problem triple booting Vista/XP/OpenSuSE11 and Vista Boot Pro (I think that was the title) was suggested and worked fine. I will double check the title when I get home tonight - it was free.