Suse 11.0 on VMware Workstation 6.0.4

I installed Suse 11.0 on a VMware Workstation 6.0.4; however, I ran into problems when I tried to install VMware tools. It seems Suse 11.0 contains a preinstalled version of VMware tools, and this has to be uninstalled before installing the VMware original version. However, I do not know how to do this, i.e., uninstall the preinstalled VMware tools modules. Can anyone help, please?

I’m running openSUSE 11.0 in VMware WS 6.0.4 on a openSUSE 11.0 host, and I’ve had no problems w/ the pre-installed VMware modules that openSUSE included - if you want the VMware provided tools, fire up YaST in the guest, go into Software Managment and search for ‘vmware’ and mark all the installed packages as Taboo - then apply the changes and you should be clean w/ no VMware modules and will be free to install the VMware provided tools.


How did you install the VMWare kernel modules in the most install.

I get this error:

Your kernel was built with “gcc” version “4.3.1”, while you are trying to use

“/usr/bin/gcc” version “4.3”. This configuration is not recommended and VMware

Workstation may crash if you’ll continue. Please try to use exactly same

compiler as one used for building your kernel. Do you want to go with compiler

“/usr/bin/gcc” version “4.3” anyway? [no]

If I proceed, I simply get these errors when starting a guest machine:

Could not open /dev/vmmon: No such file or directory.

Please make sure that the kernel module `vmmon’ is loaded.

Failed to initialize monitor device.

Unable to change virtual machine power state: Cannot find a valid peer process to connect to.

Failed to reply to the dialog: Pipe: Read failed

From the command line;
su -c “zypper remove open-vm-tools”

If you want to go GUI, go to YAST / Install Software and search for open-vm.

Then install the VMWare ones.

For the poster above, you need to answer “yes” to using GCC 4.3 - the VMware configuration script is confused by the new GCC versions. Just type y/yes everytime it asks for it - if you do not do this, it won’t compile and install the necessary drivers for the system.

Thanks for your reply. Unfortunately, I have not been able to make the preinstalled vmware modules to work (I checked memory sharing: there is no hgfs item in /mnt; and I cannot get a decent resolution). Alas, up to now I have not been able to get the proprietary modules to work either: I get a bad compiler version message, and no module gets loaded.

Ignore it, continue, let it build. is too dumb to figure out that the gcc-4.3 package is in fact 4.3.1. Works here.

Actually I can’t build either the open source or distributed tools because of the stupid compiler. This is one of the worst dot-0 release of SuSE in history. Something like this is just butt stupid. So how to compile the tools without downgrading the compiler?



I just went through this today. For some reason I had downloaded 6.0.3 workstation first. While trying to run I had the same compiling problems as above.

Instead of downgrading my compilers, I downloaded and tried 6.0.4 and it worked great first time.

I think I read on another forum that if you want to use 6.0.3 with opensuse 11 you need to use the any-any patch. I can verify that the any-any patch is not necessary with 6.0.4.

The only thing I am having trouble with is sharing a directory on the host with the winxp guest.

Hope that helps

As far as concerns my problem, I was able to get vmware tools to work following the instructions in the following thread:

VMware Communities: opensuse 11 - unable to install vmware …