Suse 11.0 Linux<=> Windows Problem

You can put anything you like here: netbios name = LINUX-U719

I forgot to mention that after major changes, to hurry communications up and get things settled you can do this: restart Suse completely, restart windows completely, restart Suse completely, restart windows completely.

I made the changes you suggested(conf. file,removed 192.168.1.0 from hosts allow)…,even turned off both suse and xp firewalls,but still from XP could only get a list of directories)homes,Profiles,Printers.

Soo,I have to look somewhere else for the problem,now that you’ve supplied the “perfect” smb.conf file. lol!

Can you show us the results you get from these five diagnostic commands entered in a normal user console window:

  • rpm -qa | grep samba
    That tells what software is installed
  • smbtree -N
    that tells what servers Suse sees
  • cat /etc/samba/smb.conf | egrep “netbios|string|master|order”
    that tells about a few things in smb.conf
  • sudo pdbedit -L
    that tells who is in the Samba user database
  • sudo /usr/sbin/rcnmb status
  • sudo /usr/sbin/rcsmb status
    those two tell whether the Samba daemons are running

On Wed April 15 2009 05:46 pm, itpro007ca wrote:

>
> I made the changes you suggested(conf. file,removed 192.168.1.0 from
> hosts allow)…,even turned off both suse and xp firewalls,but still from
> XP could only get a list of directories)homes,Profiles,Printers.
>
> Soo,I have to look somewhere else for the problem,now that you’ve
> supplied the “perfect” smb.conf file. lol!
>
>
itpro007ca;

I had planned to sit on my hands here, but I can not resist. By default XP
will connect using your Windows log on name and password. Unless these are
identical to your Samba name/password, you are probably connecting as guest (
i.e. Bad User). As guest you do not have access to [homes]. You can change
this behavior in Windows. To test this, try creating an XP user with the
same name/password as you have on Samba( the one set with smbpasswd -a). You
should see your home directory and be able to access it.

I will now step out.

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

Well spotted…


samba-client-3.2.4-4.3
yast2-samba-client-2.16.9-3.1
yast2-samba-server-2.16.3-15.1
samba-3.2.4-4.3


read_socket_with_timeout: timeout read. read error = Connection reset by peer.
Receiving SMB: Server stopped responding
failed tcon_X with NT_STATUS_INVALID_NETWORK_RESPONSE
read_socket_with_timeout: timeout read. read error = Connection reset by peer.
Receiving SMB: Server stopped responding
failed tcon_X with NT_STATUS_INVALID_NETWORK_RESPONSE


netbios name = LINUX -U719
preferred master = Yes
domain master = No


richard:1000:richard

Checking for Samba NMB daemon running


Checking for Samba SMB daemon running

Switch off “hosts allow” line and if it fails again then post the smb.conf

I just ran some tests. If I have this: hosts allow = 192.168.0 I get your error message. If I have 192.168.0. it works. So – did you forget the final period?

Where is the “hosts allow=” line.According to the smb.conf file you gave ,it isn’t there?

No, it’s not here. I thought because of the nature of the error that you might have put it in according to my earlier post. So do a listing of smb.conf (e.g. cat /etc/samba/smb.conf) and post the result here.

Here it is:

smb.conf is the main Samba configuration file. You find a full commented

version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the

samba-doc package is installed.

Date: 2008-08-27

This is a Local Master Browser and the Preferred Master

[global]
workgroup = MSHOME
netbios name = LINUX-U719
name resolve order = bcast host lmhosts wins
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
use client driver = yes
map to guest = Bad User
local master = yes
preferred master = yes
os level = 65
usershare allow guests = Yes
usershare owner only = False

[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes

Share disabled by YaST

[profiles]

comment = Network Profiles Service

path = %H

read only = No

store dos attributes = Yes

create mask = 0600

directory mask = 0700

Share disabled by YaST

[users]

comment = All users

path = /home

read only = No

inherit acls = Yes

veto files = /aquota.user/groups/shares/

[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0700
guest ok = yes
browseable = No

Share disabled by YaST

[print$]

comment = Printer Drivers

path = /var/lib/samba/drivers

write list = @ntadmin root

force group = ntadmin

create mask = 0664

directory mask = 0775

That’s a bit different from the one that had the line “domain master = No” in it. Did you restart the Samba daemons after changing some content and before running smbtree -N? Puzzled…
In any event, after editing smb.conf you should restart the Samba daemons, either by running these two commands:

  • sudo /usr/sbin/rcnmb restart
  • sudo /usr/sbin/rcsmb restart

and wait 2 minutes
Or by rebooting the computer.

I suggest you:
put this line in the [global]: server string = “”
and then reboot Suse and then windows and then look in windows network browser for \linux-u719. You might see richard as a share or not, depending on history. If you do, drill down into it. If you don’t, then use this address: \linux-u719\richard

I don’t see the “domain master=no” line in your smb.conf. file I reposted.

Yes,I’ve run the restart smb and nmb and restart firewall commands everytime I’ve made a change.

Nice,that I can just copy and paste commands(new to me!) straight into the terminal! lol!

btw: I tried following your “simple samba shares on the fly article” to see if that helped -it didn’t.

I see in XP’s Network Places browser,it shows the windows shares and local and linux(homes and profiles) as "internet."Also for linux-u719 under the computer column it says “unknown”

Also,one time,view workgroups brings up “Samba Server…” and “Winbox” then another time,it gives me the old “Mshomes is not accessable…”

You said:

I don’t see the “domain master=no” line in your smb.conf. file I reposted.

I was talking about this set of results:


netbios name = LINUX -U719
preferred master = Yes
domain master = No


When you had the line “domain master = No” in there. But I suppose that’s too far back to consider now.

OK
Please go to Yast –> Software –> Online Update and do a full update.
Also turn off all electrical devices including computers, modems, routers, switches, whatever and restart them.
Do you still get the error result from the command: smbtree -N. If you don’t, copy here what you get.

Finally, in windows network browser (My Network Places) you have an address bar at the top. Type in there this address:
\linux-u719\richard.
What happens?

1)I did: YAST>>>Online Update>>>Update all packages,if needed(had a few conflicts had to say do not install to)…

*Wow!Quite a different looking system!

2)smbtree-N :

linux-u719:~ # smbtree -N
MSHOME
\WINBOX Windows Computer
\WINBOX\SharedDocs
\WINBOX\IPC$ Remote IPC
\WINBOX\My Documents
\LINUX-U719 Samba 3.2.4-4.3-2042-SUSE-SL11.0
\LINUX-U719\IPC$ IPC Service (Samba 3.2.4-4.3-2042-SUSE-SL11.0)

That’s better!lol!

3)NOW:

Wait for copy and paste from XP -in next post -before u reply

1)My Network Places:

H
Homes On Samba 3.2.4432 >>>Linux-U719

M
My docs… Windows

P
Profile on Samba…

S

Sharedocs on Windows

2)Clicking view workgroups shows:

Samba 3…and Windows Computer(Winbox)

*clicking on the Samba .3.2…icon shows me “Printers and Faxes”

3)\linux-u719\richard

result: Windows “Connect to Linux-u719.site” logon box

4)\linux-u719:

“printers and faxes” icon

For this one: 3)\linux-u719\richard
Do you see all your Linux home file tree once you supply the credentials richard and richard’s Samba password into the logon box?

I typed:

Username: linux-u719\richard
password: linux pasword

but it won’t let me in

Forget it,SWERDA,I’m in!

I forgot I gave a DIFFERENT Samba password -btw: Can I change it to be the same as my linux login password and if so,how?

Finally!

"I’m flying high…highhhhhh! (sings an old pop song…!)

Linux>My Computer>Network Folders>Ms Home> Linux-u719 and Winbox>Winbox>Mydocs -this can’t be happening! Whoohoo!Just tranferred 2 docs to “Documents” so I could double-click that directory in Windows and see them -works fine!

btw: Winbox: I see “Bin” “Desktop” “Documents” and “Public.html”

Yes you can change the password by opening a console and entering: su — to become root and then this:

smbpasswd -a richard

I’m leaving now for couple days. Others will have to help you with any more Qs.

Glad you’re in!